forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-plugins/kodi-visualization-goom: 19.0.0 version bump
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Craig Andrews <[email protected]>
- Loading branch information
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kodi-visualization-goom-19.0.0.tar.gz 1217302 BLAKE2B 7e7092d47a176cb25930616eed696023541e2e056efdb9b0cb0396763f761ec34d3c38f5c95540408dddb14d26ca9f95817b6bba12931485046f3081bbb17cd8 SHA512 199fb3dfb03f2874b5cf6df33fd29de3727026c98a7115333db2f19fa880a723930a1b8336ab125f769928af1e823b01fbdaeb66ee02f673c77d68cc61b84f13 | ||
DIST kodi-visualization-goom-3.4.0.tar.gz 1210534 BLAKE2B c871188f50a1deab108e36e4199dc4d0450ddb59cf8f87090505b46f7494a66006b796d4a7c60e61057f8668dc7afebbab15e1018ed8fa644d77315ea8b3c2be SHA512 d864932202b2611b435b91a0ced86cc60b5e1853dfa958651a7327e931d7744b267d4a151f1a8e1d8080f37c009b6bc5d22ca9cef5bf2f9cecc8d4a114fa1971 |
45 changes: 45 additions & 0 deletions
45
media-plugins/kodi-visualization-goom/kodi-visualization-goom-19.0.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit kodi-addon | ||
|
||
DESCRIPTION="Goom visualizer for Kodi" | ||
HOMEPAGE="https://github.com/xbmc/visualization.goom" | ||
KODI_PLUGIN_NAME="visualization.goom" | ||
|
||
case ${PV} in | ||
9999) | ||
SRC_URI="" | ||
EGIT_REPO_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}.git" | ||
inherit git-r3 | ||
DEPEND="~media-tv/kodi-9999" | ||
;; | ||
*) | ||
CODENAME="Matrix" | ||
KEYWORDS="~amd64 ~x86" | ||
SRC_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/${KODI_PLUGIN_NAME}-${PV}-${CODENAME}" | ||
DEPEND="=media-tv/kodi-19*:=" | ||
;; | ||
esac | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
DEPEND+=" | ||
>=media-libs/glm-0.9.9.8-r1 | ||
virtual/opengl | ||
" | ||
|
||
RDEPEND="${DEPEND}" | ||
|
||
BDEPEND="virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
if [ -d depends ]; then rm -rf depends || die; fi | ||
|
||
cmake_src_prepare | ||
} |