Skip to content

Commit

Permalink
dev-ros/ament_cmake_gtest: bump to 1.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Mar 15, 2022
1 parent 284117a commit 9bc0416
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ros/ament_cmake_gtest/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ament_cmake-1.1.4.tar.gz 94117 BLAKE2B 612bf25301b9794cf51b460819cf4a029547fbc97f7a428215a19f0a7747115de02d3f2cb5f5e524e73ba30813388ca7bff059ab7fe472916eaf2b23ecc76355 SHA512 56acd3d2a8d4b15a164dfdcaa2157fff2889a4c5c0b155ad65a815760f531cdf10226d158f40fc15660c52dd1585b85a2566e402f31881378351624f286efb3d
DIST ament_cmake-1.3.0.tar.gz 103040 BLAKE2B 8220d380923a591667b3b4bbe785f30ac935ce10c4fd6bf8bd22149586373f353cd9e71723638dca503bd54ff709783ea1e133c5034901fe2d891fd6bbe7c560 SHA512 44f71102e22fe9f6cd8c3cc13960d63af377eec0a6f7fb7ae99c18f2afae07f3997c9f226f7db8cc8020acdf45561ad9eb1006c6834125d6da137e8638617df8
46 changes: 46 additions & 0 deletions dev-ros/ament_cmake_gtest/ament_cmake_gtest-1.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..10} )

inherit cmake python-any-r1

ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_cmake"
SRC_URI=""
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
fi

DESCRIPTION="The ability to add gtest-based tests in the ament buildsystem"
HOMEPAGE="https://github.com/ament/ament_cmake"

LICENSE="Apache-2.0"
SLOT="0"
if [ "${PV#9999}" != "${PV}" ] ; then
PROPERTIES="live"
else
KEYWORDS="~amd64"
fi
IUSE=""

RDEPEND="
dev-ros/ament_cmake_core
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"

python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}

0 comments on commit 9bc0416

Please sign in to comment.