Skip to content

Commit

Permalink
app-portage/metagen: 0.6.3 (fixes bug #561908)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
hartwork committed Oct 30, 2015
1 parent 4775fca commit 9bebd56
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/metagen/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST metagen-0.6.2.tar.gz 6100 SHA256 d1f6c7a24fa9f7f119c9309ed2ec217bc0fd3da48568417a46220a40e2c74201 SHA512 0ab8d7755259b870c995c471f366a976f4acc336dda4c2fa1c4e5b78b5aa701fb75d4dd88ac0ee069a231550b07b89b4a8f724c94ec791efe6c4c64b97ac19ff WHIRLPOOL fa6b85934e58cc5b73237fb619d64bd87df148b8f70fa5df2bbf94ef986f1ea3e693b7e3eb25b56cbe26fe35fff5102ba5787a22ec94800d3d328ccc9606473c
DIST metagen-0.6.3.tar.bz2 6118 SHA256 655253786c3dafe2426a61d8585acfbbd4a560e0a2609331e230c72699b10494 SHA512 1a25e1ebd35ae97e0823aee2f929c09b9041c78496c2425cf5c0bf3d9f1747313dcf30b7e0a5d4e861cbd0caaf48b506f85eb5f25ab0b9e75a62514b0bb64ecd WHIRLPOOL 5e0c594ad728b6646a324d7c8115ad19f15304baad1922fb45e96a771355092e43ba3ae98f0f44e87f2c8e9d74af5ee75c09e86472329e1497dd81959467f927
35 changes: 35 additions & 0 deletions app-portage/metagen/metagen-0.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

DESCRIPTION="metadata.xml generator for ebuilds"
HOMEPAGE="https://cgit.gentoo.org/proj/metagen.git"
SRC_URI="https://cgit.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"

IUSE=""
DEPEND=">=dev-python/jaxml-3.01[${PYTHON_USEDEP}]
>=sys-apps/portage-2.1.9.42[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"

python_install() {
distutils-r1_python_install
python_newscript metagen/main.py metagen
}

python_install_all() {
distutils-r1_python_install_all
doman docs/metagen.1
}

python_test() {
"${PYTHON}" -c "from metagen import metagenerator; metagenerator.do_tests()" || die
}

0 comments on commit 9bebd56

Please sign in to comment.