forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
virtualbox packages: Bump to version 5.2.2
Closes: https://bugs.gentoo.org/635542 Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Lars Wendler
committed
Dec 19, 2017
1 parent
30fc8a5
commit 9bf4389
Showing
12 changed files
with
1,121 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST VBoxGuestAdditions_5.1.26.iso 59496448 BLAKE2B c2ea9dac192b09efb41daf57fd12541fc86ae13a21eb5650e2b2bb2256c13b3cfd00f0020d12d92eaa3dead9b3a7928cf766be7d58e2e2b7d5116d5b0d7d7c9c SHA512 5329ce9bb787efed088a9f89412974cef3a982a351c0053b3daf15a9c95c55f99556e2b86cdcd39c168042503eb00eaa83fb99f8f5c4c97d177dd2b61bb33f5d | ||
DIST VBoxGuestAdditions_5.1.28.iso 59494400 BLAKE2B fe91d8c7bf04e8eced7003f954879d25802e6afb8e7cb51f422ac2949845d394eeea252b1b5771731757827e3090226bddaae82c79c238e5f83611fcd05e85a7 SHA512 68a1bcaa658bff040d18c5d59fe20bb0e6155186bdaea5cf30d673d8356fa33087a23280f3d571742ca1c144caef421d0c32a080fee0cb05c6046f361fbe2785 | ||
DIST VBoxGuestAdditions_5.1.30.iso 59494400 BLAKE2B 37f70eb8dd17e0492a106fa5e2cea1ed93b0a0a955e75a3a32d5bd45c447c6c4ff8e78e13b19922a34e8e982d1de5bbf0815a8e81c2a8ea2596477318d7acbf5 SHA512 3205444339a0c85a3b234ba462add21033b5b3eee18eecc15b150b21f5f9f1aadb92b7049bef6be1201e1acfd1edd6f2924c38d56a52770113c8401bcca9abcb | ||
DIST VBoxGuestAdditions_5.2.2.iso 60481536 BLAKE2B 560dc43a901cfaad4d9d6ca6f065614751765de7d78575c0dfe7d8ebcb0bf828a2b676ae91f6b346f179065e0f093e54742821c8a60765ec347d07288ae7b9fe SHA512 3c75468821287e4abe80e319ea8d4cd66c3075061610f74619c474b8c5bd8542ab55fe8747cb710e34863fcbc056b03c9256ad7d4b32fe9b0b56d74c4d93f3b5 |
35 changes: 35 additions & 0 deletions
35
app-emulation/virtualbox-additions/virtualbox-additions-5.2.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit eutils | ||
|
||
MY_PN=VBoxGuestAdditions | ||
MY_PV="${PV/beta/BETA}" | ||
MY_PV="${MY_PV/rc/RC}" | ||
MY_P=${MY_PN}_${MY_PV} | ||
|
||
DESCRIPTION="CD image containing guest additions for VirtualBox" | ||
HOMEPAGE="http://www.virtualbox.org/" | ||
SRC_URI="http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}.iso" | ||
|
||
LICENSE="GPL-2+ LGPL-2.1+ MIT SGI-B-2.0 CDDL" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
RESTRICT="mirror" | ||
|
||
RDEPEND="!app-emulation/virtualbox-bin | ||
!=app-emulation/virtualbox-9999" | ||
|
||
S="${WORKDIR}" | ||
|
||
src_unpack() { | ||
return 0 | ||
} | ||
|
||
src_install() { | ||
insinto /usr/share/${PN/-additions} | ||
newins "${DISTDIR}"/${MY_P}.iso ${MY_PN}.iso | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,12 +1,16 @@ | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.26-117224.tar.gz 19624237 BLAKE2B 593d70c49e47b49cc64d1c4c8f78703e6cd608f4ef6ab836492822429d213c1b70323cfe7847a206d284821572431423a841e8d802a3f47519818906cee63e39 SHA512 c6e31e8fb26b8ca32c423d14e85e15f6372a030ec40e9f06ce1e1234913d3586cc58d46819684c99cf3ced37f35d0a964339199cad5cf43580c88bf1afa63ef6 | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.28-117968.tar.gz 19626161 BLAKE2B 0f2677cfd4e29b3178f750c932747983267de980d9bef58c6e4937829f835f57977f3bedecb358f2bb1fd8d84d5ae1ef1bf4f38cb0d459f752e9542ad3543f5a SHA512 71c6ce267c14303bbd9e386ea849d37aeb569afff848054deced4c74fd6fffca83c96b392d066f684b7101a786cc7d24cf9308114c08cbb77b26bb07bf23fcf8 | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.30-118389.tar.gz 19624724 BLAKE2B de52acef8ad0785e576b361721d3a2f0b3d7e3820964d7e47fb6ffa7fd33bc4126f0e496396a412994e5eadc17fbd72699295865aa520f5e4b7a8ca53007e905 SHA512 6b468879f0fb6d6f916c40fb60f418457c526c20ebb1a6253bfc38392e0ae965e3b54590173b0d974070ced1646db82035950fb7dd54b22e20f4ad29850d6cf4 | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.2.2-119230.tar.gz 19504049 BLAKE2B ff3be5b81c409c33d7c831e2bba6df7d7ab87e6422d8cc4cbc3599f75c84100fceec5547b8f9b44d204941b48102a23a4c2183340ec017159ae7c37e07d21813 SHA512 cf3f08f7ee966b5a991fe029b3d4014f333678f0fddb9d75589695811dc4d780651a6dbdddf55a6466631bf8a9dce099256468490847229ac2c26dba9fc57d27 | ||
DIST VirtualBox-5.1.26-117224-Linux_amd64.run 87981522 BLAKE2B a1067daca90eb45509aa314d8e346f565cca845c8ec2fdbe6d27ec6d12e4cf6a288638a083295da62858bcda44b2f97720475b246e9e03013ab68c9c5e191720 SHA512 9b486fd52918469fdffaa39bbef234d22fad9d3b562fa04443bf6c1040e744db6dc9bd103ead299127b82c5d4bc96c1e05f677cacd623affa6569408c8d26df5 | ||
DIST VirtualBox-5.1.26-117224-Linux_x86.run 87090639 BLAKE2B 89ec5ed5a9c0a5c16fbe4e3bbab5035c027d1c24ca561536a9c7e1924a5b7b5ddd180aa798212a3dc213439dc844761b73212d7fb1ed7611b0a91b078e96c950 SHA512 3aafad5374dc79c0fdd9bf1da6708ae4ce2f43d9fce3222326424bf03d6b73a7283ba5ebeb01a9ab6b24eeb8a8ec7c23af84e40f3edeb512c2101c329f4091e7 | ||
DIST VirtualBox-5.1.28-117968-Linux_amd64.run 88391123 BLAKE2B 4fbabed2d0d1a7d61e734818003048e58e9763eee5ba46b7653ee0f0efa13bd7830cce6bcf607dd09559dffbf5352f1ae21729e86f049067063e3a2426f602dd SHA512 e84f002ed4804533832dfcc65f12ad4e72d6693de5af62bf26b702d19d8f17511335415968eac44ee3d98e87d5137c0004afa213b0bf75b89699cbe3bc20097c | ||
DIST VirtualBox-5.1.28-117968-Linux_x86.run 87582159 BLAKE2B 39e9c8b222ee284d678022a09fca0d0214a116b97fefbc73248bb7bba4d7ccc323619fa93e1bf2c719dee00ac17cb21da86c1f1155ad88ca52301bcdb42c9fb9 SHA512 96491961bfae60671b40f591151da26dab3135feaa3b9cf3838d7e74104cb4ae716eb5ff76ab75683c98ffba840cacaa045fa959f8e4eb4ab976801d38ebb917 | ||
DIST VirtualBox-5.1.30-118389-Linux_amd64.run 88186323 BLAKE2B 4700613906658a223134130e99eb4f669ffc875e732e9b43d237926b9a33d385d6056240ae5f498d13b6a0cf26c600b293657fc64c838db498bd3935fa23a8e4 SHA512 b6312abbf5c0e4bf22aca50a81d297a0ed21d5b4b72242e21750ac088c56817dc90ac1ae068dd9006f4f736130510f26f55793b8c09999c590da09908e304280 | ||
DIST VirtualBox-5.1.30-118389-Linux_x86.run 87397839 BLAKE2B cc0fb245f98883dc19cfc9a64d8c7a9593d8ae784895a9a8224c146779ab65901052ba5d62f57c9cd5bc46d23e208cc97046fd6641eb8848e90c4828bd745813 SHA512 643ef90453e3a6a6d3fbb365176a72de1743230a58ee45f1cb22fd8bb57c9cfe6013ec1ffdb0076a248d1987a1e3fea13ca71ef9ca983cb8e6378d30c76451fb | ||
DIST VirtualBox-5.2.2-119230-Linux_amd64.run 90346949 BLAKE2B f6ae64b7b9b5ad41865a12792bd611d05c8899250c1740fcfabc0c6c07ce495e143b29c8bc8b5b2c2dbe690076c8593c030de4374af9d31a82e99dc9c58fec40 SHA512 a99d0922b341b821976bc944a5882d2804ca7ceb565a9512ce86c3968fb0d27dc533009dde51bea4881d729c97277597d329927183be4ffd081b5ed73c8f5ec3 | ||
DIST VirtualBox-5.2.2-119230-Linux_x86.run 89548224 BLAKE2B de4cfd7a21caa49bc5752bfe097e99ec5e55eb9abcfafc34eb9f74e88c12fb6d0af1754e88180daf7f420ca3b968a25a3a0d6b878ebe6f7eb51c543ed24fbb1d SHA512 cd83828fdde57ac6c9b1bed58a8500c7ad2d2e83b83a4ffe304addd1d5df277dbddebc1e9c779030e5352b66b6a7505309fb0b5cfbbb575f122a7f126c397591 | ||
DIST VirtualBoxSDK-5.1.26-117224.zip 9860247 BLAKE2B 6525792471a71aca9824e2fa9a0c9b722f248bf4873f3f683a04ab335bb06257fd051e1baeb2c106d663c09e805f88784bb01614042660949566766002183b4e SHA512 d2bef837d61bfb35ba550f004345c2c412c2f62da23ffded6dff8aa33281fdce7c0a8f6b70c131b35e04c34ca0a4221bf97a78e65a470c657980572ebedb0774 | ||
DIST VirtualBoxSDK-5.1.28-117968.zip 9860778 BLAKE2B 9f4e4d9c74331be5781ad6820f340c48b372949916952a0f98d040fea05f0319975b1f83fbf479de8c0e2eda2927ff56f3a26901dbfe08395b2b3c4273d11bb6 SHA512 d7e365c57a1179ccbba7e695b8b8fc4dcdf36b45fbb199000878ccb161b13208b14ad3fe963f99a9b680cba5a2c562e3d39cf9892acc16879919ddaa4d24c22b | ||
DIST VirtualBoxSDK-5.1.30-118389.zip 9861374 BLAKE2B 4890a76c5bdf6ec8215095ce3246ee518a6cf527136fd896bec3503175115de05e52f946b5c44fa82ecb087900a5eb4f2bbd0cfa79a4eba94ba4d48f757f9604 SHA512 89d3407860f202329e5958e724b848884a9047f01000090d1000bce22005311b3650c1ef1fb1fc998c29cc77887af856b64a5ac76154408cae7b921860d8a9f1 | ||
DIST VirtualBoxSDK-5.2.2-119230.zip 10146673 BLAKE2B 8bdb6ffcd9e0a59c5a27676a9cd71c402b6a8dd7c03fc7e543e620e3f96b02f252e46432b3724fad508953636a9643731fe60c7cad2ef79a107d83ea154aca3b SHA512 2bfd6e391af3ad55dfced0dcf551112c364317b226bdc29bab42420055c2dc6053f9ab5ce28eace15bb9c7680ddc83c0bc77c53938d05d507cdd51a6c781a27f |
287 changes: 287 additions & 0 deletions
287
app-emulation/virtualbox-bin/virtualbox-bin-5.2.2.119230.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,287 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit eutils xdg-utils gnome2 pax-utils python-r1 udev unpacker versionator | ||
|
||
MAIN_PV="$(get_version_component_range 1-3)" | ||
if [[ ${PV} = *_beta* ]] || [[ ${PV} = *_rc* ]] ; then | ||
MY_PV="${MAIN_PV}_$(get_version_component_range 5)" | ||
MY_PV="${MY_PV/beta/BETA}" | ||
MY_PV="${MY_PV/rc/RC}" | ||
else | ||
MY_PV="${MAIN_PV}" | ||
fi | ||
VBOX_BUILD_ID="$(get_version_component_range 4)" | ||
VBOX_PV="${MY_PV}-${VBOX_BUILD_ID}" | ||
MY_P="VirtualBox-${VBOX_PV}-Linux" | ||
# needed as sometimes the extpack gets another build ID | ||
EXTP_PV="${VBOX_PV}" | ||
EXTP_PN="Oracle_VM_VirtualBox_Extension_Pack" | ||
EXTP_P="${EXTP_PN}-${EXTP_PV}" | ||
# needed as sometimes the SDK gets another build ID | ||
SDK_PV="${VBOX_PV}" | ||
SDK_P="VirtualBoxSDK-${SDK_PV}" | ||
|
||
DESCRIPTION="Family of powerful x86 virtualization products for enterprise and home use" | ||
HOMEPAGE="http://www.virtualbox.org/" | ||
SRC_URI="amd64? ( http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}_amd64.run ) | ||
x86? ( http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}_x86.run ) | ||
http://download.virtualbox.org/virtualbox/${MY_PV}/${EXTP_P}.vbox-extpack -> ${EXTP_P}.tar.gz" | ||
|
||
LICENSE="GPL-2 PUEL" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+additions +chm headless python vboxwebsrv rdesktop-vrdp" | ||
RESTRICT="mirror" | ||
|
||
if [[ "${PV}" != *beta* ]] ; then | ||
SRC_URI+=" | ||
sdk? ( http://download.virtualbox.org/virtualbox/${MY_PV}/${SDK_P}.zip )" | ||
IUSE+=" sdk" | ||
fi | ||
|
||
DEPEND="app-arch/unzip | ||
${PYTHON_DEPS}" | ||
|
||
RDEPEND="!!app-emulation/virtualbox | ||
!app-emulation/virtualbox-additions | ||
~app-emulation/virtualbox-modules-${MAIN_PV} | ||
!headless? ( | ||
dev-libs/glib | ||
media-libs/fontconfig | ||
media-libs/freetype | ||
media-libs/libpng | ||
media-libs/libsdl[X] | ||
x11-libs/libXcursor | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXft | ||
x11-libs/libXi | ||
x11-libs/libXinerama | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
chm? ( dev-libs/expat ) | ||
) | ||
dev-libs/libxml2 | ||
sys-fs/lvm2 | ||
x11-libs/libXau | ||
x11-libs/libX11 | ||
x11-libs/libXt | ||
x11-libs/libXmu | ||
x11-libs/libSM | ||
x11-libs/libICE | ||
x11-libs/libXdmcp | ||
${PYTHON_DEPS}" | ||
|
||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
S=${WORKDIR} | ||
|
||
QA_PREBUILT="opt/VirtualBox/*" | ||
|
||
PYTHON_UPDATER_IGNORE="1" | ||
|
||
src_unpack() { | ||
unpack_makeself ${MY_P}_${ARCH}.run | ||
unpack ./VirtualBox.tar.bz2 | ||
|
||
mkdir "${S}"/${EXTP_PN} || die | ||
pushd "${S}"/${EXTP_PN} &>/dev/null || die | ||
unpack ${EXTP_P}.tar.gz | ||
popd &>/dev/null || die | ||
|
||
if [[ "${PV}" != *beta* ]] && use sdk ; then | ||
unpack VirtualBoxSDK-${SDK_PV}.zip | ||
fi | ||
} | ||
|
||
src_configure() { | ||
:; | ||
} | ||
|
||
src_compile() { | ||
:; | ||
} | ||
|
||
src_install() { | ||
# create virtualbox configurations files | ||
insinto /etc/vbox | ||
newins "${FILESDIR}/${PN}-config" vbox.cfg | ||
|
||
if ! use headless ; then | ||
newmenu "${FILESDIR}"/${PN}.desktop-2 ${PN}.desktop | ||
|
||
# set up symlinks (bug #572012) | ||
dosym ../../../../opt/VirtualBox/virtualbox.xml /usr/share/mime/packages/virtualbox.xml | ||
|
||
local size ico icofile | ||
for size in 16 24 32 48 64 72 96 128 256 ; do | ||
pushd "${S}"/icons/${size}x${size} &>/dev/null || die | ||
if [[ -f "virtualbox.png" ]] ; then | ||
doicon -s ${size} virtualbox.png | ||
fi | ||
for ico in hdd ova ovf vbox{,-extpack} vdi vdh vmdk ; do | ||
icofile="virtualbox-${ico}.png" | ||
if [[ -f "${icofile}" ]] ; then | ||
doicon -s ${size} ${icofile} | ||
fi | ||
done | ||
popd &>/dev/null || die | ||
done | ||
doicon -s scalable "${S}"/icons/scalable/virtualbox.svg | ||
insinto /usr/share/pixmaps | ||
newins "${S}"/icons/48x48/virtualbox.png ${PN}.png | ||
fi | ||
|
||
pushd "${S}"/${EXTP_PN} &>/dev/null || die | ||
insinto /opt/VirtualBox/ExtensionPacks/${EXTP_PN} | ||
doins -r linux.${ARCH} | ||
doins ExtPack* PXE-Intel.rom | ||
popd &>/dev/null || die | ||
rm -rf "${S}"/${EXTP_PN} | ||
|
||
insinto /opt/VirtualBox | ||
dodir /opt/bin | ||
|
||
doins UserManual.pdf | ||
|
||
if [[ "${PV}" != *beta* ]] && use sdk ; then | ||
doins -r sdk | ||
fi | ||
|
||
if use additions; then | ||
doins -r additions | ||
fi | ||
|
||
if use vboxwebsrv; then | ||
doins vboxwebsrv | ||
fowners root:vboxusers /opt/VirtualBox/vboxwebsrv | ||
fperms 0750 /opt/VirtualBox/vboxwebsrv | ||
dosym ../../opt/VirtualBox/VBox.sh /opt/bin/vboxwebsrv | ||
newinitd "${FILESDIR}"/vboxwebsrv-initd vboxwebsrv | ||
newconfd "${FILESDIR}"/vboxwebsrv-confd vboxwebsrv | ||
fi | ||
|
||
if use rdesktop-vrdp; then | ||
doins rdesktop-vrdp | ||
doins -r rdesktop-vrdp-keymaps | ||
fperms 0750 /opt/VirtualBox/rdesktop-vrdp | ||
dosym ../../opt/VirtualBox/rdesktop-vrdp /opt/bin/rdesktop-vrdp | ||
fi | ||
|
||
if ! use headless && use chm; then | ||
doins kchmviewer VirtualBox.chm | ||
fowners root:vboxusers /opt/VirtualBox/kchmviewer | ||
fperms 0750 /opt/VirtualBox/kchmviewer | ||
fi | ||
|
||
# This ebuild / package supports only py2.7. When py3 comes is unknown. | ||
# The compile phase makes VBoxPython2_7.so. | ||
# py3 support would presumably require a binary pre-compiled by py3. | ||
use python && doins VBoxPython.so VBoxPython2_7.so | ||
|
||
rm -rf src rdesktop* deffiles install* routines.sh runlevel.sh \ | ||
vboxdrv.sh VBox.sh VBox.png vboxnet.sh additions VirtualBox.desktop \ | ||
VirtualBox.tar.bz2 LICENSE VBoxSysInfo.sh rdesktop* vboxwebsrv \ | ||
webtest kchmviewer VirtualBox.chm vbox-create-usb-node.sh \ | ||
90-vbox-usb.fdi uninstall.sh vboxshell.py vboxdrv-pardus.py \ | ||
VBoxPython?_*.so | ||
|
||
if use headless ; then | ||
rm -rf VBoxSDL VirtualBox VBoxKeyboard.so | ||
fi | ||
|
||
doins -r * || die | ||
|
||
# create symlinks for working around unsupported $ORIGIN/.. in VBoxC.so (setuid) | ||
dosym ../VBoxVMM.so /opt/VirtualBox/components/VBoxVMM.so | ||
dosym ../VBoxREM.so /opt/VirtualBox/components/VBoxREM.so | ||
dosym ../VBoxRT.so /opt/VirtualBox/components/VBoxRT.so | ||
dosym ../VBoxDDU.so /opt/VirtualBox/components/VBoxDDU.so | ||
dosym ../VBoxXPCOM.so /opt/VirtualBox/components/VBoxXPCOM.so | ||
|
||
local each | ||
for each in VBox{Manage,SVC,XPCOMIPCD,Tunctl,NetAdpCtl,NetDHCP,NetNAT,TestOGL,ExtPackHelperApp}; do | ||
fowners root:vboxusers /opt/VirtualBox/${each} | ||
fperms 0750 /opt/VirtualBox/${each} | ||
pax-mark -m "${D}"/opt/VirtualBox/${each} | ||
done | ||
# VBoxNetAdpCtl and VBoxNetDHCP binaries need to be suid root in any case.. | ||
fperms 4750 /opt/VirtualBox/VBoxNetAdpCtl | ||
fperms 4750 /opt/VirtualBox/VBoxNetDHCP | ||
fperms 4750 /opt/VirtualBox/VBoxNetNAT | ||
|
||
if ! use headless ; then | ||
# Hardened build: Mark selected binaries set-user-ID-on-execution | ||
for each in VBox{SDL,Headless} VirtualBox; do | ||
fowners root:vboxusers /opt/VirtualBox/${each} | ||
fperms 4510 /opt/VirtualBox/${each} | ||
pax-mark -m "${D}"/opt/VirtualBox/${each} | ||
done | ||
|
||
dosym ../VirtualBox/VBox.sh /opt/bin/VirtualBox | ||
dosym ../VirtualBox/VBox.sh /opt/bin/VBoxSDL | ||
else | ||
# Hardened build: Mark selected binaries set-user-ID-on-execution | ||
fowners root:vboxusers /opt/VirtualBox/VBoxHeadless | ||
fperms 4510 /opt/VirtualBox/VBoxHeadless | ||
pax-mark -m "${D}"/opt/VirtualBox/VBoxHeadless | ||
fi | ||
|
||
exeinto /opt/VirtualBox | ||
newexe "${FILESDIR}/${PN}-3-wrapper" "VBox.sh" | ||
fowners root:vboxusers /opt/VirtualBox/VBox.sh | ||
fperms 0750 /opt/VirtualBox/VBox.sh | ||
|
||
dosym ../VirtualBox/VBox.sh /opt/bin/VBoxManage | ||
dosym ../VirtualBox/VBox.sh /opt/bin/VBoxVRDP | ||
dosym ../VirtualBox/VBox.sh /opt/bin/VBoxHeadless | ||
dosym ../VirtualBox/VBoxTunctl /opt/bin/VBoxTunctl | ||
|
||
# set an env-variable for 3rd party tools | ||
echo -n "VBOX_APP_HOME=/opt/VirtualBox" > "${T}/90virtualbox" | ||
doenvd "${T}/90virtualbox" | ||
|
||
local udevdir="$(get_udevdir)" | ||
insinto ${udevdir}/rules.d | ||
doins "${FILESDIR}"/10-virtualbox.rules | ||
sed "s@%UDEVDIR%@${udevdir}@" \ | ||
-i "${D}"${udevdir}/rules.d/10-virtualbox.rules || die | ||
# move udev scripts into ${udevdir} (bug #372491) | ||
mv "${D}"/opt/VirtualBox/VBoxCreateUSBNode.sh "${D}"${udevdir} || die | ||
fperms 0750 ${udevdir}/VBoxCreateUSBNode.sh | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_desktop_database_update | ||
|
||
gnome2_icon_cache_update | ||
|
||
udevadm control --reload-rules && udevadm trigger --subsystem-match=usb | ||
|
||
elog "" | ||
if ! use headless ; then | ||
elog "To launch VirtualBox just type: \"VirtualBox\"" | ||
elog "" | ||
fi | ||
elog "You must be in the vboxusers group to use VirtualBox." | ||
elog "" | ||
elog "For advanced networking setups you should emerge:" | ||
elog "net-misc/bridge-utils and sys-apps/usermode-utilities" | ||
elog "" | ||
elog "Please visit http://www.virtualbox.org/wiki/Editions for" | ||
elog "an overview about the different features of ${PN}" | ||
elog "and virtualbox-ose" | ||
if [ -e "${ROOT}/etc/udev/rules.d/10-virtualbox.rules" ] ; then | ||
elog "" | ||
elog "Please remove \"${ROOT}/etc/udev/rules.d/10-virtualbox.rules\"" | ||
elog "or else USB in ${PN} won't work." | ||
fi | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_desktop_database_update | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.26-117224.tar.gz 19624237 BLAKE2B 593d70c49e47b49cc64d1c4c8f78703e6cd608f4ef6ab836492822429d213c1b70323cfe7847a206d284821572431423a841e8d802a3f47519818906cee63e39 SHA512 c6e31e8fb26b8ca32c423d14e85e15f6372a030ec40e9f06ce1e1234913d3586cc58d46819684c99cf3ced37f35d0a964339199cad5cf43580c88bf1afa63ef6 | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.28-117968.tar.gz 19626161 BLAKE2B 0f2677cfd4e29b3178f750c932747983267de980d9bef58c6e4937829f835f57977f3bedecb358f2bb1fd8d84d5ae1ef1bf4f38cb0d459f752e9542ad3543f5a SHA512 71c6ce267c14303bbd9e386ea849d37aeb569afff848054deced4c74fd6fffca83c96b392d066f684b7101a786cc7d24cf9308114c08cbb77b26bb07bf23fcf8 | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.30-118389.tar.gz 19624724 BLAKE2B de52acef8ad0785e576b361721d3a2f0b3d7e3820964d7e47fb6ffa7fd33bc4126f0e496396a412994e5eadc17fbd72699295865aa520f5e4b7a8ca53007e905 SHA512 6b468879f0fb6d6f916c40fb60f418457c526c20ebb1a6253bfc38392e0ae965e3b54590173b0d974070ced1646db82035950fb7dd54b22e20f4ad29850d6cf4 | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.2.2-119230.tar.gz 19504049 BLAKE2B ff3be5b81c409c33d7c831e2bba6df7d7ab87e6422d8cc4cbc3599f75c84100fceec5547b8f9b44d204941b48102a23a4c2183340ec017159ae7c37e07d21813 SHA512 cf3f08f7ee966b5a991fe029b3d4014f333678f0fddb9d75589695811dc4d780651a6dbdddf55a6466631bf8a9dce099256468490847229ac2c26dba9fc57d27 |
42 changes: 42 additions & 0 deletions
42
app-emulation/virtualbox-extpack-oracle/virtualbox-extpack-oracle-5.2.2.119230.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit eutils multilib versionator | ||
|
||
MAIN_PV="$(get_version_component_range 1-3)" | ||
if [[ ${PV} = *_beta* ]] || [[ ${PV} = *_rc* ]] ; then | ||
MY_PV="${MAIN_PV}_$(get_version_component_range 5)" | ||
DEP_PV="${MY_PV}" | ||
MY_PV="${MY_PV/beta/BETA}" | ||
MY_PV="${MY_PV/rc/RC}" | ||
else | ||
MY_PV="${MAIN_PV}" | ||
DEP_PV="${MAIN_PV}" | ||
fi | ||
VBOX_BUILD_ID="$(get_version_component_range 4)" | ||
MY_PN="Oracle_VM_VirtualBox_Extension_Pack" | ||
MY_P="${MY_PN}-${MY_PV}-${VBOX_BUILD_ID}" | ||
|
||
DESCRIPTION="PUEL extensions for VirtualBox" | ||
HOMEPAGE="http://www.virtualbox.org/" | ||
SRC_URI="http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}.vbox-extpack -> ${MY_P}.tar.gz" | ||
|
||
LICENSE="PUEL" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
RESTRICT="mirror strip" | ||
|
||
RDEPEND="~app-emulation/virtualbox-${DEP_PV}" | ||
|
||
S="${WORKDIR}" | ||
|
||
QA_PREBUILT="/usr/lib*/virtualbox/ExtensionPacks/${MY_PN}/.*" | ||
|
||
src_install() { | ||
insinto /usr/$(get_libdir)/virtualbox/ExtensionPacks/${MY_PN} | ||
doins -r linux.${ARCH} | ||
doins ExtPack* PXE-Intel.rom | ||
} |
Oops, something went wrong.