Skip to content

Commit

Permalink
media-video/obs-studio: version bump to 20.1.0.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Closes: gentoo#5972
  • Loading branch information
Chiitoo authored and monsieurp committed Oct 27, 2017
1 parent 15c55f9 commit 9bfc25f
Show file tree
Hide file tree
Showing 2 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/obs-studio/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST obs-studio-18.0.2.tar.gz 6073678 SHA256 1cfbad3439b1d581b4f5b47792ccc4dae231acaf37178808811ff4e2b68feb0a SHA512 5d03791438e73e1b7689b319d4a7bb2235a178655061e816309a115026207db11053e3c27c08c5dde4f3638b3bb424ebb3bf3748bbbe828374a06abe75b2e39d WHIRLPOOL 66e3a425dd4029f3649e50fcc88d57f7e85133e16ae65e56b69d5e7ad584df37f6d51079419d47ec79397e321388c762715bab14f797f1fc40d1980cafa9c785
DIST obs-studio-19.0.2.tar.gz 5509958 SHA256 c7846e09f13061587d844588c538276aec6d498c8f9a4518fc3d8bb206776f01 SHA512 8e2c720d713f6b3fdfb0ce64252cba3129644155be75e0942250bb616700ba62acdb04265a7a6d0ce9406282fbbf85d662d7bdc36736c36be89fd726c8bbf5a9 WHIRLPOOL 7200a787ef1afc848fabf52193210a3309456b799da8cbd083d5914723e2c721dc3f7269d5b23edee3fd61c61314c96f11c683b5585d13d8b19536e3480f1f5c
DIST obs-studio-20.0.1.tar.gz 5610534 SHA256 3241667f180816b860622fd9ac572a86375a9a766ac45c69a886dcbdaf524643 SHA512 891be96bbe18a2de4af8efd2eaeb54c388332ac7d93a66efcc18208af9ef2dfe3981f81ba351bdb16a93b2d66bcfef4f5277d3d8746261f0beb1f324ed9a7534 WHIRLPOOL d43526496775a409c75212ab53c30ebe3d55250583761c58ab5bf9cbe958c5ac4174ea7a3692a133d0be58265862b9e4a62515afa85b429d4d601b0b102a1ec6
DIST obs-studio-20.1.0.tar.gz 5637636 SHA256 3354e21f1909633dc98e7faafc4c6c57fe0edd049d2675a85c0a1a0e007eee83 SHA512 fd0c4b910b9a07644a9ddb72c2622d1fac67878a8bf445d7ab33385aafa23a5207f89971c428a3be01fa851141d9cbb55e86ca81201928783227fc730d12b962 WHIRLPOOL e0ce146c09ba85904191d339b9a14ff3f9420a7fe8f6a5e079e3f78a019e553a17ba8cdd1b38b0a6c5f66d3b3e517bb567bee5e4d1e9ba31b820f765012f9744
116 changes: 116 additions & 0 deletions media-video/obs-studio/obs-studio-20.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,116 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils gnome2-utils

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/jp9000/obs-studio.git"
EGIT_SUBMODULES=()
else
SRC_URI="https://github.com/jp9000/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Software for Recording and Streaming Live Video Content"
HOMEPAGE="https://obsproject.com"

LICENSE="GPL-2"
SLOT="0"
IUSE="+alsa fdk imagemagick jack pulseaudio truetype v4l"

COMMON_DEPEND="
>=dev-libs/jansson-2.5
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtnetwork:5
dev-qt/qtquickcontrols:5
dev-qt/qtsql:5
dev-qt/qttest:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
media-video/ffmpeg:=[x264]
net-misc/curl
x11-libs/libXcomposite
x11-libs/libXinerama
x11-libs/libXrandr
alsa? ( media-libs/alsa-lib )
fdk? ( media-libs/fdk-aac:= )
imagemagick? ( media-gfx/imagemagick:= )
jack? ( virtual/jack )
pulseaudio? ( media-sound/pulseaudio )
truetype? (
media-libs/fontconfig
media-libs/freetype
)
v4l? ( media-libs/libv4l )
"
DEPEND="${COMMON_DEPEND}
imagemagick? (
|| (
<media-gfx/imagemagick-7
(
>=media-gfx/imagemagick-7
>=dev-util/cmake-3.9
)
)
)
"
RDEPEND="${COMMON_DEPEND}"

CMAKE_REMOVE_MODULES_LIST=( FindFreetype )

src_configure() {
local libdir=$(get_libdir)
local mycmakeargs=(
-DDISABLE_ALSA=$(usex !alsa)
-DDISABLE_FREETYPE=$(usex !truetype)
-DDISABLE_JACK=$(usex !jack)
-DDISABLE_LIBFDK=$(usex !fdk)
-DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
-DDISABLE_V4L2=$(usex !v4l)
-DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
-DOBS_MULTIARCH_SUFFIX=${libdir#lib}
-DOBS_VERSION_OVERRIDE=${PV}
-DUNIX_STRUCTURE=1
)
cmake-utils_src_configure
}

pkg_postinst() {
gnome2_icon_cache_update

if ! use alsa && ! use pulseaudio; then
elog
elog "For the audio capture features to be available,"
elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
elog "be enabled."
elog
fi

if ! has_version "sys-apps/dbus"; then
elog
elog "The 'sys-apps/dbus' package is not installed, but"
elog "could be used for disabling hibernating, screensaving,"
elog "and sleeping. Where it is not installed,"
elog "'xdg-screensaver reset' is used instead"
elog "(if 'x11-misc/xdg-utils' is installed)."
elog
fi

if ! has_version "media-libs/speex"; then
elog
elog "For the speexdsp-based noise suppression filter"
elog "to be available, the 'media-libs/speex' package needs"
elog "to be installed."
elog
fi
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 9bfc25f

Please sign in to comment.