Skip to content

Commit

Permalink
dev-python/nbformat: Bump to 5.8.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Mar 21, 2023
1 parent bb2f92a commit 9bfd2c3
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/nbformat/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST nbformat-5.7.3.tar.gz 140407 BLAKE2B 7e699939e0d13394851d6bccd02855beca041192ffc273c754770fe6c7d6135a17b32b40224d664bbfbc02e30dbb92aacb24b56cfd44a6c10b4c817a09bd11c1 SHA512 d705d959ea4d5b5294f137dff6b2b60b936ad7d2ff4aa06030429e9ee1e55cc5c9ec7d0f2196a67b67080e79177a18085c6bf75b84ab8ac5606fabb53455e4c2
DIST nbformat-5.8.0.tar.gz 140655 BLAKE2B e45b6fcc45fa01ceed49fba0b3a3fd749df6692e355156845cf69fd9d2e176332c61c89b5474ffa89d96da4d4453b668150e96ac266cddd254efdcb1a3b742a1 SHA512 f000db59701eec2fed8adba6c1b521bdfaf942bcd0dba2d8d6d79a7d28b078f4a29df05ca3f393c1651f3ddc6b3690f536928d6fff5937982cc52dd013bc6498
48 changes: 48 additions & 0 deletions dev-python/nbformat/nbformat-5.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE='sqlite'

inherit distutils-r1 pypi

DESCRIPTION="Reference implementation of the Jupyter Notebook format"
HOMEPAGE="
https://jupyter.org/
https://github.com/jupyter/nbformat/
https://pypi.org/project/nbformat/
"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"

RDEPEND="
dev-python/fastjsonschema[${PYTHON_USEDEP}]
>=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
>=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
dev-python/jupyter_core[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/testpath[${PYTHON_USEDEP}]
)
"

distutils_enable_sphinx docs \
dev-python/numpydoc \
dev-python/myst-parser \
dev-python/pydata-sphinx-theme
distutils_enable_tests pytest

PATCHES=(
"${FILESDIR}/nbformat-5.7.1-no-node.patch"
)

EPYTEST_IGNORE=(
# requires pep440 package, which is not really relevant for us
tests/test_api.py
)

0 comments on commit 9bfd2c3

Please sign in to comment.