Skip to content

Commit

Permalink
dev-vcs/mercurial: Bunp to version 4.2.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Lars Wendler committed Jun 4, 2017
1 parent 392123b commit 9c1b2ab
Show file tree
Hide file tree
Showing 2 changed files with 135 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/mercurial/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mercurial-3.8.4.tar.gz 4775341 SHA256 4b2e3ef19d34fa1d781cb7425506a05d4b6b1172bab69d6ea78874175fdf3da6 SHA512 2ee785f631f9ae346e10ca77251a9ce6d3dacd598588c39f1a69ce1f4b668866f6109d682428512c37c300b26741b74672195538d66845e85cfff5ead886cf4c WHIRLPOOL 1f0a12cc6d00f3544ab00e011a9ff9308fe1652c0598045ddba2a41ba17b55c291da200bce85d4c600d673b8746e936c441ffa7398ad810d1069bd97fb32f2db
DIST mercurial-4.1.3.tar.gz 5134965 SHA256 103d2ae187d5c94110c0e86ccc3b46f55fcd8e21c78d1c209bac7b59a73e86d8 SHA512 794c513b7e061bc56d270ef57adc0fadeffd5bcc988da0934b24db686b76bf573aef2bbaa3baa9220f31463795bc6e6a99fc1284ebcf8d7e49f42b8129347811 WHIRLPOOL a2f5d5e3e89f794415521bf0bc93ff0e8a67aec6c39951437b6b585f9f6d604bd556af10cce50951128c746719db54ea48f86fb7c262a36a29576ba539be1e79
DIST mercurial-4.2.1.tar.gz 5317692 SHA256 d7d5572f5aa0797fbf2168440eaa51149df88645fe37af8b15fa660d9a8158a0 SHA512 0349fb5343210869bacb2247d30546676e5cf486f64fb8ebb2b1c6cdf7d564e7b754a43fb5b61c7d7e66a67609c514c8e15f415f4189bccbebb2fbb5a5474645 WHIRLPOOL f64df61fe2a10abca4765f150952e5d529034909666f1bee6df40d628af52d650086bd51c5d2db2e0ce2874f38fd439bb9d958bda3d2d63dccbf861b933d51f1
DIST mercurial-4.2.tar.gz 5303367 SHA256 23a412308fc9c2b354a0e91a89588a4af2af061b47da80bc4233ccb0cceef47d SHA512 bd03134a70fe0576a31d86cb6ca2d232b8f98bd9b038dc972a4d332889bb39c776f47d44ea9c45588d6e53590a8e3fbd48ca25238525919b8e44beab3d3c79cb WHIRLPOOL 930882698c0e662f5fadc8a57a14ce00270cce70f7a9f8f0081647a28c3558aeda1a4d7bc5aa7e264cb60ec85051dae6a16cc62df0f51be3cc406bf587ff5485
134 changes: 134 additions & 0 deletions dev-vcs/mercurial/mercurial-4.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic

DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bugzilla emacs gpg test tk"

RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )
app-misc/ca-certificates"
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments[${PYTHON_USEDEP}] )"

SITEFILE="70${PN}-gentoo.el"

PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )

python_prepare_all() {
# fix up logic that won't work in Gentoo Prefix (also won't outside in
# certain cases), bug #362891
sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die

distutils-r1_python_prepare_all
}

python_configure_all() {
strip-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing

"${PYTHON}" setup.py build_mo || die
}

python_compile_all() {
rm -r contrib/{win32,macosx} || die
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
}

python_install_all() {
distutils-r1_python_install_all

newbashcomp contrib/bash_completion hg

insinto /usr/share/zsh/site-functions
newins contrib/zsh_completion _hg

rm -f doc/*.?.txt
dodoc CONTRIBUTORS
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die

dobin hgeditor
dobin contrib/hgk
python_foreach_impl python_doscript contrib/hg-ssh

if use emacs; then
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi

local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
*.el mercurial.spec)
for f in ${RM_CONTRIB[@]}; do
rm -r contrib/$f || die
done

dodoc -r contrib
docompress -x /usr/share/doc/${PF}/contrib
doman doc/*.?

insinto /etc/mercurial/hgrc.d
doins "${FILESDIR}/cacerts.rc"
}

src_test() {
pushd tests &>/dev/null || die
rm -rf *svn* # Subversion tests fail with 1.5
rm -f test-archive* # Fails due to verbose tar output changes
rm -f test-convert-baz* # GNU Arch baz
rm -f test-convert-cvs* # CVS
rm -f test-convert-darcs* # Darcs
rm -f test-convert-git* # git
rm -f test-convert-mtn* # monotone
rm -f test-convert-tla* # GNU Arch tla
#rm -f test-doctest* # doctest always fails with python 2.5.x
rm -f test-largefiles* # tends to time out

popd &>/dev/null || die
distutils-r1_src_test
}

python_test() {
local TEST_DIR

rm -rf "${TMPDIR}"/test
distutils_install_for_testing
cd tests || die
"${PYTHON}" run-tests.py --verbose \
--tmpdir="${TMPDIR}"/test \
--with-hg="${TEST_DIR}"/scripts/hg \
|| die "Tests fail with ${EPYTHON}"
}

pkg_postinst() {
use emacs && elisp-site-regen

elog "If you want to convert repositories from other tools using convert"
elog "extension please install correct tool:"
elog " dev-vcs/cvs"
elog " dev-vcs/darcs"
elog " dev-vcs/git"
elog " dev-vcs/monotone"
elog " dev-vcs/subversion"
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 9c1b2ab

Please sign in to comment.