Skip to content

Commit

Permalink
dev-python/pypy3-exe-bin: Bump to 7.3.2 (3.6)
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Sep 26, 2020
1 parent 671602c commit 9c2da90
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/pypy3-exe-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST pypy3-exe-7.3.1-1.amd64.xpak 11657579 BLAKE2B 1a037b447c7a73ac37bd7c33f4009442dabaf082a844744093dbb0f835b71abad48a6bfb28ebed0b02bb8a86f59f11b351768f152fd5db8b31ee010b14ffde79 SHA512 ee03ac675e6967d306136e79cbbb1554c44a32a21a0756b09dd7c1af84a9b3cb7e69a0094431bf6427271cf2fb1840e62935f53580e8d3eedef54d9bef2994e2
DIST pypy3-exe-7.3.1-1.x86.xpak 8983621 BLAKE2B 00ea3210e040dd72f169eb2f162f032eb3ddadefd5f114cb4fdb052b40640235f866fc26f577eb22ff64025d2b4234a194529cbac6350aeffa17bb662e98c5b0 SHA512 caa6e4e08c61e3101aa7e971b2aeae04b41c57206327baefeee4a077d09b5bef28ca3518e6823bdf9907ccd4a8ee2b843369ffd87ef0bcb95a66f21ddd87c61e
DIST pypy3-exe-7.3.2-1.amd64.xpak 11747236 BLAKE2B 5421ad051d2af6f88875591c99e801eab3991aa4a6936c0661f7fe131b13ec5cf9a261774f4ce6cae6202a9b0087265a457e2bdefe50110ce12c71e56885992a SHA512 6cdf308a12d2dffc44335b06e8e6212e559f329f0045fdfb8e3b5fe127d62b8881eaf8231a3b7f9ad7f628ac059a1e68a9bb2b43d677e59cfc81ea202ebf0898
DIST pypy3-exe-7.3.2-1.x86.xpak 9043236 BLAKE2B 0c07e5bba6d44444c227e63dea02c390254b809a2c14a4b9faefa080e32a86849c354971eb4f1d13331e00e2af7e79d108a6f69fed1cdec0faf70ed8320b6c64 SHA512 8040abb95b2bd4144a456f429fad39492672b6f225951f93d138609a7265bdadff9d2ea0b4cf7b481cd9a16fa1017bdcce0f7a3afda27ab60c094cc2a0ba2a92
48 changes: 48 additions & 0 deletions dev-python/pypy3-exe-bin/pypy3-exe-bin-7.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit pax-utils

MY_P=pypy3-exe-${PV}-1
DESCRIPTION="PyPy3 executable (pre-built version)"
HOMEPAGE="https://pypy.org/"
SRC_URI="
amd64? (
https://dev.gentoo.org/~mgorny/binpkg/amd64/pypy/dev-python/pypy3-exe/${MY_P}.xpak
-> ${MY_P}.amd64.xpak
)
x86? (
https://dev.gentoo.org/~mgorny/binpkg/x86/pypy/dev-python/pypy3-exe/${MY_P}.xpak
-> ${MY_P}.x86.xpak
)"
S="${WORKDIR}"

LICENSE="MIT"
SLOT="${PV}"
KEYWORDS="~amd64 ~x86"

RDEPEND=">=sys-libs/zlib-1.1.3:0/1
dev-libs/libffi:0/7
virtual/libintl:0/0
dev-libs/expat:0/0
app-arch/bzip2:0/1
sys-libs/ncurses:0/6
!dev-python/pypy-exe:${PV}"

QA_PREBUILT="
usr/lib/pypy3.6/pypy3-c-${SLOT}"

src_unpack() {
ebegin "Unpacking ${MY_P}.${ARCH}.xpak"
tar -x < <(xz -c -d --single-stream "${DISTDIR}/${MY_P}.${ARCH}.xpak")
eend ${?} || die "Unpacking ${MY_P} failed"
}

src_install() {
insinto /
doins -r usr
fperms +x "/usr/lib/pypy3.6/pypy3-c-${SLOT}"
pax-mark m "${ED}/usr/lib/pypy3.6/pypy3-c-${SLOT}"
}

0 comments on commit 9c2da90

Please sign in to comment.