Skip to content

Commit

Permalink
app-text/sword: bump to 1.9.0 and EAPI 7
Browse files Browse the repository at this point in the history
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Dec 9, 2020
1 parent 346aeb4 commit 9c39875
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/sword/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST sword-1.8.1.tar.gz 2449503 BLAKE2B 4cc130ade49211dd4def6d9410ad6a0f01b35d11df246e26bb7fd0ee5c27ef02ee06ed3ec33c7becd140fa303b4fb4b3d4ba4d62de78b86be343949d5fcf7c6d SHA512 5c08c070ea0c86b7d929bbf94c89730eb5a487986deb9edf01c08d1710356aecd1ab3bde4437a778e5fc1ceb05b63287612ec6161381c0986a36344c27d2ab36
DIST sword-1.9.0.tar.gz 2606652 BLAKE2B cd0fd85267c81410dc6acdc45594688ac1855a6160f5d39d38e225982e1440433fbdc75f22eee52291fcbf1ef92b8ca5a40652a98d7cafbfc9186e6d132ef236 SHA512 9ed3fbb5024af1f93b1473bae0d95534d02a5b00b3c9d41a0f855cee8106dc4e330844080adbee7c3f74c0e5ce1480bf16c87c842421337a341f641bae11137f
41 changes: 41 additions & 0 deletions app-text/sword/sword-1.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

DESCRIPTION="Library for Bible reading software"
HOMEPAGE="https://www.crosswire.org/sword/"
SRC_URI="https://www.crosswire.org/ftpmirror/pub/${PN}/source/v${PV%.*}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos"
IUSE="clucene curl debug doc icu static-libs"

RDEPEND="sys-libs/zlib
curl? ( net-misc/curl )
icu? ( dev-libs/icu:= )
clucene? ( dev-cpp/clucene )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

DOCS=( AUTHORS CODINGSTYLE ChangeLog README )

src_configure() {
use doc && DOCS+=( examples/ samples/ )

local mycmakeargs=(
-DSYSCONF_INSTALL_DIR="${EPREFIX}/etc"
-DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
-DWITH_CLUCENE=$(usex clucene)
-DWITH_CURL=$(usex curl)
-DWITH_ICU=$(usex icu)
-DWITH_ZLIB=1
)
# Upstream default is to build both the shared and the static library
use static-libs || mycmakeargs+=( -DLIBSWORD_LIBRARY_TYPE="Shared" )

cmake_src_configure
}

0 comments on commit 9c39875

Please sign in to comment.