Skip to content

Commit

Permalink
app-text/evince: version bump 3.24.0 → 3.24.1
Browse files Browse the repository at this point in the history
Performance enhancements. Fix a problem with layers not from the
current visible page and crash with orca.

Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
EvaSDK committed Aug 9, 2017
1 parent f47a7cf commit 9c4101d
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/evince/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST evince-3.22.1.tar.xz 3365004 SHA256 f3d439db3b5a5745d26175d615a71dffa1535235b1e3aa0b85d397ea33ab231c SHA512 c36a90bf98f25b4f9f05536f1a09c38be30b814529e17a4ab159ba7c1e952402a211f335d4cdf1928ace8a5b46d6d019fbbd457ce11c2ffa264d8bb7c32d5a18 WHIRLPOOL 7b646bab40f9c05b7689de70b1de2e313b0576a772887187d71b51b00c456251169b7e5bb85f44f443a0dcce5199a405dc303c49a4be3d62c244225493c58749
DIST evince-3.24.0.tar.xz 3507256 SHA256 043895af7bbd6f1b57f9ab8778e78cf9c0af5dfcc347eaa94a17bf864c04dc8f SHA512 b793c44b2976abe58461adfdb0b1874af8d6bafaf9b80a851d94b776f9d50f6a81774bcb5b35cd59a9ad3afeea9a8b88018aa85d670373c7c2fa9617407a09c4 WHIRLPOOL 944a9622802d2ab99140115f65922cf79baefcabf43be08b9b3f9654fe095ef57909a03ba20ad6cfe1f396878674265d7198e48669168b288e4b21ace1172a69
DIST evince-3.24.1.tar.xz 3511576 SHA256 9ca0c5213407b37be55fddb04a85d9301b692c4412c5920319d975403bff0f37 SHA512 205c1c9b68c9215bdcebf0c36841a35898e056ef8e56208db62c1fac04c4efad8fbc0800f410e3c94c526536adba5e8ead68bebec8f81061a3831789c5173726 WHIRLPOOL de0074c42ec8614a7ef34848de6768a722a855f3113fdad7392993a913f707f6e4fc55f86cbab945b41bc84ba92d79c82e2bc0b680a99702681b4d775706e3c6
98 changes: 98 additions & 0 deletions app-text/evince/evince-3.24.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_LA_PUNT="yes"

inherit gnome2 systemd

DESCRIPTION="Simple document viewer for GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/Evince"

LICENSE="GPL-2+ CC-BY-SA-3.0"
# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
SLOT="0/evd3.4-evv3.3"
IUSE="djvu dvi gstreamer gnome gnome-keyring +introspection nautilus nsplugin +postscript t1lib tiff xps"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"

# atk used in libview
# gdk-pixbuf used all over the place
COMMON_DEPEND="
dev-libs/atk
>=dev-libs/glib-2.36:2[dbus]
>=dev-libs/libxml2-2.5:2
sys-libs/zlib:=
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.16.0:3[introspection?]
gnome-base/gsettings-desktop-schemas
>=x11-libs/cairo-1.10:=
>=app-text/poppler-0.33[cairo]
djvu? ( >=app-text/djvu-3.5.22:= )
dvi? (
virtual/tex-base
dev-libs/kpathsea:=
t1lib? ( >=media-libs/t1lib-5:= ) )
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
media-libs/gst-plugins-good:1.0 )
gnome? ( gnome-base/gnome-desktop:3= )
gnome-keyring? ( >=app-crypt/libsecret-0.5 )
introspection? ( >=dev-libs/gobject-introspection-1:= )
nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
postscript? ( >=app-text/libspectre-0.2:= )
tiff? ( >=media-libs/tiff-3.6:0= )
xps? ( >=app-text/libgxps-0.2.1:= )
"
RDEPEND="${COMMON_DEPEND}
gnome-base/gvfs
gnome-base/librsvg
|| (
>=x11-themes/adwaita-icon-theme-2.17.1
>=x11-themes/hicolor-icon-theme-0.10 )
"
DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.3
app-text/yelp-tools
dev-util/gdbus-codegen
>=dev-util/gtk-doc-am-1.13
>=dev-util/intltool-0.35
dev-util/itstool
sys-devel/gettext
virtual/pkgconfig
"
# eautoreconf needs:
# app-text/yelp-tools

src_prepare() {
gnome2_src_prepare

# Do not depend on adwaita-icon-theme, bug #326855, #391859
# https://bugs.freedesktop.org/show_bug.cgi?id=29942
sed -e 's/adwaita-icon-theme >= $ADWAITA_ICON_THEME_REQUIRED//g' \
-i configure || die "sed failed"
}

src_configure() {
gnome2_src_configure \
--disable-static \
--enable-pdf \
--enable-comics \
--enable-thumbnailer \
--with-platform=gnome \
--enable-dbus \
$(use_enable djvu) \
$(use_enable dvi) \
$(use_enable gstreamer multimedia) \
$(use_enable gnome libgnome-desktop) \
$(use_with gnome-keyring keyring) \
$(use_enable introspection) \
$(use_enable nautilus) \
$(use_enable nsplugin browser-plugin) \
$(use_enable postscript ps) \
$(use_enable t1lib) \
$(use_enable tiff) \
$(use_enable xps) \
BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins \
--with-systemduserunitdir="$(systemd_get_userunitdir)"
}

0 comments on commit 9c4101d

Please sign in to comment.