Skip to content

Commit

Permalink
dev-ros/tf2: forward port console bridge patch
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
aballier committed Jan 7, 2018
1 parent 8f1f995 commit 9c588b5
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
98 changes: 98 additions & 0 deletions dev-ros/tf2/files/logging2.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
Index: tf2/src/buffer_core.cpp
===================================================================
--- tf2.orig/src/buffer_core.cpp
+++ tf2/src/buffer_core.cpp
@@ -123,7 +123,7 @@ bool BufferCore::warnFrameId(const char*
{
std::stringstream ss;
ss << "Invalid argument passed to "<< function_name_arg <<" in tf2 frame_ids cannot be empty";
- logWarn("%s",ss.str().c_str());
+ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
return true;
}

@@ -131,7 +131,7 @@ bool BufferCore::warnFrameId(const char*
{
std::stringstream ss;
ss << "Invalid argument \"" << frame_id << "\" passed to "<< function_name_arg <<" in tf2 frame_ids cannot start with a '/' like: ";
- logWarn("%s",ss.str().c_str());
+ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
return true;
}

@@ -218,26 +218,26 @@ bool BufferCore::setTransform(const geom
bool error_exists = false;
if (stripped.child_frame_id == stripped.header.frame_id)
{
- logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
+ CONSOLE_BRIDGE_logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
error_exists = true;
}

if (stripped.child_frame_id == "")
{
- logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
+ CONSOLE_BRIDGE_logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
error_exists = true;
}

if (stripped.header.frame_id == "")
{
- logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
+ CONSOLE_BRIDGE_logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
error_exists = true;
}

if (std::isnan(stripped.transform.translation.x) || std::isnan(stripped.transform.translation.y) || std::isnan(stripped.transform.translation.z)||
std::isnan(stripped.transform.rotation.x) || std::isnan(stripped.transform.rotation.y) || std::isnan(stripped.transform.rotation.z) || std::isnan(stripped.transform.rotation.w))
{
- logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
+ CONSOLE_BRIDGE_logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
stripped.child_frame_id.c_str(), authority.c_str(),
stripped.transform.translation.x, stripped.transform.translation.y, stripped.transform.translation.z,
stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w
@@ -252,7 +252,7 @@ bool BufferCore::setTransform(const geom

if (!valid)
{
- logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
+ CONSOLE_BRIDGE_logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
stripped.child_frame_id.c_str(), authority.c_str(),
stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w);
error_exists = true;
@@ -274,7 +274,7 @@ bool BufferCore::setTransform(const geom
}
else
{
- logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
+ CONSOLE_BRIDGE_logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
return false;
}
}
@@ -633,7 +633,7 @@ geometry_msgs::TransformStamped BufferCo
case tf2_msgs::TF2Error::LOOKUP_ERROR:
throw LookupException(error_string);
default:
- logError("Unknown error code: %d", retval);
+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
assert(0);
}
}
@@ -1604,7 +1604,7 @@ void BufferCore::_chainAsVector(const st
case tf2_msgs::TF2Error::LOOKUP_ERROR:
throw LookupException(error_string);
default:
- logError("Unknown error code: %d", retval);
+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
assert(0);
}
}
@@ -1623,7 +1623,7 @@ void BufferCore::_chainAsVector(const st
case tf2_msgs::TF2Error::LOOKUP_ERROR:
throw LookupException(error_string);
default:
- logError("Unknown error code: %d", retval);
+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
assert(0);
}
}
1 change: 1 addition & 0 deletions dev-ros/tf2/tf2-0.5.17.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -23,3 +23,4 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-ros/roscpp )
"
PATCHES=( "${FILESDIR}/logging2.patch" )

0 comments on commit 9c588b5

Please sign in to comment.