Skip to content

Commit

Permalink
dev-python/python-heatclient: 1.17.0 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Apr 12, 2019
1 parent 2a64717 commit 9c67470
Show file tree
Hide file tree
Showing 2 changed files with 90 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/python-heatclient/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST python-heatclient-1.11.1.tar.gz 166963 BLAKE2B 340c9f1ed054815176af8da9b3035d8e260730fdd389317190281314af7b3df60214dc780036b098a15485bf2cd5b02010eacaf474746a73d7d7ee94972c14da SHA512 f4ffc4706a2630753c11423270ef18a344603ec6b1d5afc550fb8f3cfeca1bf4fbd0c32670318eded6b81a810fcdff68faf9039c6290c6a106bf8618502efe78
DIST python-heatclient-1.16.2.tar.gz 173543 BLAKE2B f5b4016166bba804a2704b2cc3203438e7ebdae429f85b74e89ccc6d1b2db2de32d4acc6622138b211f5d8657876001b83977d55d56f0cd5906df99eb92a429e SHA512 eb566e5c0270a0cdb8994194a757102febf88869a61bec65e345fd62f8ae9c0b3609bf27f758d37088d69d2227cbbe086960123feebfae7f543ba2bac2133b0e
DIST python-heatclient-1.17.0.tar.gz 172475 BLAKE2B 79dbaa2b6f3bc5e97ac4f2630e3e5ef5a320b7b37b1abdfee5ce66df6c63c9d488770135ffdaff53d3e88f93becd8f26019c4c1967624693c9c0ce1479055181 SHA512 44a16f32ede251c36546a0dcab2ca2ca0e145ce924f257c623cc375e52a851094639529a77d770d2703e28f9446e27e03424240fdc0272096e91703180dd6190
DIST python-heatclient-1.8.2.tar.gz 165073 BLAKE2B 32f09850f2da3ae3235dd8a7f683529189db6a97712374bb2a387c87fe61a74b132d7b51c3fc77e0fffbfd6d8f2596ee097102f034d5fe029b8a08ceb0e31500 SHA512 38c27dff97c8bf9826e57c02fdd5edb4c0410ccc041b7b1f2e95aa16b22d46cfd9a8b728bbd371e1dee0664aa1f8e14b4eafc6bbaab92a038abbb821e3c8dd34
89 changes: 89 additions & 0 deletions dev-python/python-heatclient/python-heatclient-1.17.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )

inherit distutils-r1

DESCRIPTION="OpenStack Orchestration API Client Library"
HOMEPAGE="http://www.openstack.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"

CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
test? (
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
>=dev-python/mox3-0.20.0[${PYTHON_USEDEP}]
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
>=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
>=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
)
doc? (
>=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
>=dev-python/sphinxcontrib-httpdomain-1.3.0[${PYTHON_USEDEP}]
>=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
)
"

RDEPEND="
${CDEPEND}
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
!~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
>=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
!~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
>=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
>=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
<dev-python/prettytable-0.8[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
!~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
>=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
"

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
sed -i '/^tempest/d' test-requirements.txt || die

distutils-r1_python_prepare_all
}

python_compile_all() {
use doc && esetup.py build_sphinx
}

python_test() {
rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"

testr init
testr run || die "testsuite failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( doc/build/html/. )

distutils-r1_python_install_all
}

0 comments on commit 9c67470

Please sign in to comment.