Skip to content

Commit

Permalink
app-misc/vlock: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
monsieurp committed Aug 3, 2017
1 parent d2eccd2 commit 9c9804c
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/vlock/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST vlock-2.2.3.tar.gz 54860 SHA256 85aa5aed1ae49351378a0bd527a013078f0f969372a63164b1944174ae1a5e39 SHA512 7eba8fe4f7085be7ef9169843d0814e55840b823dfc061727db037d2420e8ff4b669a3b08e15f61cdd9d5048c1e088288a46acad341cbe97585e64da2b58c855 WHIRLPOOL 3cc62216d07111eaa5c3298714274266e1a204c79423c1447205d8df7aadeaac51dcab287d7cda0456fbaf605cc5ac31a838350ac07878b6778f8903390328d6
DIST vlock-2.2.3.zip 85751 SHA256 8b1e4a3a1dcea619333256814b72c552c2e99a7d9d15bcc3a72fd9bb39e3df61 SHA512 90390bcecbc5cd55a19f9d3a6007fd39257183f63366d667263c8d49217206ba5d929814c32181bf3d3fa82197a544211ee815b65ab1c7e09a2502c4ab079b07 WHIRLPOOL 28f4412532e57f1371ead9328461189d63850e09d83be9f1a5770453bf30a96d71f40de3f2a36a93d007e33c53fa388cf2d4171add8fa6a9550041cd9b66a9a7
53 changes: 53 additions & 0 deletions app-misc/vlock/vlock-2.2.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit pam toolchain-funcs user

DESCRIPTION="A console screen locker"
HOMEPAGE="https://github.com/WorMzy/vlock"
SRC_URI="https://github.com/WorMzy/vlock/archive/master.zip -> ${P}.zip"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="pam test"

RDEPEND="
pam? ( sys-libs/pam )"

DEPEND="
${RDEPEND}
test? ( dev-util/cunit )"

DOCS=( ChangeLog PLUGINS README README.X11 SECURITY STYLE TODO )

S="${WORKDIR}/${PN}-master"

RESTRICT="test"

pkg_setup() {
enewgroup "${PN}"
}

src_configure() {
local myconf="--enable-shadow"
use pam && myconf="--enable-pam"

# this package has handmade configure system which fails with econf...
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
--libdir=/usr/$(get_libdir) \
${myconf} \
CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
CFLAGS="${CFLAGS} -pedantic -std=gnu99" \
LDFLAGS="${LDFLAGS}" || die "configure failed"
}

src_install() {
default
use pam && pamd_mimic_system vlock auth
}

0 comments on commit 9c9804c

Please sign in to comment.