Skip to content

Commit

Permalink
dev-python/nuitka: Bump to 0.6.15
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 25, 2021
1 parent 04b9065 commit 9cb5428
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/nuitka/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Nuitka-0.6.11.tar.gz 2582563 BLAKE2B e65c3a01f3283b24aadefc47a17a41ebae116265946c24f2225fa7f3f6f824a0a822c76aa2fa1ff33b5a00d4d3762bbac7cd0d090d2627274155b13a48d8f0ba SHA512 c1ead8430f0af3a20d7a14ae3cb34b9a4675c18f0c775e8833b5722cb0acdd8213b28639e52067b3e6758b8b6cc516b05151cfd85560630c92b872dae05a88b4
DIST Nuitka-0.6.15.tar.gz 2712097 BLAKE2B 78c43be4a2ef5678d7a0d6164d7cba2b3a67a738215915b001cdb3774e209fcecc167c52db4c3b22d87dde9169e48077875d09f8601df7c8b079e3d57b21aea6 SHA512 9a41e9b8fb3f51ec16dccd5415b3b7d7d201230fea6aff902931be1764ba65e1d5e4885cd772b4c1cb9f36b1b14a02a73351bc5c1b8e7f7bbb87e5d74aad16b4
48 changes: 48 additions & 0 deletions dev-python/nuitka/nuitka-0.6.15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1 flag-o-matic optfeature

DESCRIPTION="Python to native compiler"
HOMEPAGE="https://www.nuitka.net"
SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
S="${WORKDIR}/${P^}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
BDEPEND="
${RDEPEND}
test? ( dev-util/ccache )
"

DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )

distutils-r1_src_prepare() {
# remove vendored version of SCons that is Python2 only
# this should be removed when upstream removes support for Python2
rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
eapply_user
}

python_install() {
distutils-r1_python_install
python_optimize
doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
}

python_test() {
append-ldflags -Wl,--no-warn-search-mismatch
./tests/basics/run_all.py search || die
}

pkg_postinst() {
optfeature "support for stand-alone executables" app-admin/chrpath
}

0 comments on commit 9cb5428

Please sign in to comment.