Skip to content

Commit

Permalink
dev-libs/librelp: Version bump to v1.2.10
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
Closes: gentoo#1658

Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
Whissi authored and monsieurp committed Jun 12, 2016
1 parent 15b49e4 commit 9cced3a
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/librelp/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST librelp-1.2.10.tar.gz 415653 SHA256 6c80eed5e29061d2cce35408ae43ddaee354edc27c1076eabec6da4eaecdcc72 SHA512 09f88daa59711449a50b9414f30bc7a217bf3dd7722af53caee024bfe1060e1749f1083d2965c79cbe3c12819359cd3cc262e9dea8ab5ad7bf275f3b61ca907f WHIRLPOOL fd9ec0af4769df65d9631faf0b5739f10b50d55b7ba60bb42f4a41a46bc1e1cf7fbda58b2c3b1fd1f0f7fff3d41ffc0c9cd52d243a599be033c2a5e118db8ca1
DIST librelp-1.2.7.tar.gz 410896 SHA256 3a434a1c71772706104cfb1c93ba8e6809d257851d60de29ac2142c60c68d7d1 SHA512 f8a71ad037cb5eaeb807b1bcb942893e2d10bcd57b18764bb13700c8e114d59de37b1b36560288abac18a07b6cb2920b46feaef4ae629aa0b3478ed16723542a WHIRLPOOL 784f291d0318b29be33bcd4bdd41e04c2e0fc8f292c6cb7f5985743559aa65f3c10932680f943e065ebf34e3f62c75bf2ed5500aebe0b7ab2fa7e64ced37cc44
DIST librelp-1.2.9.tar.gz 415909 SHA256 520de7ba3dc688dc72c5b014dc61ef191e9528f77d1651ddca55fc0c149d98a3 SHA512 2d30fdb1946d8c0484de26a741bf187016b8639a702e3a1d42aa390a34931be46064bdb2552950a078366fe2705644db8c6a6015ced2ce14d3d2488527cf0819 WHIRLPOOL ae7095cdf93c2057f34aeee0cf0622284c39f9e84672baa9ff6296b50438cba4d8893114962b2b6f8feb68c0313057edb5fde3060e4fdffb904626a84e7a9690
56 changes: 56 additions & 0 deletions dev-libs/librelp/librelp-1.2.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools

DESCRIPTION="An easy to use library for the RELP protocol"
HOMEPAGE="http://www.librelp.com/"
SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"

LICENSE="GPL-3 doc? ( FDL-1.3 )"

# subslot = soname version
SLOT="0/0.1.0"

KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
IUSE="debug doc +ssl static-libs"

RDEPEND="
ssl? ( >=net-libs/gnutls-3.3.17.1:0= )
"

DEPEND="
ssl? ( >=net-libs/gnutls-3.3.17.1:0= )
virtual/pkgconfig
"

src_prepare() {
sed -i \
-e 's/ -g"/"/g' \
configure.ac || die "sed failed"

default

eautoreconf
}

src_configure() {
local myeconfargs=(
$(use_enable debug)
$(use_enable ssl tls)
$(use_enable static-libs static)
)

econf "${myeconfargs[@]}"
}

src_install() {
local DOCS=( ChangeLog )
use doc && local HTML_DOCS=( doc/relp.html )
default

find "${ED}"usr/lib* -name '*.la' -delete || die
}

0 comments on commit 9cced3a

Please sign in to comment.