Skip to content

Commit

Permalink
dev-util/cutter: Bump to 1.12.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.4, Repoman-2.3.23
Signed-off-by: Petr Vaněk <[email protected]>
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
arkamar authored and Sergei Trofimovich committed Sep 3, 2020
1 parent c91258e commit 9cf42da
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/cutter/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cutter-1.11.0.tar.gz 1990964 BLAKE2B b996a3e4c55b3077a8aa54b3df5517d270410ab81f8a111865dc89dc6e61f2712ebd29c10be37a50d9bf143b98916bf48c5df9ed1bfaf936af714d4a12687052 SHA512 a69efee672fb0e142ac6c1fae287c463ec1e777a2ec6b604f412fd0c21b0614d2f05a289beb4602af70d6446f0a6263b353dcbd38d41a6466ae2cdbd14e0bea3
DIST cutter-1.12.0.tar.gz 2323732 BLAKE2B fb40444b60c19f88dafb9447731b91031ad764359121b835ae03477bf52f17d12d1a0b651059072b6ffb7bf811d4493b3746ab9c48d8f09257b5338130edecbd SHA512 3d8dd9cb6f9e69f41e295795f3d1b7256c071abafd04bdecd619817b8fd04396770f69df753701ffb376a358f0df9bd38dff6a344df4e5ca92163275ad670531
54 changes: 54 additions & 0 deletions dev-util/cutter/cutter-1.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8,9} )

inherit qmake-utils xdg-utils python-single-r1

DESCRIPTION="A Qt and C++ GUI for radare2 reverse engineering framework"
HOMEPAGE="https://cutter.re https://github.com/radareorg/cutter/"
SRC_URI="https://github.com/radareorg/cutter/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DEPEND="
${PYTHON_DEPS}
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
~dev-util/radare2-4.5.1
"

RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-1.10.3-python3-config.patch"
)

src_configure() {
local myqmakeargs=(
CUTTER_ENABLE_PYTHON=true
PREFIX=\'${EPREFIX}/usr\'
)

eqmake5 "${myqmakeargs[@]}" src
}

src_install() {
emake INSTALL_ROOT="${D}" install
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit 9cf42da

Please sign in to comment.