Skip to content

Commit

Permalink
app-text/blogc: initial commit
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.15
  • Loading branch information
Rafael G. Martins committed Aug 18, 2015
1 parent bf9a47c commit 9d2a84f
Show file tree
Hide file tree
Showing 4 changed files with 138 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/blogc/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST blogc-0.1-beta.1.tar.xz 242960 SHA256 2673df3b2fbd13234a82c26cb9fb4db5560e4b6475b883d8092362b0e0873d5a SHA512 c111145552f200f27be38b100061c119d49125d0802582d54f27e2c35bda41b029803da7bd82798a437df49ea3a1f112ba490b3c72ca4692938d7211be775231 WHIRLPOOL 1495972f4c47c7fe5f7f56d097380cc47a753dedde6d9876970449455e173c2c92de9b4bb0c820ecdd0abe4372183684aa9657f7c8e951fd1f78400786d681a4
59 changes: 59 additions & 0 deletions app-text/blogc/blogc-0.1_beta1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://github.com/blogc/blogc.git
https://github.com/blogc/blogc.git"
inherit git-r3 autotools
fi

DESCRIPTION="A blog compiler"
HOMEPAGE="http://blogc.org/"

MY_PV="${PV/_/-}"
MY_PV="${MY_PV/beta/beta.}"

MY_P="${PN}-${MY_PV}"

SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
KEYWORDS="~amd64 ~x86"
if [[ ${PV} = *9999* ]]; then
SRC_URI=""
KEYWORDS=""
DEPEND="app-text/ronn"
else
S="${WORKDIR}/${MY_P}"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND=""

# pkg-config is used only to find cmocka libraries
DEPEND="${DEPEND}
test? (
virtual/pkgconfig
dev-util/cmocka )"

src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
default
}

src_configure() {
local myconf=""
if [[ ${PV} = *9999* ]]; then
myconf+="--enable-ronn"
else
myconf+="--disable-ronn"
fi
econf \
$(use_enable test tests) \
--disable-valgrind \
${myconf}
}
59 changes: 59 additions & 0 deletions app-text/blogc/blogc-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://github.com/blogc/blogc.git
https://github.com/blogc/blogc.git"
inherit git-r3 autotools
fi

DESCRIPTION="A blog compiler"
HOMEPAGE="http://blogc.org/"

MY_PV="${PV/_/-}"
MY_PV="${MY_PV/beta/beta.}"

MY_P="${PN}-${MY_PV}"

SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
KEYWORDS="~amd64 ~x86"
if [[ ${PV} = *9999* ]]; then
SRC_URI=""
KEYWORDS=""
DEPEND="app-text/ronn"
else
S="${WORKDIR}/${MY_P}"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND=""

# pkg-config is used only to find cmocka libraries
DEPEND="${DEPEND}
test? (
virtual/pkgconfig
dev-util/cmocka )"

src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
default
}

src_configure() {
local myconf=""
if [[ ${PV} = *9999* ]]; then
myconf+="--enable-ronn"
else
myconf+="--disable-ronn"
fi
econf \
$(use_enable test tests) \
--disable-valgrind \
${myconf}
}
19 changes: 19 additions & 0 deletions app-text/blogc/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>[email protected]</email>
<name>Rafael G. Martins</name>
</maintainer>
<longdescription lang="en">
blogc(1) is a blog compiler. It converts source files and templates
into blog/website resources.
</longdescription>
<upstream>
<maintainer status="active">
<email>[email protected]</email>
<name>Rafael G. Martins</name>
</maintainer>
<remote-id type="github">blogc/blogc</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 9d2a84f

Please sign in to comment.