Skip to content

Commit

Permalink
app-admin/hcloud: version bump to 1.31.1
Browse files Browse the repository at this point in the history
Signed-off-by: Agostino Sarubbo <[email protected]>
  • Loading branch information
asarubbo committed Dec 8, 2022
1 parent 8c1e5b3 commit 9d2c6f1
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/hcloud/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST hcloud-1.30.3.tar.xz 1690980 BLAKE2B 115a6769d5bd5e6a10d812502506f9921a7659a262eea7088c88205e9fc748a570c1c9830e5061923f1be18a64d96104e6e930c9edc3316645e5d86450fbf69c SHA512 64bc692b8d098149815ba63aec8346a7f4f2ff7461fac3369343595a733a5c727b41ec8341e4eee1a98804b14bfc5a94ff9fc0621abb798d381d9bc802818b77
DIST hcloud-1.30.4.tar.xz 1725492 BLAKE2B 25af9abb1bcc3e7dce880774716c1abe8e4c7da52e5ae7e7bf1c872e50ee0f66358b981df3401cb97ede1b6c6950b97751b8200a72713d9dcf557891b3e7d81e SHA512 d3572be3ebce21d3dece129d391261fd1ff8a769660509cd67946815d1782d5dcf003b2539b3eb9a9b6e40bfd9b452e438fc7b0ff2805a7808ad8ad9f32c3ed0
DIST hcloud-1.31.1.tar.xz 1735560 BLAKE2B 66b2deaefbf61a72bf6a9e004c29d1198e5cfd40956e9936d5db27903aff5f8151c230da61b33ce4231885613d53ba5c96f99fb10df03fdcc241ec32fa465de5 SHA512 b61683ea54455be1db0ae196615642d0247e56ca51f3848847fba09124a45606aea2495f4408694acc5e819d9dc79ffdb2b9ce4e85aade7dea0335be94461066
34 changes: 34 additions & 0 deletions app-admin/hcloud/hcloud-1.31.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="A command-line interface for Hetzner Cloud"
HOMEPAGE="https://github.com/hetznercloud/cli"
SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

IUSE=""
DEPEND="dev-lang/go:="
RESTRICT="strip"
QA_FLAGS_IGNORED=".*"

src_compile() {
go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
}

src_test() {
# For upstream a simple test is run 'hcloud version'
./hcloud version
if [[ $? -ne 0 ]]
then
die "Test failed"
fi
}

src_install() {
dobin ${PN}
}

0 comments on commit 9d2c6f1

Please sign in to comment.