Skip to content

Commit

Permalink
app-office/abiword: Version bump to 3.0.2
Browse files Browse the repository at this point in the history
Gentoo-bug: 488462, 582788, 595250
* EAPI=6

Package-Manager: portage-2.3.2
  • Loading branch information
SoapGentoo committed Nov 12, 2016
1 parent c5e1ca1 commit 9d2e95e
Show file tree
Hide file tree
Showing 10 changed files with 1,492 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/abiword/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST abiword-3.0.1.tar.gz 11144990 SHA256 e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6 SHA512 c655aabe0ba0a9880f30808e26c02ec3280c750625faa482a68d4d336742f85659a7af7d6413d8813b82d3de0a3f6b61b6f6898f030bb921d792ad866879dbcf WHIRLPOOL 7d06614673d7275df57999783205b98a41f0588c7eadfdd4d29e30dd52cf1c44aa5b07e90d47ece328119da9877aec7754511a40768b6ea844c3683abefdcad7
DIST abiword-3.0.2.tar.gz 11154333 SHA256 afbfd458fd02989d8b0c6362ba8a4c14686d89666f54cfdb5501bd2090cf3522 SHA512 29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 WHIRLPOOL c916d144a68f6581927c6d75d12cac2ae39e213e1ca928f190c19ffd8843cb0c463e671ec4ef6b21ab0d4c49a084e04a8b7eeed75bf45fdc0f76dfa4391ff898
138 changes: 138 additions & 0 deletions app-office/abiword/abiword-3.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,138 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools gnome2

DESCRIPTION="Fully featured yet light and fast cross platform word processor"
HOMEPAGE="http://www.abisource.com/"
SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~mips ~x86 ~amd64-linux ~x86-linux"
IUSE="calendar collab cups debug eds +goffice grammar +introspection latex map math ots +plugins readline redland spell wordperfect wmf thesaurus"

# You need 'plugins' enabled if want to enable the extra plugins
REQUIRED_USE="!plugins? ( !collab !grammar !latex !math !ots !readline !thesaurus !wordperfect !wmf )"

RDEPEND="
>=app-text/wv-1.2
>=dev-libs/fribidi-0.10.4
>=dev-libs/glib-2.16:2
>=dev-libs/libgcrypt-1.4.5:0=
dev-libs/libxslt
>=gnome-base/librsvg-2.16:2
>=gnome-extra/libgsf-1.14.18:=
>=media-libs/libpng-1.2:0=
virtual/jpeg:0
>=x11-libs/cairo-1.10[X]
>=x11-libs/gtk+-3.0.8:3[cups?]
calendar? ( >=dev-libs/libical-0.46:= )
eds? ( >=gnome-extra/evolution-data-server-3.6.0:= )
goffice? ( >=x11-libs/goffice-0.10.2:0.10 )
introspection? ( >=dev-libs/gobject-introspection-1.0.0 )
map? ( >=media-libs/libchamplain-0.12 )
plugins? (
collab? (
>=dev-libs/libxml2-2.4
>=net-libs/loudmouth-1
net-libs/libsoup:2.4
net-libs/gnutls:= )
grammar? ( >=dev-libs/link-grammar-4.2.1 )
math? ( >=x11-libs/gtkmathview-0.7.5 )
ots? ( >=app-text/ots-0.5-r1 )
readline? ( sys-libs/readline:0= )
thesaurus? ( >=app-text/aiksaurus-1.2[gtk] )
wordperfect? (
app-text/libwpd:0.10
app-text/libwpg:0.3 )
wmf? ( >=media-libs/libwmf-0.2.8 )
)
redland? (
>=dev-libs/redland-1.0.10
>=dev-libs/rasqal-0.9.17 )
spell? ( >=app-text/enchant-1.2 )
!<app-office/abiword-plugins-2.8
"
DEPEND="${RDEPEND}
dev-lang/perl
>=dev-libs/boost-1.40.0
virtual/pkgconfig
collab? ( dev-cpp/asio )
"

PATCHES=(
"${FILESDIR}"/${PN}-2.8.3-desktop.patch
"${FILESDIR}"/${PN}-2.6.0-boolean.patch
"${FILESDIR}"/${PN}-3.0.0-librevenge.patch
"${FILESDIR}"/${PN}-3.0.0-link-grammar-5-second.patch
"${FILESDIR}"/${PN}-3.0.0-libwp.patch
"${FILESDIR}"/${PN}-3.0.1-libwps-0.4.patch
"${FILESDIR}"/${PN}-3.0.1-fixwps.patch
"${FILESDIR}"/${PN}-3.0.2-fix-installing-readme.patch
)

src_prepare() {
gnome2_src_prepare
eautoreconf
}

src_configure() {
local plugins=()

if use plugins; then
# Plugins depending on libgsf
plugins=(t602 docbook clarisworks wml kword hancom openwriter pdf
loadbindings mswrite garble pdb applix opendocument sdw xslfo)

# Plugins depending on librsvg
plugins+=(svg)

# Plugins not depending on anything
plugins+=(gimp bmp freetranslation iscii s5 babelfish opml eml wikipedia
gdict passepartout google presentation urldict hrtext mif openxml)

# inter7eps: eps.h
# libtidy: gsf + tidy.h
# paint: windows only ?
use collab && plugins+=(collab)
use goffice && plugins+=(goffice)
use latex && plugins+=(latex)
use math && plugins+=(mathview)
use ots && plugins+=(ots)
# psion: >=psiconv-0.9.4
use readline && plugins+=(command)
use thesaurus && plugins+=(aiksaurus)
use wmf && plugins+=(wmf)
# wordperfect: >=wpd-0.9 >=wpg-0.2
use wordperfect && plugins+=(wpg)
fi

gnome2_src_configure \
--enable-plugins="${plugins[*]}" \
--disable-static \
--disable-default-plugins \
--disable-builtin-plugins \
--disable-collab-backend-telepathy \
--enable-clipart \
--enable-statusbar \
--enable-templates \
--with-gio \
--without-gnomevfs \
--without-gtk2 \
$(use_enable debug) \
$(use_with goffice goffice) \
$(use_with calendar libical) \
$(use_enable cups print) \
$(use_enable collab collab-backend-xmpp) \
$(use_enable collab collab-backend-tcp) \
$(use_enable collab collab-backend-service) \
$(use_with eds evolution-data-server) \
$(use_enable introspection) \
$(use_with map champlain) \
$(use_with redland) \
$(use_enable spell)
}
13 changes: 13 additions & 0 deletions app-office/abiword/files/abiword-2.6.0-boolean.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff -u -r abiword-2.6.0.orig/src/text/ptbl/xp/pd_Style.h abiword-2.6.0/src/text/ptbl/xp/pd_Style.h
--- abiword-2.6.0.orig/src/text/ptbl/xp/pd_Style.h 2008-03-18 23:16:20.000000000 +0100
+++ abiword-2.6.0/src/text/ptbl/xp/pd_Style.h 2008-03-25 17:14:23.000000000 +0100
@@ -23,6 +23,9 @@
#ifndef PD_STYLE_H
#define PD_STYLE_H

+#ifndef FALSE
+#define FALSE 0
+#endif /* FALSE */
#include "ut_types.h"
#include "pt_Types.h"
#include "ut_xml.h"
12 changes: 12 additions & 0 deletions app-office/abiword/files/abiword-2.8.3-desktop.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -u -r abiword-2.8.3.orig/abiword.desktop abiword-2.8.3/abiword.desktop
--- abiword-2.8.3.orig/abiword.desktop 2010-04-02 19:59:58.000000000 +0200
+++ abiword-2.8.3/abiword.desktop 2010-04-08 09:07:01.000000000 +0200
@@ -6,7 +6,7 @@
Categories=Office;WordProcessor;GNOME;GTK;X-Red-Hat-Base;
StartupNotify=true
X-Desktop-File-Install-Version=0.9
-MimeType=application/x-abiword;text/x-abiword;text/x-xml-abiword;text/plain;application/msword;application/rtf;application/vnd.plain;application/xhtml+xml;text/html;application/x-crossmark;application/docbook+xml;application/x-t602;application/vnd.oasis.opendocument.text;application/vnd.oasis.opendocument.text-template;application/vnd.oasis.opendocument.text-web;application/vnd.sun.xml.writer;application/vnd.stardivision.writer;text/vnd.wap.wml;application/wordperfect6;application/wordperfect5.1;application/vnd.wordperfect;application/x-abicollab;
+MimeType=application/x-abiword;text/x-abiword;text/x-xml-abiword;text/plain;application/msword;application/rtf;application/vnd.plain;application/xhtml+xml;text/html;application/x-crossmark;application/docbook+xml;application/x-t602;application/vnd.oasis.opendocument.text;application/vnd.oasis.opendocument.text-template;application/vnd.oasis.opendocument.text-web;application/vnd.sun.xml.writer;application/vnd.stardivision.writer;text/vnd.wap.wml;application/wordperfect6;application/wordperfect5.1;application/vnd.wordperfect;application/x-abicollab;application/x-applix-word;application/x-mswrite;application/x-kword;application/x-mif;
Name=AbiWord
GenericName=Word Processor
Comment=Compose, edit, and view documents
Loading

0 comments on commit 9d2e95e

Please sign in to comment.