forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
xfce-extra/xfce4-weather-plugin: Version bump to 0.8.8
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST xfce4-weather-plugin-0.8.7.tar.bz2 2976092 SHA256 071e71106868c7d90c936256d837ca834d0ca6f54daea59a9b5fc11b318e65b0 SHA512 681b500cbeead09e61b2d30960853503e90ece6a73871b0a603d32026d7781096e5dac8fc456fb80a9a3a69c65f2ff1e297ffab520e7a7b27a31d5b7627710c8 WHIRLPOOL b195c2bf4a517623f3ad869f4ef70776de0ee49a99644207869c9ab6b3bce8e81e7f8e46143b38af468f638e5d34b7ca9d2878f50dc6468007a04152360a93c2 | ||
DIST xfce4-weather-plugin-0.8.8.tar.bz2 2979971 SHA256 651b722714fdafde3f548f183958c34e1539cf563193d7e51f28bfb6933d6d3f SHA512 98e35d11bc57edf926228d7da2c5fbd4320f9dce0ff4fab232b81a98f4ff979c80575c077b9ffb161c54bf81f5da400b518838be881fbea82e5b1c37cae2c01a WHIRLPOOL 47118162fa35ab3b69018605190802ce17a2df9dcc4712bea267d262afe88c226bd0b58c9eb323957fe47e8531003fb6abe2f5dd4c05ea488874cc345966fa1d |
38 changes: 38 additions & 0 deletions
38
xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.8.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit xfconf | ||
|
||
DESCRIPTION="A weather plug-in for the Xfce desktop environment" | ||
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin" | ||
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86" | ||
IUSE="debug upower" | ||
|
||
RDEPEND=">=dev-libs/glib-2.20:= | ||
dev-libs/libxml2:= | ||
>=net-libs/libsoup-2.32:= | ||
>=x11-libs/gtk+-2.14:2= | ||
>=xfce-base/libxfce4ui-4.10:= | ||
>=xfce-base/libxfce4util-4.10:= | ||
>=xfce-base/xfce4-panel-4.10:= | ||
upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )" | ||
DEPEND="${RDEPEND} | ||
dev-util/intltool | ||
virtual/pkgconfig" | ||
|
||
pkg_setup() { | ||
# For GEONAMES_USERNAME, read README file and ask ssuominen@! | ||
XFCONF=( | ||
$(use_enable upower) | ||
$(xfconf_use_debug) | ||
GEONAMES_USERNAME=Gentoo | ||
) | ||
|
||
DOCS=( AUTHORS ChangeLog NEWS README TODO ) | ||
} |