Skip to content

Commit

Permalink
mail-client/roundcube: add 1.6.8
Browse files Browse the repository at this point in the history
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Aug 5, 2024
1 parent 3edab8e commit 9e2287f
Show file tree
Hide file tree
Showing 2 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/roundcube/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST roundcubemail-1.6.7-complete.tar.gz 5899345 BLAKE2B c22803f3651c32f863081afe28d05e4b7918ba0cb1238c11de646a0fe3a16a6faff633a3a193a5813a50be710a71a8900d049f0e628661b6c7c036c0d69055ab SHA512 aedc940e769e881d448eced2ef0b603c87f9a9e18624cae4d14a946e6f9509c827f75e6fb294a760970e37caa9ab0bfb0a7ec8843b12542f59f350948d2d8d3b
DIST roundcubemail-1.6.8-complete.tar.gz 5899212 BLAKE2B c5069fb038afe96dda75c815e564b23c629dc5683af7f428622556045f84e1cbe38b163609a6faefbc86d94d6f0bbab6778e9e62830fe68f98ea311cfbbdbbe1 SHA512 91bf08d5c2643b81efee87cae7045adad7fd6867bef6847ff64eac2490d84b38d08a8c6622fb947da67ecd43eaecb83ab4f3b5ebecc75e9f6dd511db6eb88128
97 changes: 97 additions & 0 deletions mail-client/roundcube/roundcube-1.6.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit webapp

MY_PN=${PN}mail
MY_PV=${PV/_/-}
MY_P=${MY_PN}-${MY_PV}

DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
HOMEPAGE="https://roundcube.net"

# roundcube is GPL-licensed, the rest of the licenses here are
# for bundled PEAR components, googiespell and utf8.class.php
LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"

IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
REQUIRED_USE="|| ( mysql postgres sqlite )"

# this function only sets DEPEND so we need to include that in RDEPEND
need_httpd_cgi

RDEPEND="
${DEPEND}
>=dev-lang/php-7.4.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
virtual/httpd-php
change-password? (
dev-lang/php[sockets]
)
enigma? (
app-crypt/gnupg
)
mysql? (
|| (
dev-lang/php[mysql]
dev-lang/php[mysqli]
)
)
spell? ( dev-lang/php[curl,spell] )
"

if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
EGIT_BRANCH="master"
BDEPEND="${BDEPEND}
app-arch/unzip
dev-php/composer
net-misc/curl"
else
SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi

src_unpack() {
if [[ "${PV}" == *9999* ]]; then
git-r3_src_unpack
pushd "${S}" > /dev/null || die
rm Makefile || die
mv composer.json-dist composer.json || die
composer install --no-dev || die
./bin/install-jsdeps.sh || die
popd > /dev/null || die
else
default
fi
}

src_install() {
webapp_src_preinst

dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md

insinto "${MY_HTDOCSDIR}"
doins -r [[:lower:]]* SQL
doins .htaccess

webapp_serverowned "${MY_HTDOCSDIR}"/logs
webapp_serverowned "${MY_HTDOCSDIR}"/temp

webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"

webapp_src_install
}

pkg_postinst() {
webapp_pkg_postinst

if [[ -n ${REPLACING_VERSIONS} ]]; then
elog "You can review the post-upgrade instructions at:"
elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
fi
}

0 comments on commit 9e2287f

Please sign in to comment.