Skip to content

Commit

Permalink
dev-python/ply: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 10, 2015
1 parent f5007f9 commit 9e23b42
Show file tree
Hide file tree
Showing 3 changed files with 49 additions and 4 deletions.
1 change: 1 addition & 0 deletions dev-python/ply/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ply-3.4.tar.gz 138342 SHA256 af435f11b7bdd69da5ffbc3fecb8d70a7073ec952e101764c88720cdefb2546b SHA512 6f6ee528393ff83eff2530ca468caf12e4c89b817a38302738597f1478dd41758036c8f32f88f60d1a26e70d9cfceab5530ddcfd3f058c1ee722be95c27e6bcc WHIRLPOOL f2f58e2d0c1170d35554999ca643c102d6821a7535b5782ee7317a4100cf56b5648d643c274cefd66a7b484ae3a9e952bcf4b98d50e7fd1ff220853f982a2f4c
DIST ply-3.6.tar.gz 281690 SHA256 61367b9eb2f4b819f69ea116750305270f1df8859992c9e356d6a851f25a4b47 SHA512 1a408d7cd4cdc9d747154623672e6baaf37ad2190cb9d6d6a7c1e1cc3cb40f15547734441b8fc99ecd67d7804d767576bdf0ed219cc669bf3d0df37498c55c55 WHIRLPOOL 2868a0046519750a446b683a85966650407afc1ea32ab6d8209b46b280529ca6aa8c47816782020b4c90f6f92d4733dd07565b6518e20c7a036d743edc629496
DIST ply-3.8.tar.gz 157286 SHA256 e7d1bdff026beb159c9942f7a17e102c375638d9478a7ecd4cc0c76afd8de0b8 SHA512 2c8cf0ee49ca6dec9ec8d5146e98885e871c26125fb5764988fbefae984ee94b4240f265762aaab26d6ec24989b35a4fd6905c3c0d14aac8a085e89b7d6159ef WHIRLPOOL f4258065a479033d2100c2fe9f725a8fbdfb278dabc71a6aa27d7846352dc11496cf34596a0ca0669ce72238702978f1c8a587313410218aa014b80bc98dec37
8 changes: 4 additions & 4 deletions dev-python/ply/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
<longdescription>
<herd>python</herd>
<longdescription>
PLY is a Python-only implementation of the popular compiler construction
tools lex and yacc. The implementation borrows ideas from a number of
previous efforts; most notably John Aycock's SPARK toolkit. However,
Expand All @@ -11,8 +11,8 @@ the C version of lex and yacc. The other significant feature of PLY is
that it provides extensive input validation and error reporting--much
more so than other Python parsing tools.
</longdescription>
<longdescription lang="ja">
<longdescription lang="ja">
PLYはLexとYaccの有名なコンパイラ・コンストラクション・ツールのPython言語実装です
。この実装は以前の試みから幾つものアイディアを借りています。そのほとんどがJohn AycockのSPARKツールキットからです。しかしながら、実装の全体像はC言語によるLexとYaccにより近いモデルです。PLYの他の重要点は幅広い入力バリデーションとエラー報告を>提供する点です。 -- その二点は他のPython言語パーサーより優れています。
。この実装は以前の試みから幾つものアイディアを借りています。そのほとんどがJohn AycockのSPARKツールキットからです。しかしながら、実装の全体像はC言語によるLexとYaccにより近いモデルです。PLYの他の重要点は幅広い入力バリデーションとエラー報告を&gt;提供する点です。 -- その二点は他のPython言語パーサーより優れています。
</longdescription>
</pkgmetadata>
44 changes: 44 additions & 0 deletions dev-python/ply/ply-3.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )

inherit distutils-r1

DESCRIPTION="Python Lex-Yacc library"
HOMEPAGE="http://www.dabeaz.com/ply/ https://pypi.python.org/pypi/ply"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="examples"

RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

# See bug #458648 for reference
RESTRICT="test"

DOCS=( ANNOUNCE CHANGES TODO )

PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )

python_test() {
cp -r -l test "${BUILD_DIR}"/ || die
cd "${BUILD_DIR}"/test || die

local t
for t in testlex.py testyacc.py; do
"${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
done
}

python_install_all() {
local HTML_DOCS=( doc/. )
use examples && local EXAMPLES=( example/. )
distutils-r1_python_install_all
}

0 comments on commit 9e23b42

Please sign in to comment.