Skip to content

Commit

Permalink
mail-mta/msmtp: Bump to version 1.8.14
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Dec 24, 2020
1 parent c84f5f6 commit 9e331a9
Show file tree
Hide file tree
Showing 2 changed files with 146 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-mta/msmtp/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST msmtp-1.8.12.tar.xz 364712 BLAKE2B 94707d18d9be71e8e51413cdcc55887fc15bd7d0f059d54cfcf4e07b5589febbb9ed4025206e3b82d1b12edad45086d3ad8a47fb3d37488a49e46984d7b7bc32 SHA512 8620e5e9a88a49769cfdbf2aa83842b230b3fd1584641d17129cb404e3c9696edd5a28237ef46a115ca82d2a846c0f653eaa837ba6f8512f8b57493d64451df8
DIST msmtp-1.8.13.tar.xz 359536 BLAKE2B 824d88b571ac1dfd78046f1939fa83c4fad9679bce993c20d073df5cd431deee1ca36119123d307d788be13d700901c13c54ba47496f2148cb9fbf9e2308698c SHA512 1b466fc518d0468a8febdf238a6d422fabb95be8158d2e52e38aeb5e5b21661af9791ff8ed82f72f111cebe2ce1b93deabeb91dca4f06f09cf765152095a1cfd
DIST msmtp-1.8.14.tar.xz 363988 BLAKE2B 46953512002365f8e80e1bdf80f8513845bae62bcfcbe8334642b7a51f2d7da7719e3c1812d43e2a887162d45a1b29893744f452f6ac7dc205fd72a578eec39f SHA512 fa274849082553b14aef922c43b84fa6226a26638747ed3ef6baae9d97ff753b24f5eca055426c2e0355df81b2458f524d940faf2a7db771d80fb027e9f45e8b
DIST msmtp-1.8.7.tar.xz 340908 BLAKE2B 5241acf54d5a6af6ccf2c3bfd33954a5235af2d2cb467e4134401538e60e1847489a7a599359e2d13202ea9637c32a67ec5180372b139e06f6d47f060cba6c8f SHA512 5a079cb90b48853ad812125e8b341f5bcd5f5ba4725d62c37210050896527b63f993aa6393f1d4107636153bf0ed84b0288e88a7e78a119c66b2d58f1e69a67d
145 changes: 145 additions & 0 deletions mail-mta/msmtp/msmtp-1.8.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,145 @@
# Copyright 2004-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit fcaps multilib

DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
HOMEPAGE="https://marlam.de/msmtp/"
SRC_URI="https://marlam.de/msmtp/releases/${P}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="daemon doc gnome-keyring idn +mta nls sasl ssl vim-syntax"

# fcaps.eclass unconditionally defines "filecaps" USE flag which we need for
# USE="daemon" in order to set the caps we need.
REQUIRED_USE="daemon? ( filecaps )"

# Upstream discourages usage of openssl. See also
# https://marlam.de/msmtp/news/openssl-discouraged/
DEPEND="
gnome-keyring? ( app-crypt/libsecret )
idn? ( net-dns/libidn2:= )
nls? ( virtual/libintl )
sasl? ( virtual/gsasl )
ssl? ( net-libs/gnutls[idn?] )
"

RDEPEND="${DEPEND}
net-mail/mailbase
daemon? (
acct-group/msmtpd
acct-user/msmtpd
)
mta? (
!mail-mta/courier
!mail-mta/esmtp
!mail-mta/exim
!mail-mta/mini-qmail
!mail-mta/netqmail
!mail-mta/nullmailer
!mail-mta/postfix
!mail-mta/qmail-ldap
!mail-mta/sendmail
!mail-mta/opensmtpd
!<mail-mta/ssmtp-2.64-r2
!>=mail-mta/ssmtp-2.64-r2[mta]
)
"

BDEPEND="
doc? ( virtual/texi2dvi )
nls? ( sys-devel/gettext )
virtual/pkgconfig
"

DOCS="AUTHORS ChangeLog NEWS README THANKS doc/msmtprc*"

src_prepare() {
# Use default Gentoo location for mail aliases
sed 's:/etc/aliases:/etc/mail/aliases:' \
-i scripts/find_alias/find_alias_for_msmtp.sh || die

default
}

src_configure() {
local myeconfargs=(
--disable-gai-idn
$(use_enable nls)
$(use_with daemon msmtpd)
$(use_with gnome-keyring libsecret)
$(use_with idn libidn)
$(use_with sasl libgsasl)
$(use_with ssl tls gnutls)
)
econf "${myeconfargs[@]}"
}

src_compile() {
default

if use doc ; then
cd doc || die
emake html pdf
fi
}

src_install() {
default

if use daemon ; then
fcaps CAP_NET_BIND_SERVICE usr/bin/msmtpd
newinitd "${FILESDIR}"/msmtpd.init msmtpd
newconfd "${FILESDIR}"/msmtpd.confd msmtpd
fi

if use doc ; then
dodoc doc/msmtp.{html,pdf}
fi

if use mta ; then
dosym ../bin/msmtp /usr/sbin/sendmail
dosym ../bin/msmtp /usr/$(get_libdir)/sendmail
fi

if use vim-syntax ; then
insinto /usr/share/vim/vimfiles/syntax
doins scripts/vim/msmtp.vim
fi

insinto /etc
newins doc/msmtprc-system.example msmtprc

src_install_contrib find_alias find_alias_for_msmtp.sh
src_install_contrib msmtpqueue "*.sh" "README ChangeLog"
src_install_contrib msmtpq "msmtpq msmtp-queue" README.msmtpq
src_install_contrib set_sendmail set_sendmail.sh set_sendmail.conf
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
einfo "Please edit ${EROOT}/etc/msmtprc before first use."
einfo "In addition, per user configuration files can be placed"
einfo "as '~/.msmtprc'. See the msmtprc-user.example file under"
einfo "/usr/share/doc/${PF}/ for an example."
fi
}

src_install_contrib() {
subdir="$1"
bins="$2"
docs="$3"
local dir=/usr/share/${PN}/${subdir}
insinto ${dir}
exeinto ${dir}
for i in ${bins} ; do
doexe scripts/${subdir}/${i}
done
for i in ${docs} ; do
newdoc scripts/${subdir}/${i} ${subdir}.${i}
done
}

0 comments on commit 9e331a9

Please sign in to comment.