forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-db/mariadb-connector-c: New package to provide libmariadb.so
Package-Manager: Portage-2.3.24, Repoman-2.3.6
- Loading branch information
Brian Evans
committed
Feb 28, 2018
1 parent
c44bb20
commit 9e503d7
Showing
4 changed files
with
126 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST mariadb-connector-c-3.0.3-src.tar.gz 666928 BLAKE2B 83181949f1867909fd96696ac5cc9d11433a0c772ecb97d862983916b235d380fd84462d547faf42756d6698dd9dbe7dcd4d6b1d0f6336e147f5a597108ea025 SHA512 6da66a32165cb74b106bf94e13a35d4bb38f05e5d2b3ff3740862dfc0892a7705977c1394b4f84b8e1f1e50a59a3fadbc62e7733b1feb532c6368a9fc262db04 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,9 @@ | ||
--- a/mariadb_config/CMakeLists.txt 2016-02-12 21:21:06.981021227 -0500 | ||
+++ b/mariadb_config/CMakeLists.txt 2016-02-12 22:06:02.397130410 -0500 | ||
@@ -40,5 +44,5 @@ | ||
# Installation | ||
# | ||
INSTALL(TARGETS mariadb_config | ||
- DESTINATION "bin" | ||
+ DESTINATION ${INSTALL_BINDIR} | ||
COMPONENT Development) |
105 changes: 105 additions & 0 deletions
105
dev-db/mariadb-connector-c/mariadb-connector-c-3.0.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,105 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
VCS_INHERIT="" | ||
if [[ "${PV}" == 9999 ]] ; then | ||
VCS_INHERIT="git-r3" | ||
EGIT_REPO_URI="https://github.com/MariaDB/connector-c.git" | ||
KEYWORDS="" | ||
else | ||
MY_PN=${PN#mariadb-} | ||
MY_PV=${PV/_b/-b} | ||
SRC_URI="https://downloads.mariadb.org/f/${MY_PN}-${PV%_beta}/${PN}-${MY_PV}-src.tar.gz?serve -> ${P}-src.tar.gz" | ||
S="${WORKDIR}/${PN}-${MY_PV}-src" | ||
KEYWORDS="~amd64 ~x86" | ||
fi | ||
|
||
inherit cmake-utils multilib-minimal ${VCS_INHERIT} | ||
|
||
MULTILIB_CHOST_TOOLS=( /usr/bin/mariadb_config ) | ||
|
||
MULTILIB_WRAPPED_HEADERS+=( | ||
/usr/include/mariadb/mariadb_version.h | ||
) | ||
|
||
DESCRIPTION="C client library for MariaDB/MySQL" | ||
HOMEPAGE="http://mariadb.org/" | ||
LICENSE="LGPL-2.1" | ||
|
||
SLOT="0/3" | ||
IUSE="+curl gnutls kerberos libressl mysqlcompat +ssl static-libs" | ||
|
||
DEPEND="sys-libs/zlib:=[${MULTILIB_USEDEP}] | ||
virtual/libiconv:=[${MULTILIB_USEDEP}] | ||
curl? ( net-misc/curl:0=[${MULTILIB_USEDEP}] ) | ||
kerberos? ( || ( app-crypt/mit-krb5[${MULTILIB_USEDEP}] | ||
app-crypt/heimdal[${MULTILIB_USEDEP}] ) ) | ||
ssl? ( | ||
gnutls? ( >=net-libs/gnutls-3.3.24:0=[${MULTILIB_USEDEP}] ) | ||
!gnutls? ( | ||
libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] ) | ||
!libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] ) | ||
) | ||
) | ||
" | ||
RDEPEND="${DEPEND} | ||
mysqlcompat? ( | ||
!dev-db/mysql[client-libs(+)] | ||
!dev-db/mysql-cluster[client-libs(+)] | ||
!dev-db/mariadb[client-libs(+)] | ||
!dev-db/mariadb-galera[client-libs(+)] | ||
!dev-db/percona-server[client-libs(+)] | ||
!dev-db/mysql-connector-c ) | ||
!>=dev-db/mariadb-10.2.0[client-libs(+)] | ||
" | ||
PATCHES=( | ||
"${FILESDIR}/gentoo-layout-3.0.patch" ) | ||
|
||
src_prepare() { | ||
local gpluginconf="${T}/gentoo-plugins.cmake" | ||
touch "${gpluginconf}" || die | ||
# Plugins cannot be disabled by a build switch, redefine them in our own file to be included | ||
if ! use kerberos ; then | ||
echo 'REGISTER_PLUGIN("AUTH_GSSAPI" "" "auth_gssapi_plugin" "OFF" "auth_gssapi_client" 1)' \ | ||
>> "${gpluginconf}" || die | ||
fi | ||
if ! use curl ; then | ||
echo 'REGISTER_PLUGIN("REMOTEIO" "" "remote_io_plugin" "OFF" "remote_io" 1)' \ | ||
>> "${gpluginconf}" || die | ||
fi | ||
cmake-utils_src_prepare | ||
} | ||
|
||
multilib_src_configure() { | ||
local mycmakeargs=( | ||
-DWITH_EXTERNAL_ZLIB=ON | ||
-DWITH_SSL:STRING=$(usex ssl $(usex gnutls GNUTLS OPENSSL) OFF) | ||
-DWITH_CURL=$(usex curl ON OFF) | ||
-DAUTH_GSSAPI_PLUGIN_TYPE:STRING=$(usex kerberos ON OFF) | ||
-DINSTALL_LIBDIR="$(get_libdir)" | ||
-DINSTALL_PLUGINDIR="$(get_libdir)/mariadb/plugin" | ||
-DINSTALL_BINDIR=bin | ||
-DPLUGIN_CONF_FILE:STRING="${T}/gentoo-plugins.cmake" | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
multilib_src_install() { | ||
cmake-utils_src_install | ||
if use mysqlcompat ; then | ||
dosym libmariadb.so.3 /usr/$(get_libdir)/libmysqlclient.so.19 | ||
dosym libmariadb.so.3 /usr/$(get_libdir)/libmysqlclient.so | ||
fi | ||
} | ||
|
||
multilib_src_install_all() { | ||
if ! use static-libs ; then | ||
find "${D}" -name "*.a" -delete || die | ||
fi | ||
if use mysqlcompat ; then | ||
dosym mariadb_config /usr/bin/mysql_config | ||
dosym mariadb /usr/include/mysql | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>MySQL</name> | ||
</maintainer> | ||
<use> | ||
<flag name="mysqlcompat">Enable mysqlclient library symbolic links</flag> | ||
</use> | ||
</pkgmetadata> |