Skip to content

Commit

Permalink
dev-ada/e3-core: porting to python3.10 and PEP517
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/827054
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Feb 3, 2022
1 parent 5d7553c commit 9e58e3e
Showing 1 changed file with 8 additions and 3 deletions.
11 changes: 8 additions & 3 deletions dev-ada/e3-core/e3-core-22.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,10 @@
# Copyright 2021 Gentoo Authors
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8,9} )
PYTHON_COMPAT=( python3_{8,9,10} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 toolchain-funcs

DESCRIPTION="Ease the development of portable automated build systems"
Expand Down Expand Up @@ -39,11 +40,15 @@ PATCHES=(
"${FILESDIR}"/${P}-test.patch
)

distutils_enable_tests --install pytest
distutils_enable_tests pytest

src_compile() {
local PLATFORM=x86_64-linux
rm src/e3/os/data/rlimit* || die
$(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c ${LDFLAGS}
distutils-r1_src_compile
}

python_test() {
epytest -p no:markdown
}

0 comments on commit 9e58e3e

Please sign in to comment.