forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.26
- Loading branch information
Michael Sterrett
committed
Apr 1, 2016
1 parent
f7269e7
commit 9e5f28f
Showing
3 changed files
with
155 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST fbzx-2.10.0.tar.bz2 326352 SHA256 deed3d37247e4154bb10325d014461c8caf0c55ca23a611c62035e491a4f960f SHA512 b96ae4029e4ef73d15c851a54c8e057131ba6e0acf03820222aa4d4bc91e8ad497556cce41c5faef230939f1c88423e09e435f9ce91c0e0f183f6eac7843bb36 WHIRLPOOL 97bb0fcbb9d1c5921b7c6f9d4873fd620d2219b71abbaece2453f4417bace91c1b1fab44382f2d63b5aa8c3225f5f865150b51ce534a228712a39543912ea908 | ||
DIST fbzx-3.0.0.tar.gz 435239 SHA256 8c739edd3de599943daea0078220b5c7774fc04b62a24a7a33854e5ee24056f3 SHA512 cf2a01a1dde62da03c1f04e91f226859ae4cf06d099597dc1a1554c4ff9782dd287f9d924083829eee40cf0450c053d818f963f68381f9e16e0e61ca1f3d3083 WHIRLPOOL d56d7c54458f75de135b4e675bc7980ca72bebebbd0461c52db5d9be34faae1000c9d7e52dea6a5a199133edb2a5b9974979ee27dc30d811235c90fca83c908f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit eutils games | ||
|
||
DESCRIPTION="A Sinclair Spectrum emulator, designed to work at full screen using the FrameBuffer" | ||
HOMEPAGE="https://github.com/rastersoft/fbzx" | ||
SRC_URI="https://github.com/rastersoft/fbzx/archive/3.0.0.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="media-libs/libsdl[video] | ||
media-sound/pulseaudio | ||
media-libs/alsa-lib" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
sed -i -e "s|/usr/share/|${GAMES_DATADIR}/${PN}/|g" src/llscreen.cpp || die | ||
epatch "${FILESDIR}"/${P}-gentoo.patch | ||
} | ||
|
||
src_install() { | ||
dogamesbin src/fbzx | ||
insinto "${GAMES_DATADIR}/${PN}" | ||
doins -r data/{keymap.bmp,spectrum-roms} | ||
dodoc AMSTRAD CAPABILITIES FAQ PORTING README* TODO VERSIONS | ||
doicon data/fbzx.svg | ||
make_desktop_entry fbzx FBZX | ||
prepgamesdirs | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,118 @@ | ||
diff -ru fbzx-3.0.0.orig/src/Makefile fbzx-3.0.0/src/Makefile | ||
--- fbzx-3.0.0.orig/src/Makefile 2015-04-01 17:22:47.000000000 -0400 | ||
+++ fbzx-3.0.0/src/Makefile 2016-04-01 13:15:27.230190807 -0400 | ||
@@ -1,78 +1,74 @@ | ||
-CC=g++ -c -O2 | ||
-CPP=g++ -c -O2 | ||
-LN=g++ -O2 | ||
- | ||
CFLAGS += `pkg-config --cflags sdl libpulse-simple alsa` -D D_SOUND_PULSE -D D_SOUND_ALSA -D D_SOUND_OSS | ||
-CPPFLAGS += `pkg-config --cflags sdl libpulse-simple alsa` -D D_SOUND_PULSE -D D_SOUND_ALSA -D D_SOUND_OSS | ||
+CXXFLAGS += `pkg-config --cflags sdl libpulse-simple alsa` -D D_SOUND_PULSE -D D_SOUND_ALSA -D D_SOUND_OSS | ||
LDFLAGS += `pkg-config --libs sdl libpulse-simple alsa` | ||
|
||
|
||
fbzx: cargador.o cmdline.o computer.o emulator.o keyboard.o llscreen.o llsound.o menus.o microdrive.o osd.o screen.o signals.o spk_ay.o tape.o Z80free.o Z80free_codes.o Z80free_codesCB.o Z80free_codesED.o Z80free_codesDD.o Z80free_codesFD.o Z80free_codesDDCB.o Z80free_codesFDCB.o | ||
- $(LN) -o fbzx cargador.o cmdline.o computer.o emulator.o keyboard.o llscreen.o llsound.o menus.o microdrive.o osd.o screen.o signals.o spk_ay.o tape.o Z80free.o Z80free_codes.o Z80free_codesCB.o Z80free_codesED.o Z80free_codesDD.o Z80free_codesFD.o Z80free_codesDDCB.o Z80free_codesFDCB.o $(LDFLAGS) | ||
+ $(CXX) -o fbzx cargador.o cmdline.o computer.o emulator.o keyboard.o llscreen.o llsound.o menus.o microdrive.o osd.o screen.o signals.o spk_ay.o tape.o Z80free.o Z80free_codes.o Z80free_codesCB.o Z80free_codesED.o Z80free_codesDD.o Z80free_codesFD.o Z80free_codesDDCB.o Z80free_codesFDCB.o $(LDFLAGS) | ||
|
||
Z80free.o: z80free/Z80free.c z80free/Z80free.h | ||
- $(CC) -o Z80free.o z80free/Z80free.c | ||
+ $(CXX) -c $(CFLAGS) -o Z80free.o z80free/Z80free.c | ||
|
||
Z80free_codes.o: z80free/Z80free_codes.c z80free/Z80free.h | ||
- $(CC) -o Z80free_codes.o z80free/Z80free_codes.c | ||
+ $(CXX) -c $(CFLAGS) -o Z80free_codes.o z80free/Z80free_codes.c | ||
|
||
Z80free_codesCB.o: z80free/Z80free_codesCB.c z80free/Z80free.h | ||
- $(CC) -o Z80free_codesCB.o z80free/Z80free_codesCB.c | ||
+ $(CXX) -c $(CFLAGS) -o Z80free_codesCB.o z80free/Z80free_codesCB.c | ||
|
||
Z80free_codesED.o: z80free/Z80free_codesED.c z80free/Z80free.h | ||
- $(CC) -o Z80free_codesED.o z80free/Z80free_codesED.c | ||
+ $(CXX) -c $(CFLAGS) -o Z80free_codesED.o z80free/Z80free_codesED.c | ||
|
||
Z80free_codesDD.o: z80free/Z80free_codesDD.c z80free/Z80free.h | ||
- $(CC) -o Z80free_codesDD.o z80free/Z80free_codesDD.c | ||
+ $(CXX) -c $(CFLAGS) -o Z80free_codesDD.o z80free/Z80free_codesDD.c | ||
|
||
Z80free_codesFD.o: z80free/Z80free_codesFD.c z80free/Z80free.h | ||
- $(CC) -o Z80free_codesFD.o z80free/Z80free_codesFD.c | ||
+ $(CXX) -c $(CFLAGS) -o Z80free_codesFD.o z80free/Z80free_codesFD.c | ||
|
||
Z80free_codesDDCB.o: z80free/Z80free_codesDDCB.c z80free/Z80free.h | ||
- $(CC) -o Z80free_codesDDCB.o z80free/Z80free_codesDDCB.c | ||
+ $(CXX) -c $(CFLAGS) -o Z80free_codesDDCB.o z80free/Z80free_codesDDCB.c | ||
|
||
Z80free_codesFDCB.o: z80free/Z80free_codesFDCB.c z80free/Z80free.h | ||
- $(CC) -o Z80free_codesFDCB.o z80free/Z80free_codesFDCB.c | ||
+ $(CXX) -c $(CFLAGS) -o Z80free_codesFDCB.o z80free/Z80free_codesFDCB.c | ||
|
||
cargador.o: cargador.cpp spk_ay.hh keyboard.hh emulator.hh screen.hh osd.hh z80free/Z80free.h computer.hh signals.hh llscreen.hh tape.hh cargador.hh | ||
- $(CPP) $(CPPFLAGS) -o cargador.o cargador.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o cargador.o cargador.cpp | ||
|
||
cmdline.o: cmdline.cpp cmdline.hh | ||
- $(CPP) $(CPPFLAGS) -o cmdline.o cmdline.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o cmdline.o cmdline.cpp | ||
|
||
computer.o: computer.cpp z80free/Z80free.h llsound.hh keyboard.hh computer.hh screen.hh signals.hh llscreen.hh tape.hh emulator.hh osd.hh spk_ay.hh microdrive.hh menus.hh | ||
- $(CPP) $(CPPFLAGS) -o computer.o computer.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o computer.o computer.cpp | ||
|
||
emulator.o: emulator.cpp spk_ay.hh keyboard.hh llsound.hh cmdline.hh computer.hh screen.hh signals.hh llscreen.hh z80free/Z80free.h tape.hh emulator.hh osd.hh microdrive.hh menus.hh cargador.hh | ||
- $(CPP) $(CPPFLAGS) -o emulator.o emulator.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o emulator.o emulator.cpp | ||
|
||
keyboard.o: keyboard.cpp menus.hh llscreen.hh llsound.hh computer.hh screen.hh signals.hh z80free/Z80free.h tape.hh emulator.hh osd.hh keyboard.hh | ||
- $(CPP) $(CPPFLAGS) -o keyboard.o keyboard.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o keyboard.o keyboard.cpp | ||
|
||
llscreen.o: llscreen.cpp osd.hh font.h llscreen.hh | ||
- $(CPP) $(CPPFLAGS) -o llscreen.o llscreen.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o llscreen.o llscreen.cpp | ||
|
||
llsound.o: llsound.cpp emulator.hh screen.hh osd.hh z80free/Z80free.h computer.hh signals.hh llscreen.hh tape.hh llsound.hh | ||
- $(CPP) $(CPPFLAGS) -o llsound.o llsound.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o llsound.o llsound.cpp | ||
|
||
menus.o: menus.cpp spk_ay.hh microdrive.hh z80free/Z80free.h keyboard.hh llsound.hh llscreen.hh menus.hh tape.hh signals.hh emulator.hh screen.hh osd.hh computer.hh cargador.hh | ||
- $(CPP) $(CPPFLAGS) -o menus.o menus.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o menus.o menus.cpp | ||
|
||
microdrive.o: microdrive.cpp osd.hh emulator.hh screen.hh z80free/Z80free.h computer.hh signals.hh llscreen.hh tape.hh microdrive.hh | ||
- $(CPP) $(CPPFLAGS) -o microdrive.o microdrive.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o microdrive.o microdrive.cpp | ||
|
||
osd.o: osd.cpp osd.hh | ||
- $(CPP) $(CPPFLAGS) -o osd.o osd.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o osd.o osd.cpp | ||
|
||
screen.o: screen.cpp keyboard.hh computer.hh screen.hh signals.hh llscreen.hh z80free/Z80free.h tape.hh emulator.hh osd.hh | ||
- $(CPP) $(CPPFLAGS) -o screen.o screen.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o screen.o screen.cpp | ||
|
||
signals.o: signals.cpp signals.hh | ||
- $(CPP) $(CPPFLAGS) -o signals.o signals.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o signals.o signals.cpp | ||
|
||
spk_ay.o: spk_ay.cpp spk_ay.hh llsound.hh computer.hh screen.hh signals.hh llscreen.hh z80free/Z80free.h tape.hh emulator.hh osd.hh | ||
- $(CPP) $(CPPFLAGS) -o spk_ay.o spk_ay.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o spk_ay.o spk_ay.cpp | ||
|
||
tape.o: tape.cpp z80free/Z80free.h tape.hh signals.hh emulator.hh screen.hh osd.hh computer.hh llscreen.hh | ||
- $(CPP) $(CPPFLAGS) -o tape.o tape.cpp | ||
+ $(CXX) -c $(CXXFLAGS) -o tape.o tape.cpp | ||
|
||
diff -ru fbzx-3.0.0.orig/src/menus.cpp fbzx-3.0.0/src/menus.cpp | ||
--- fbzx-3.0.0.orig/src/menus.cpp 2015-04-01 17:22:47.000000000 -0400 | ||
+++ fbzx-3.0.0/src/menus.cpp 2016-04-01 13:15:33.213974823 -0400 | ||
@@ -1691,7 +1691,7 @@ | ||
|
||
void keyboard_menu() { | ||
|
||
- llscreen->paint_picture("fbzx/keymap.bmp"); | ||
+ llscreen->paint_picture("keymap.bmp"); | ||
print_copy(); | ||
wait_key(); | ||
llscreen->clear_screen(); |