Skip to content

Commit

Permalink
version bump (bug #563252)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
Michael Sterrett committed Nov 11, 2015
1 parent bc6a0fb commit 9e6a255
Show file tree
Hide file tree
Showing 5 changed files with 106 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-engines/stratagus/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST stratagus_2.2.7.orig.tar.gz 939967 SHA256 9bdaf207623b60a5e98451128bb7fb649e00ce4aba507320bde63e60f93e8c9f SHA512 965d7b87db209c03fbdb73bbc4a7a660e1de3073638ddb1883d62bd3f837c5785e130e5328cd704cb2859be5e49b1f5f09cadee42a1b202213f24859bf6dc10e WHIRLPOOL 55c975e75d2838fc3cc553f35a42ac5763243bd4c4970df713cc8f762a3aeb24ed23e291ecba5f948b24c1f6bbb4613706a80770d9baed1847cbb4cfcb4869f4
DIST stratagus_2.3.0.orig.tar.gz 1000990 SHA256 d3d124f253e987ee1be396ebcdec31228790163a121a9f4e0049d334114adb99 SHA512 ad38568029aa777fcc2d2e6d4a862b4192bc87354b23712270b9f0a62e269548a08097305e97adcea7bc9d9d506a6d092c578656a1957db808a48f44712a76bf WHIRLPOOL 705ab071fff4dc6d865d8e14c67bf3ef1e64fde45a85115178b4686d3c066907e193d733f5f9d09ec363660925349097f83afa6895a8c27e73c680e27db357a9
19 changes: 19 additions & 0 deletions games-engines/stratagus/files/stratagus-2.3.0-debug.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
From: Julian Ospald <[email protected]>
Date: Thu Oct 18 14:31:37 UTC 2012
Subject: build-system

do not rename the target if debug is enabled

--- stratagus_2.2.7.orig/CMakeLists.txt
+++ stratagus_2.2.7.orig/CMakeLists.txt
@@ -911,10 +911,6 @@
add_executable(stratagus WIN32 ${stratagus_SRCS} ${stratagus_HDRS})
target_link_libraries(stratagus ${stratagus_LIBS})

-if(CMAKE_BUILD_TYPE STREQUAL "Debug")
- set_target_properties(stratagus PROPERTIES OUTPUT_NAME stratagus-dbg)
-endif()
-
if(WIN32 AND MINGW AND ENABLE_STATIC)
set_target_properties(stratagus PROPERTIES LINK_FLAGS "${LINK_FLAGS} -static-libgcc -static-libstdc++ -Wl,--stack,10485760")
endif()
11 changes: 11 additions & 0 deletions games-engines/stratagus/files/stratagus-2.3.0-doc.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- stratagus_2.2.7.orig/CMakeLists.txt
+++ stratagus_2.2.7.orig/CMakeLists.txt
@@ -1050,7 +1050,7 @@
doc/media.html
doc/metaserver_protocol.txt
doc/README-SDL.txt
- DESTINATION share/doc/stratagus
+ DESTINATION ${DOCDIR}
)
install(DIRECTORY doc/graphics doc/scripts ${CMAKE_CURRENT_BINARY_DIR}/doxygen DESTINATION ${DOCDIR})
endif(ENABLE_DOC AND DOXYGEN_FOUND)
3 changes: 3 additions & 0 deletions games-engines/stratagus/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
<use>
<flag name="fluidsynth">compile with support for fluidsynth</flag>
</use>
<upstream>
<remote-id type="launchpad">stratagus</remote-id>
<remote-id type="sourceforge">stratagus</remote-id>
Expand Down
72 changes: 72 additions & 0 deletions games-engines/stratagus/stratagus-2.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit cmake-utils eutils games

DESCRIPTION="A realtime strategy game engine"
HOMEPAGE="https://launchpad.net/stratagus/"
SRC_URI="https://launchpad.net/stratagus/trunk/2.3/+download/stratagus_${PV}.orig.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bzip2 debug doc fluidsynth mikmod mng theora vorbis"

RDEPEND="dev-db/sqlite:3
>=dev-lang/lua-5:0
dev-lua/toluapp
media-libs/libpng:0
virtual/opengl
x11-libs/libX11
media-libs/libsdl[sound,opengl,video]
sys-libs/zlib
bzip2? ( app-arch/bzip2 )
fluidsynth? ( media-sound/fluidsynth )
mikmod? ( media-libs/libmikmod )
mng? ( media-libs/libmng )
vorbis? (
media-libs/libogg
media-libs/libvorbis
theora? ( media-libs/libtheora )
)"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
virtual/pkgconfig"

REQUIRED_USE="theora? ( vorbis )"
PATCHES=( "${FILESDIR}"/${P}-{debug,doc}.patch )

S=${WORKDIR}/${PN}_${PV}.orig

src_configure() {
# there are in-source switches
use debug && CMAKE_BUILD_TYPE=Debug

local mycmakeargs=(
-DGAMEDIR="${GAMES_BINDIR}"
-DBINDIR="${GAMES_BINDIR}"
-DSBINDIR="${GAMES_BINDIR}"
-DDOCDIR="/usr/share/doc/${PF}"
$(cmake-utils_use_with bzip2)
$(cmake-utils_use_enable doc)
$(cmake-utils_use_with fluidsynth)
$(cmake-utils_use_with mikmod)
$(cmake-utils_use_with mng)
$(cmake-utils_use_with vorbis OGGVORBIS)
$(cmake-utils_use_with theora)
-DENABLE_DEV=ON
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
prepgamesdirs
}

0 comments on commit 9e6a255

Please sign in to comment.