Skip to content

Commit

Permalink
app-text/highlight: version bump to 3.57
Browse files Browse the repository at this point in the history
Remove dev-libs/double-conversion from RDEPEND, a dependency of
dev-qt/qtcore not highlight.

Drop inherit of unused flag-o-matic eclass.

Closes: https://bugs.gentoo.org/724342
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Chris Mayo <[email protected]>
Closes: gentoo#11553
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
cjmayo authored and a17r committed May 24, 2020
1 parent cfffa73 commit 9e7066a
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/highlight/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST highlight-3.42.tar.bz2 1294770 BLAKE2B 22c79258be6a665eda8ee17d1de6a97811f97dc4b4491c24b466dc5375d98d865e07ac4e462288d066613bef8bb5a469fa0bdb3065ecf098fc6c4f6090ecb63e SHA512 362150ee396d2b203f11ecc3d011e23b6f8c7d93ff9f8cb0e9e980be6da21e7b3b1ea1e347e3f09129ab0fb1a0aab19ff19f021e643b93a163a99d3882f9bf80
DIST highlight-3.57.tar.bz2 1412857 BLAKE2B c0ee8189294feac3b5e8c6d356634d8074a8960f2010918de52f23515ad4a13626971e9106ecc6d2adbdb45e0ebb66ff60eb3cbe86d2449666e3424f1c0dc3a6 SHA512 a086f6b8c4a4fc0b6651d456b178350a6c59a32cd613451d81b53fe3294eb0f80d673cb64fb615ef91d6c4d4bbc8a57413aec2490d2a5ad67e695ec6e92b3d99
93 changes: 93 additions & 0 deletions app-text/highlight/highlight-3.57.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit qmake-utils toolchain-funcs

DESCRIPTION="Converts source code to formatted text (HTML, LaTeX, etc.) with syntax highlight"
HOMEPAGE="http://www.andre-simon.de/"
SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="examples qt5"

RDEPEND="
dev-lang/lua:0=
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)
"
DEPEND="${RDEPEND}
dev-libs/boost
"
BDEPEND="
virtual/pkgconfig
qt5? ( dev-qt/linguist-tools:5 )
"

myhlopts=(
"CXX=$(tc-getCXX)"
"AR=$(tc-getAR)"
"LDFLAGS=${LDFLAGS}"
"CFLAGS=${CXXFLAGS} -DNDEBUG -std=c++11"
"DESTDIR=${D}"
"PREFIX=${EPREFIX}/usr"
"HL_CONFIG_DIR=${EPREFIX}/etc/highlight/"
"HL_DATA_DIR=${EPREFIX}/usr/share/highlight/"
"doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
"conf_dir=${EPREFIX}/etc/highlight/"
)

src_prepare() {
default

# disable man page compression
sed -e "/GZIP/d" -i makefile || die

sed -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
-i src/core/datadir.cpp || die

if has_version "<dev-lang/lua-5.2"; then
sed -e "s/-DUSE_LUA52//" -i src/makefile || die
fi

# We set it via eqmake5, otherwise it forces clang...
sed -e "s/QMAKE_CC/#QMAKE_CC/g" \
-e "s/QMAKE_CXX /#QMAKE_CXX /g" \
-i src/gui-qt/highlight.pro || die
}

src_configure() {
if use qt5 ; then
pushd src/gui-qt > /dev/null || die
eqmake5 \
'DEFINES+=DATA_DIR=\\\"'"${EPREFIX}"'/usr/share/${PN}/\\\" CONFIG_DIR=\\\"'"${EPREFIX}"'/etc/${PN}/\\\" DOC_DIR=\\\"'"${EPREFIX}"'/usr/share/doc/${PF}/\\\"'
popd > /dev/null || die
fi
}

src_compile() {
emake -f makefile "${myhlopts[@]}"
if use qt5 ; then
pushd src/gui-qt > /dev/null || die
emake
popd > /dev/null || die
fi
}

src_install() {
emake -f makefile "${myhlopts[@]}" install
if use qt5; then
emake -f makefile "${myhlopts[@]}" install-gui
docompress -x /usr/share/doc/${PF}/{ChangeLog,COPYING,README,README_PLUGINS}
fi

if ! use examples ; then
rm -r "${ED}"/usr/share/doc/${PF}/extras || die
fi
}

0 comments on commit 9e7066a

Please sign in to comment.