Skip to content

Commit

Permalink
games-strategy/wargus: version bump (bug #565670)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Michael Sterrett committed Jan 15, 2016
1 parent cc36a59 commit 9e73d60
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-strategy/wargus/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST wargus_2.2.7.orig.tar.gz 3655476 SHA256 f688663458e035725f5cd18535a7a1eaecd66eaf55b032fe2ac21ed48b239908 SHA512 a419e70c53db6f3919255ef98ea717a0802e0854095b019bd9c6eef66d6602f75c1849a53ef654b5d66191a824725e3eff23f1f01767eab861e6ddfaf2414bbb WHIRLPOOL d440ac1f279912b13f37fd618f31b1bb2ac53f143789dbe56835343e9486a6ec2aeca71874c4ae2bd9c707706cdf33efbec8df8993d102b0276da0aa53e04cc3
DIST wargus_2.3.0.orig.tar.gz 45006918 SHA256 9b8def814a8c7135653ae95bb1ff836627d39d5f8242a436f486c59701eaeee7 SHA512 79dbef5f86fafe7357c2911a16655c29bccef71dad39bfe6e02866c1734ee1598bb29a9005c8fa7c73d6f64e13fb7cdd3962214921b0b18c3868cb5abb2a0a87 WHIRLPOOL 8c34fcd6b84f26183c5a0ad1f8d14cae1eed601d2b4e38aa22a8fa8a1bd068b93fb2f1ae5fb223a41524ef467269b585c446e8476a4736507b91cb6bd23b8006
61 changes: 61 additions & 0 deletions games-strategy/wargus/wargus-2.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils cmake-utils gnome2-utils games

DESCRIPTION="Warcraft II for the Stratagus game engine"
HOMEPAGE="http://wargus.sourceforge.net/"
SRC_URI="https://launchpad.net/${PN}/trunk/2.3/+download/${PN}_${PV}.orig.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="=games-engines/stratagus-${PV}*[theora]
media-libs/libpng:0
sys-libs/zlib
x11-libs/gtk+:2
x11-libs/libX11"
DEPEND="${RDEPEND}
virtual/pkgconfig"
PDEPEND="games-strategy/wargus-data"

S=${WORKDIR}/${PN}_${PV}.orig

src_configure() {
local mycmakeargs=(
-DGAMEDIR="${GAMES_BINDIR}"
-DBINDIR="${GAMES_BINDIR}"
-DSTRATAGUS="${GAMES_BINDIR}"/stratagus
-DICONDIR=/usr/share/icons/hicolor/64x64/apps
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
prepgamesdirs
}

pkg_preinst() {
games_pkg_preinst
gnome2_icon_savelist
}

pkg_postinst() {
elog "Enabling OpenGL in-game seems to cause segfaults/crashes."
games_pkg_postinst
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 9e73d60

Please sign in to comment.