Skip to content

Commit

Permalink
gnome-extra/cinnamon-desktop: New upstream version 3.2.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
krifisk committed Nov 22, 2016
1 parent 342c962 commit 9e92ce4
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/cinnamon-desktop/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST cinnamon-desktop-2.8.1.tar.gz 529226 SHA256 e3eb7210013992db9de050bc6c26f405d66a6c4f0363812deaf191b1fbab595b SHA512 2f1447232ed11bca7507aa0af1de1f0843c5161665a42c9382b402695fa1f0b42972fb29d6d02cf8f951a7573f44fa9771e82f5bad6aa714419bf4a690e35dae WHIRLPOOL 729b191ecf237ae3bc0bfe68c63c650b596ff76347457ce15b267cb01e52dcd13f39b0d21ea1d5164ee841dc0065393587da1f51868338bd71af753891c24860
DIST cinnamon-desktop-3.0.2.tar.gz 577776 SHA256 a8bbf148b9ee25f21fb2c196a54c95eeee7e35cd23b32f25919516f08e8f4dda SHA512 0adcc7bd9f9dace245a7d7528893f729947228e4c454e423cdb1d3ac2ae3c04d010226e340d5d9315cc45a84f96f7b0bb173ee1589169ddcfbfadba59e0787a6 WHIRLPOOL 039e080ae6e43d356d0c22fce2b18ba1f382d31273a51f1c07daa0e2d0572a3b14426ec44d5e402b987676f36e606a381816396c2f466da593faeabf27d87c12
DIST cinnamon-desktop-3.2.0.tar.gz 572478 SHA256 84c29fd9256370b6789613292fd12ec7893c1b752487dc938b056a3d68607212 SHA512 e93ec4ee44152b800f75848bd9327b46f4ab0c6b2f4d0dc7f6d6f631eda0d486b995a5bb1537b2c85774fb3a48ae99332937fa8b6021aa08d98b98fc25a8429f WHIRLPOOL de9ab65cc297d8000ee9c74245080da95e12ac2e2c39a1a02316fb4d257693acee8414d98950790e9c880c6acaca0c6d535a236ab6605edbccd30d93008a9f2b
68 changes: 68 additions & 0 deletions gnome-extra/cinnamon-desktop/cinnamon-desktop-3.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python3_4 )

inherit autotools eutils gnome2 python-single-r1

DESCRIPTION="A collection of libraries and utilites used by Cinnamon"
HOMEPAGE="http://cinnamon.linuxmint.com/"
SRC_URI="https://github.com/linuxmint/cinnamon-desktop/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
SLOT="0/4" # subslot = libcinnamon-desktop soname version
KEYWORDS="~amd64 ~x86"
IUSE="+introspection systemd"

COMMON_DEPEND="${PYTHON_DEPS}
>=dev-libs/glib-2.37.3:2[dbus]
media-sound/pulseaudio[glib]
>=x11-libs/gdk-pixbuf-2.22:2[introspection?]
>=x11-libs/gtk+-3.3.16:3[introspection?]
>=x11-libs/libXext-1.1
>=x11-libs/libXrandr-1.3
x11-libs/cairo:=[X]
x11-libs/libX11
x11-libs/libxkbfile
x11-misc/xkeyboard-config
>=gnome-base/gsettings-desktop-schemas-3.5.91
introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
"
RDEPEND="${COMMON_DEPEND}
dev-python/pygobject:3[${PYTHON_USEDEP}]
"
DEPEND="${COMMON_DEPEND}
>=dev-util/gtk-doc-am-1.4
>=dev-util/intltool-0.40.6
gnome-base/gnome-common
x11-proto/randrproto
x11-proto/xproto
virtual/pkgconfig
"

pkg_setup() {
python_setup
}

src_prepare() {
eautoreconf
gnome2_src_prepare
}

src_configure() {
gnome2_src_configure \
--disable-static \
$(use_enable introspection)
}

src_install() {
gnome2_src_install

# set sane default gschema values for systemd users
if use systemd; then
insinto /usr/share/glib-2.0/schemas/
newins "${FILESDIR}"/${PN}-2.6.4.systemd.gschema.override ${PN}.systemd.gschema.override
fi
}

0 comments on commit 9e92ce4

Please sign in to comment.