Skip to content

Commit

Permalink
app-emulation/containerd: Add snapshot for docker-17.03.x
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
mrueg committed Mar 6, 2017
1 parent cf152bb commit 9ee80c3
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/containerd/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST containerd-0.2.3_p20170131.tar.gz 1021240 SHA256 77ea44af1531d46b22f0444eb506590d1b7e5a9fe891cc6f8e36db5c2aef2d80 SHA512 df782f44f53a39dbec5be281c98b1457d86d902e44451b995c35143f843e0233ac72dfea44407e47a39931bbedfa0537cf0e597d68509e3ae21311be0cc20cd6 WHIRLPOOL 322a577ed865dcac7d1185b7f7e67e59190de9f8898c6e14b7b99ada2e069652d20723f5f746fbe476586a4a3d204dc1e0563f325ea4cc0aa968e26c09debf34
DIST containerd-0.2.3_p20170223.tar.gz 1036082 SHA256 e7c655c3436968f423565010cd5d68804c039d4fa00dca403addc7a68275c5a0 SHA512 cf80b5169897bd980e4fb197a5a0c5ff29a7182836f582c0fb0acada48601a81aac1418975a67b60aefe7f8a356ff33573f86c858aa8da0cd1d46639f4727530 WHIRLPOOL 9d9ab2fef752a6f52415c043f78e152962b5aa16982643f9ee1973b1e324618e7b6bb192155e2235f5aa5a7fd3c8d62f5620169794f7222703b827a29dfc4a77
DIST containerd-0.2.5.tar.gz 1003500 SHA256 88e099af66b50abe7f2159f13bdab793fa5199d8d5b9a9ef7a68171abb4359be SHA512 ba1e074bb7556a7c4be4d68dc62aa2fa4b823682c209d1609c1f11518a7b7167139ea159d31e0b21ba190d83115a67e5e45b54b6a4770742d49e9e561309551f WHIRLPOOL eb3622ba99c4d4806bda9a45853422a5b0b884869ed3be4c3caec4c20f49027e8db78b9885eca7bc83a0f3b08e9a66eca950390f0eda1ef2535fd3ab41623bf4
40 changes: 40 additions & 0 deletions app-emulation/containerd/containerd-0.2.3_p20170223.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EGO_PN="github.com/docker/${PN}"

inherit toolchain-funcs

if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
MY_PV="${PV/_/-}"
EGIT_COMMIT="665e84e6c28653a9c29a6db601636a92d46896f3"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~ppc64"
inherit golang-vcs-snapshot
fi

DESCRIPTION="A daemon to control runC"
HOMEPAGE="https://containerd.tools"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="hardened +seccomp"

DEPEND=""
RDEPEND=">=app-emulation/docker-runc-1.0.0_rc2
seccomp? ( sys-libs/libseccomp )"

S=${WORKDIR}/${P}/src/${EGO_PN}

src_compile() {
local options=( $(usex seccomp "seccomp") )
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
}

src_install() {
dobin bin/containerd* bin/ctr
}

0 comments on commit 9ee80c3

Please sign in to comment.