Skip to content

Commit

Permalink
games-server/cyphesis: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent 62227e7 commit 9f545df
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 2 deletions.
62 changes: 62 additions & 0 deletions games-server/cyphesis/cyphesis-0.6.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit toolchain-funcs autotools python-single-r1 eutils

DESCRIPTION="WorldForge server running small games"
HOMEPAGE="http://worldforge.org/index.php/components/cyphesis/"
SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT="test"

RDEPEND="
dev-db/postgresql:=
>=dev-games/mercator-0.3.3
>=dev-games/wfmath-1.0.1
dev-libs/libgcrypt:0
dev-libs/libsigc++:2
sys-libs/ncurses:0
sys-libs/readline:0
>=media-libs/atlas-c++-0.6.3
>=media-libs/skstream-0.3.9
>=media-libs/varconf-0.6.4
"
DEPEND="${RDEPEND}
>=dev-libs/boost-1.40
dev-libs/libxml2
virtual/pkgconfig"

pkg_setup() {
python-single-r1_pkg_setup
}

PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-makefile.patch
)

src_prepare() {
default

eautoreconf
}

src_configure() {
econf --localstatedir=/var
}

src_compile() {
emake AR="$(tc-getAR)"
}

src_install() {
emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" install
dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
}
4 changes: 2 additions & 2 deletions games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.am.old 2013-09-25 14:26:30.518751250 +0200
+++ Makefile.am 2013-09-25 14:27:21.846257911 +0200
--- a/Makefile.am 2013-09-25 14:26:30.518751250 +0200
+++ b/Makefile.am 2013-09-25 14:27:21.846257911 +0200
@@ -13,8 +13,6 @@

# FIXME Remove the mkdir hack if it gets fixed in a future automake
Expand Down

0 comments on commit 9f545df

Please sign in to comment.