forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/debootstrap: Version 1.0.97.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
- Loading branch information
Jeroen Roovers
committed
Apr 18, 2018
1 parent
7b757ad
commit 9f6ecba
Showing
2 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit eutils | ||
|
||
DESCRIPTION="Debian/Ubuntu bootstrap scripts" | ||
HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html" | ||
SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz | ||
mirror://gentoo/devices.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux" | ||
|
||
RDEPEND=" | ||
app-arch/dpkg | ||
net-misc/wget | ||
sys-devel/binutils | ||
" | ||
DOCS=( TODO debian/changelog ) | ||
|
||
src_unpack() { | ||
unpack ${PN}_${PV}.tar.gz | ||
cp "${DISTDIR}"/devices.tar.gz "${S}" | ||
} | ||
|
||
src_compile() { | ||
return | ||
} | ||
|
||
src_install() { | ||
default | ||
doman debootstrap.8 | ||
} | ||
|
||
pkg_postinst() { | ||
if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then | ||
elog "To check Release files against a keyring (--keyring=K), please" | ||
elog "install app-crypt/gnupg" | ||
fi | ||
|
||
if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then | ||
elog "To check Release files from Debian or Ubuntu, please install" | ||
elog " app-crypt/debian-archive-keyring or" | ||
elog " app-crypt/ubuntu-keyring as required" | ||
fi | ||
} |