forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ml/incremental_kernel: bump to 113.33.03
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
50 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST incremental_kernel-113.33.00.tar.gz 112965 SHA256 ada5dfa4a37b3eb11f85c7e38dad8eabab91db13346446b441c332218b921d6c SHA512 67a517eace7fe435fee7a0912720ad2b8f1fab587d1a2bdd8e9d3316044dfe0923ef1bf20aca7d8305260f0c18f3a401293dc8026cd9eb69f994d003bb36563f WHIRLPOOL 0bf8ba0d272608df287cd0fe08c308a4885fd4ec664fd3da2aaf6b1153d7c9b904ed9542e1048748fe557cfcef7cc970c57fb14004fc63a7f4cc5de782296d83 | ||
DIST incremental_kernel-113.33.03.tar.gz 111566 SHA256 bb307477646a63651b36f4c125d7d94a5809aaf4107a5cec16930f463fe67af9 SHA512 5a73a394147495ffdadc877e574d2d795097b173198fd0137333c27426de308b66178f2f969833e18d865c8971910685f1fdb7c7fd13b758084566550d68bb7d WHIRLPOOL e9cf93299d53760c0324ba81b12c0afa743bf2300c7a0bcb143826b8c667580e12fcfa0d436cd4c3ea288aac32706b6c2de249db50db00a5bbf6511296801cc8 |
49 changes: 49 additions & 0 deletions
49
dev-ml/incremental_kernel/incremental_kernel-113.33.03.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
inherit oasis | ||
|
||
DESCRIPTION="Library for incremental computations depending only on Core_kernel" | ||
HOMEPAGE="http://www.janestreet.com/ocaml" | ||
SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0/${PV}" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
dev-ml/bin-prot:= | ||
>=dev-ml/core_kernel-113.33:= | ||
dev-ml/fieldslib:= | ||
dev-ml/ppx_assert:= | ||
dev-ml/ppx_bench:= | ||
dev-ml/ppx_expect:= | ||
dev-ml/ppx_inline_test:= | ||
dev-ml/ppx_jane:= | ||
dev-ml/sexplib:= | ||
dev-ml/typerep:= | ||
dev-ml/variantslib:= | ||
" | ||
RDEPEND="${DEPEND}" | ||
DEPEND="${DEPEND} dev-ml/opam" | ||
|
||
src_configure() { | ||
emake setup.exe | ||
OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure | ||
} | ||
|
||
src_compile() { | ||
emake | ||
} | ||
|
||
src_install() { | ||
opam-installer -i \ | ||
--prefix="${ED}/usr" \ | ||
--libdir="${D}/$(ocamlc -where)" \ | ||
--docdir="${ED}/usr/share/doc/${PF}" \ | ||
${PN}.install || die | ||
} |