forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-sound/teamspeak-client: bump to version 3.5.1
Closes: https://bugs.gentoo.org/714946 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Conrad Kostecki <[email protected]>
- Loading branch information
Showing
2 changed files
with
116 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,4 @@ | ||
DIST TeamSpeak3-Client-linux_amd64-3.3.2.run 95632176 BLAKE2B b1a418e6af6c364050a532063b3129e27d03ac36ec325ab5f2044896f5eae02fb4a251e71b23bc125d41f169aa35d8dde340b333a67b845ebaca7faefa49fe70 SHA512 1dd8912120ba0e9e84849fd793d54aee56e98396f6228a4bcec5c79485b9902398eeefb8f276abd46bbe627e7bd3c8fc5d740d05807342f837ac226f475510d7 | ||
DIST TeamSpeak3-Client-linux_amd64-3.5.1.run 97443497 BLAKE2B f0b4eab44cbbdc189dccdc5a57fcb22ced1469173566fb81c02348d84d1887af6827a9ec3632c122161ce9b4e16444b8c969535701dde474fe0c5fe5f3f5ce5c SHA512 8537c74df8772755c91c7c65f0fcc745475c190a18717111131bd4ab98cfe47e611503f3e03b2eb8a5f7198ce5070dc705aae2374523876b732efe21e248639d | ||
DIST TeamSpeak3-Client-linux_x86-3.3.2.run 94323084 BLAKE2B f3b0317e8cbc7143d9814a52c8a8c9cd04aa012a40172aca59e6d4db956a19ae5752bffa102f06e34ad0dd5b211082e00ca06056c05a4a2dbbd8adfd76a0c0e7 SHA512 56b7b231ffa5195418823da435fd4daef2cbdbc653d3cfd328f60881a1370b9dd6f99479e9093216d0768ddb04bdd6c6cf1a7019d836abd89806518eeee23496 | ||
DIST TeamSpeak3-Client-linux_x86-3.5.1.run 95934901 BLAKE2B b0cbc1ce3d4a98454349b356952e7fa78c06d343e1f30005df9f4165b10571ada8e52a6747684f87b19626a1891be9c2f6475ac0271da51e6524d2016d0e9148 SHA512 ff48b2aa7f7a27172f573a1373e020a7a85c7900946e0d01724f7611b4db0ddfae2a0074271919cedea2293e4dea7bed9a462b0ff09bde1e3c3681af856d9717 |
114 changes: 114 additions & 0 deletions
114
media-sound/teamspeak-client/teamspeak-client-3.5.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,114 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit desktop toolchain-funcs unpacker xdg-utils | ||
|
||
MY_PV="${PV/_/-}" | ||
|
||
DESCRIPTION="A client software for quality voice communication via the internet" | ||
HOMEPAGE="https://www.teamspeak.com/" | ||
SRC_URI=" | ||
amd64? ( https://files.teamspeak-services.com/releases/client/${PV}/TeamSpeak3-Client-linux_amd64-${MY_PV}.run ) | ||
x86? ( https://files.teamspeak-services.com/releases/client/${PV}/TeamSpeak3-Client-linux_x86-${MY_PV}.run ) | ||
" | ||
|
||
KEYWORDS="-* ~amd64 ~x86" | ||
LICENSE="teamspeak3 || ( GPL-2 GPL-3 LGPL-3 )" | ||
SLOT="0" | ||
IUSE="+alsa pulseaudio" | ||
REQUIRED_USE="|| ( alsa pulseaudio )" | ||
|
||
BDEPEND="dev-util/patchelf" | ||
|
||
RDEPEND=" | ||
app-arch/snappy:0/1 | ||
dev-libs/openssl:0 | ||
dev-libs/quazip | ||
dev-qt/qtcore:5 | ||
|| ( | ||
dev-qt/qtgui:5[accessibility,dbus,X(-)] | ||
dev-qt/qtgui:5[accessibility,dbus,xcb(-)] | ||
) | ||
dev-qt/qtnetwork:5 | ||
dev-qt/qtsql:5[sqlite] | ||
dev-qt/qtsvg:5 | ||
dev-qt/qtwebchannel:5 | ||
dev-qt/qtwebengine:5[geolocation(+),widgets] | ||
dev-qt/qtwebsockets:5 | ||
dev-qt/qtwidgets:5 | ||
net-libs/libsrtp:0 | ||
sys-libs/libcxx[libcxxabi] | ||
sys-libs/zlib:0/1 | ||
virtual/udev | ||
alsa? ( media-libs/alsa-lib ) | ||
pulseaudio? ( media-sound/pulseaudio ) | ||
" | ||
|
||
RESTRICT="bindist mirror" | ||
|
||
S="${WORKDIR}" | ||
|
||
QA_PREBUILT=" | ||
opt/teamspeak3-client/error_report | ||
opt/teamspeak3-client/package_inst | ||
opt/teamspeak3-client/soundbackends/libalsa_linux_*.so | ||
opt/teamspeak3-client/soundbackends/libpulseaudio_linux_*.so | ||
opt/teamspeak3-client/ts3client | ||
opt/teamspeak3-client/update | ||
" | ||
|
||
src_prepare() { | ||
default | ||
|
||
if ! use alsa; then | ||
rm -f soundbackends/libalsa_linux_*.so || die | ||
fi | ||
|
||
if ! use pulseaudio ; then | ||
rm -f soundbackends/libpulseaudio_linux_*.so || die | ||
fi | ||
|
||
mv ts3client_linux_* ts3client || die | ||
|
||
# Fixes QA Notice: Unresolved soname dependencies. | ||
# Since this is a binary only package, it must be patched. | ||
local soname_files=( "error_report" "ts3client" ) | ||
for soname_file in ${soname_files[@]}; do | ||
patchelf --replace-needed libquazip.so libquazip5.so.1 "${soname_file}" || die | ||
done | ||
|
||
tc-export CXX | ||
} | ||
|
||
src_install() { | ||
exeinto /opt/teamspeak3-client | ||
doexe error_report package_inst ts3client update | ||
newexe "${FILESDIR}"/ts3client-bin-r2 ts3client-bin | ||
|
||
exeinto /opt/teamspeak3-client/soundbackends | ||
doexe soundbackends/*.so | ||
|
||
insinto /opt/teamspeak3-client | ||
doins -r gfx html resources sound styles translations | ||
|
||
dosym ../../usr/$(get_libdir)/qt5/libexec/QtWebEngineProcess /opt/teamspeak3-client/QtWebEngineProcess | ||
|
||
dodir /opt/bin | ||
dosym ../teamspeak3-client/ts3client-bin /opt/bin/ts3client | ||
|
||
make_desktop_entry /opt/bin/ts3client "Teamspeak 3 Client" /opt/teamspeak3-client/styles/default/logo-128x128.png "Audio;AudioVideo;Network" | ||
|
||
einstalldocs | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_desktop_database_update | ||
xdg_mimeinfo_database_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_desktop_database_update | ||
xdg_mimeinfo_database_update | ||
} |