forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-vcs/tortoisehg: 6.1 version bump; 9999.ebuild update
Signed-off-by: Sergey Torokhov <[email protected]> Closes: gentoo#24718 Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
1 parent
89af0bb
commit 9fc6180
Showing
3 changed files
with
90 additions
and
5 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST tortoisehg-5.8.1.tar.gz 8636858 BLAKE2B 66473695e1364ff676ab314ce8b5a5e59cbe6ece68795d92278e450f70386a9e047dfd8975e7312bda10c183879d9634767f64a9c916f889f3edcf4847bf2468 SHA512 29903240c5522841e0ddc0f78741d20d589b6b48e82bf38023b87184e987721111a6a9675ccb85a31d9781cf1b8fa3d28801fef5bae187ae467d7da8f1ef982f | ||
DIST tortoisehg-5.9.1.tar.gz 8637928 BLAKE2B 57687359eb00018a811e28449dccce260569f7a26c91bf25a6473427f9942fd536c4458cae593baa371c65713f626208e6627e952e78001947b8f952988c3103 SHA512 8df24a66e24ddb95af353a363149dcee37bc678ebd741f578a8bc09d6844b52537f287b908bce2dab4e4603310867095821b52332bd5bdc55b0f114bad647eff | ||
DIST tortoisehg-5.9.3.tar.gz 8637453 BLAKE2B 9fa90c108f32b1e15c233e7ccbadbda08e434f23aa5c5fe7c235c743c98f54f4222a1804c06b0ca300cc3d0b049c117007a53452ff20ae4411bca30d8ed9013b SHA512 870b3b717962b8450d07fca5300f971d187236edce5a9d2926144b832c0771b8f5a324bdfd05a1fed3d2b4de4bad913c0c8f4435908e602e268c561ed64abbb2 | ||
DIST tortoisehg-6.1.tar.gz 8651665 BLAKE2B ed476683b5a9f64ad94a9c8d5ab0b0bf5693292985d7583b76e166ac9a472015e8f7ba62c0f98211a2784f52171f4d25c91c15c97750b395297a19b77eb2d18e SHA512 056959de987de5a5058d26b148e2edf16424554f13d5125c50bb79c49c31b8a2093ef381d15638739461b2d7597e0b7f19edc0ed621dead4cce72d5a8cd5a620 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,84 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
PYTHON_COMPAT=( python3_{8..10} ) | ||
|
||
DISTUTILS_USE_SETUPTOOLS=no | ||
|
||
inherit desktop distutils-r1 optfeature xdg-utils | ||
|
||
# Tag isn't provided this time | ||
COMMIT_SHA="cdfdf8c593f98863b4034b38001c71bc9fb970c3" | ||
|
||
if [[ ${PV} != *9999* ]]; then | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${COMMIT_SHA}/thg-${COMMIT_SHA}.tar.gz -> ${P}.tar.gz" | ||
HG_DEPEND=">=dev-vcs/mercurial-5.9[${PYTHON_USEDEP}] | ||
<dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]" | ||
S="${WORKDIR}/thg-${COMMIT_SHA}" | ||
else | ||
inherit mercurial | ||
EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg" | ||
EHG_REVISION="stable" | ||
HG_DEPEND=">=dev-vcs/mercurial-5.9[${PYTHON_USEDEP}]" | ||
fi | ||
|
||
DESCRIPTION="Set of graphical tools for Mercurial" | ||
HOMEPAGE="https://tortoisehg.bitbucket.io/" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
RDEPEND=" | ||
${HG_DEPEND} | ||
dev-python/iniparse[${PYTHON_USEDEP}] | ||
dev-python/pygments[${PYTHON_USEDEP}] | ||
dev-python/PyQt5[network,svg,${PYTHON_USEDEP}] | ||
>=dev-python/qscintilla-python-2.9.4[qt5(+),${PYTHON_USEDEP}] | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
test? ( | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
distutils_enable_sphinx doc/source | ||
|
||
python_prepare_all() { | ||
# Remove file that collides with >=mercurial-4.0 (bug #599266). | ||
rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py" | ||
|
||
sed -i -e 's:share/doc/tortoisehg:share/doc/'"${PF}"':' setup.py || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
${EPYTHON} tests/run-tests.py -m 'not largefiles' --doctest-modules tests || die | ||
${EPYTHON} tests/run-tests.py -m largefiles tests || die | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc | ||
newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg | ||
domenu contrib/thg.desktop | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_icon_cache_update | ||
elog "When startup of ${PN} fails with an API version mismatch error" | ||
elog "between dev-python/sip and dev-python/PyQt5 please rebuild" | ||
elog "dev-python/qscintilla-python." | ||
|
||
optfeature "the core git extension support" dev-python/pygit2 | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_icon_cache_update | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters