forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/diskimage-builder: bup
Package-Manager: portage-2.3.0
- Loading branch information
1 parent
7d02254
commit 9fe5f2d
Showing
2 changed files
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST diskimage-builder-1.15.0.tar.gz 225527 SHA256 cf4d1678110d53c337e94d7968126ed50dbdf790dddeda6f855f10ba5e09bb5b SHA512 4984a0bcdce5f011d08ed72910653ba60b67597f5df07f3dacabee3f9f2d4fbc8346b843d026a9a3ae8727452018a05343822bb19b268bb18d75c7c081b53b8d WHIRLPOOL 912b8acfe691f1e6941fd19b668e80ad6be1c3a364aae6310d2c8156422b5b8e7b6008f4ac3a2d1883f6149fb9122da222ba57b9c95323733c9c7aed40d1f2d7 | ||
DIST diskimage-builder-1.21.0.tar.gz 248236 SHA256 f40f9f6c5b1ceebe10344d94ad9a87f56fa1724815c755f983198e9eb5de41d8 SHA512 2965192f2148a22ca1eb7bb4ec5705ac9061337cefcb0b6154af7f8c6519ef9ea1d1577bbf1f24957152ff0497003843f58a0fd87a7921eb3d327c6d9a0a3b1a WHIRLPOOL 671a20b9b174ac7d98e5c12a67b7cf79612aa4d961e6e715621a2c42ce990cdf8615f20ba0f80a164889b7dc1693de46520026997ca4a48cdad66b2835ad1a5a |
32 changes: 32 additions & 0 deletions
32
app-emulation/diskimage-builder/diskimage-builder-1.21.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Golden Disk Image builder." | ||
HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="" | ||
|
||
CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]" | ||
DEPEND="${CDEPEND} | ||
dev-python/setuptools[${PYTHON_USEDEP}]" | ||
RDEPEND="${CDEPEND} | ||
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}] | ||
dev-python/dib-utils[${PYTHON_USEDEP}] | ||
>=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/flake8-2.5.4[${PYTHON_USEDEP}] | ||
<dev-python/flake8-2.6.0[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}] | ||
app-emulation/qemu | ||
sys-block/parted | ||
sys-fs/multipath-tools" |