Skip to content

Commit

Permalink
media-libs/libglvnd: Version bump to 1.4.0
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Dec 22, 2021
1 parent e147b8c commit a017a6b
Show file tree
Hide file tree
Showing 3 changed files with 67 additions and 1 deletion.
1 change: 1 addition & 0 deletions media-libs/libglvnd/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libglvnd-1.3.4.tar.bz2 715616 BLAKE2B 77866bcd80b80dc27accbe960d63f45b5052ad110590890ed4707db0c2d7efd6882755f7258fc007b3b11bed9cee02477103ed65003185f9d7d2f6e82bef7df8 SHA512 3132bf2a547d5b7ffe12c6f1574b62c666cce8708d0311dccdbdb82063e5b6efd6f889ff1829d550af903305cd7c5bd2f7c5e0253234b25e0ea98234769e7ccf
DIST libglvnd-1.4.0.tar.bz2 563441 BLAKE2B 079b37571da7f1eb3cf8f87ea727aeec04a27158f015889552787ff269cc779f33c10a426a7113d4e45b13008b6540c2a2eec2ac69cb1cb5c551ac82e11475e5 SHA512 a887044b6b3b8bb2dae74f28a9b92ffa0ab7b65adc74d788e28c292b99ed618f93deb1ddc041b9a9460cf46eba5f63a4ba1c20f120dea868659a022428689287
65 changes: 65 additions & 0 deletions media-libs/libglvnd/libglvnd-1.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 2018-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

EGIT_REPO_URI="https://gitlab.freedesktop.org/glvnd/libglvnd.git"

if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi

PYTHON_COMPAT=( python3_{7..10} )
VIRTUALX_REQUIRED=manual

inherit ${GIT_ECLASS} meson-multilib python-any-r1 virtualx

DESCRIPTION="The GL Vendor-Neutral Dispatch library"
HOMEPAGE="https://gitlab.freedesktop.org/glvnd/libglvnd"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
SRC_URI="https://gitlab.freedesktop.org/glvnd/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
S=${WORKDIR}/${PN}-v${PV}
fi

LICENSE="MIT"
SLOT="0"
IUSE="test X"
RESTRICT="!test? ( test )"

BDEPEND="${PYTHON_DEPS}
test? ( X? ( ${VIRTUALX_DEPEND} ) )"
RDEPEND="
!media-libs/mesa[-libglvnd(+)]
X? (
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
)"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )"

src_prepare() {
default
sed -i -e "/^PLATFORM_SYMBOLS/a '__gentoo_check_ldflags__'," \
bin/symbols-check.py || die
}

multilib_src_configure() {
local emesonargs=(
$(meson_feature X x11)
$(meson_feature X glx)
)
use elibc_musl && emesonargs+=( -Dtls=false )

meson_src_configure
}

multilib_src_test() {
if use X; then
virtx meson_src_test
else
meson_src_test
fi
}
2 changes: 1 addition & 1 deletion media-libs/libglvnd/libglvnd-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -51,7 +51,7 @@ multilib_src_configure() {
$(meson_feature X x11)
$(meson_feature X glx)
)
use elibc_musl && emesonargs+=( -Dtls=disabled )
use elibc_musl && emesonargs+=( -Dtls=false )

meson_src_configure
}
Expand Down

0 comments on commit a017a6b

Please sign in to comment.