Skip to content

Commit

Permalink
dev-util/catkin: bump to 0.7.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Mar 5, 2016
1 parent a267f67 commit a038de3
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/catkin/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST catkin-0.6.16.tar.gz 199054 SHA256 2cb7efdaecc238a156929861645c5cfd96977a8606fb7765e131304072d1c82c SHA512 907e3545e74e798e76e66cf24fa58ae9385a309a42e251e4871f4bee28026ed05faf50950b0deb8c3e2d234dafa1188031759c3acbc53a31fd35a7e3e29c1ef6 WHIRLPOOL 9c2c5e51e6e6d1d8b47c1b6d1061471de8d34304fb6fe2df19beccd68b6595c591ca3318ba72c0261b11e96c11d58998d180f44749127cec6cf7d5d38a1e9ac3
DIST catkin-0.7.0.tar.gz 199935 SHA256 253508b40241ceb334eddfd70b0eef791cc0b48fa303ef4968e364c3ebde4d00 SHA512 58823ee3f3bb071c0508f97fc288eefed65cb76aa72e69a18e4a1c493f092e7e1cefd2af4836edf276740118f83429c3f44ad1e91ab51afdd6c20ae9eb21a6e1 WHIRLPOOL 673efad52e115b3c96e56453081d90bf435515fa3cf2c5e646b6fefecf3ff0a31499c3132c3b292b424baeb41892af71b112cde6054567aacb4184b5bb9c4100
99 changes: 99 additions & 0 deletions dev-util/catkin/catkin-0.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="http://github.com/ros/catkin"
fi

PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )

inherit ${SCM} cmake-utils python-r1 python-utils-r1

DESCRIPTION="Cmake macros and associated python code used to build some parts of ROS"
HOMEPAGE="http://wiki.ros.org/catkin"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
else
SRC_URI="http://github.com/ros/catkin/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/empy[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-python/mock[${PYTHON_USEDEP}] )"

PATCHES=(
"${FILESDIR}/tests.patch"
"${FILESDIR}/distutils.patch"
"${FILESDIR}/catkin_prefix_path.patch"
"${FILESDIR}/gnuinstalldirs.patch"
)

src_prepare() {
# fix libdir
sed -i \
-e 's:LIBEXEC_DESTINATION lib:LIBEXEC_DESTINATION libexec:' \
-e 's:}/lib:}/${CMAKE_INSTALL_LIBDIR}:' \
-e 's:DESTINATION lib):DESTINATION ${CMAKE_INSTALL_LIBDIR}):' \
-e 's:DESTINATION lib/:DESTINATION ${CMAKE_INSTALL_LIBDIR}/:' \
-e 's:PYTHON_INSTALL_DIR lib:PYTHON_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}:' \
cmake/*.cmake || die
cmake-utils_src_prepare
}

catkin_src_configure_internal() {
mycmakeargs+=( -DPYTHON_EXECUTABLE="${PYTHON}" )
python_export PYTHON_SCRIPTDIR
cmake-utils_src_configure
}

src_configure() {
local mycmakeargs=(
"$(cmake-utils_use test CATKIN_ENABLE_TESTING)"
"-DCATKIN_BUILD_BINARY_PACKAGE=ON"
)
python_foreach_impl catkin_src_configure_internal
}

src_compile() {
python_foreach_impl cmake-utils_src_compile
}

src_test() {
unset PYTHON_SCRIPTDIR
python_foreach_impl cmake-utils_src_test
}

catkin_src_install_internal() {
python_export PYTHON_SCRIPTDIR
cmake-utils_src_install
if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
dodir /usr/bin
for i in "${D}/${PYTHON_SCRIPTDIR}"/* ; do
dosym ../lib/python-exec/python-exec2 "/usr/bin/${i##*/}" || die
done
touch "${T}/.catkin_python_symlinks_generated"
fi
}

src_install() {
python_foreach_impl catkin_src_install_internal

doenvd "${FILESDIR}/40catkin"

# needed to be considered as a workspace
touch "${ED}/usr/.catkin"
}

0 comments on commit a038de3

Please sign in to comment.