Skip to content

Commit

Permalink
dev-cpp/scitokens-cpp: add 1.1.0
Browse files Browse the repository at this point in the history
Closes: gentoo#33746

Signed-off-by: Oliver Freyermuth <[email protected]>
Signed-off-by: Guilherme Amadio <[email protected]>
  • Loading branch information
olifre authored and amadio committed Nov 16, 2023
1 parent 0fe64b6 commit a03b1ff
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/scitokens-cpp/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST scitokens-cpp-1.0.2.tar.gz 311221 BLAKE2B 8f77f4f5ded34f7c572567c980ef0dabaf7e36d4395d41046a1bd8e1343299309ea81efb23b0120532cba365463a9ad2c5ff857f85be5df922830541513c11cd SHA512 c15784342eb70eb0ec1cd87d5a1e89446b8aa3bb070bfdef58960c2d94739b05d186ee33807ebc066a450a0211b3dd7c04ea613fd4870d7a2d0f8fe30e8a7453
DIST scitokens-cpp-1.1.0.tar.gz 311446 BLAKE2B a515d834df04125ae9167cb4656def7df43c9f1ba6d701379257cdd0fd51b61a119e6222591fbe9c1d7ac7000b1b4590d12e9f9238810c0791397a9d9846f6f7 SHA512 e71474afbde45149fbd642918e802f7430603a14add7171525fd08fdfbfb9dc4ae5b151341d2c11b294f352cdf76315e5c1f089daca12a1c9db304f6b2c89276
57 changes: 57 additions & 0 deletions dev-cpp/scitokens-cpp/scitokens-cpp-1.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scitokens/scitokens-cpp"
else
SRC_URI="https://github.com/scitokens/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="C++ implementation of the SciTokens library with a C library interface"
HOMEPAGE="https://scitokens.org/"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="test"

DEPEND="
dev-cpp/jwt-cpp[picojson]
dev-db/sqlite
dev-libs/openssl:0=
net-misc/curl:0=
kernel_linux? ( sys-apps/util-linux )
"
RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
test? ( dev-cpp/gtest )
"
RESTRICT="!test? ( test )"

src_prepare() {
# Unbundle dev-cpp/gtest, dev-cpp/jwt-cpp
rm -r vendor || die
# Fix include path for picojson.
find src/ \( -name '*.cpp' -o -name '*.h' \) -type f -print0 | \
xargs -0 sed -r -e "s:picojson/picojson\.h:picojson.h:g" -i || die
# Disable network-based tests relying on external services.
if use test; then
sed -i -e '/^TEST_F/s#RefreshTest#DISABLED_RefreshTest#' \
-e '/^TEST_F/s#RefreshExpiredTest#DISABLED_RefreshExpiredTest#' test/main.cpp || die
fi
cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DSCITOKENS_BUILD_UNITTESTS="$(usex test)"
-DSCITOKENS_EXTERNAL_GTEST=YES
)
cmake_src_configure
}

0 comments on commit a03b1ff

Please sign in to comment.