Skip to content

Commit

Permalink
net-firewall/ipt_netflow: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
Pinkbyte committed Jan 28, 2016
1 parent 5a5df54 commit a03b210
Show file tree
Hide file tree
Showing 2 changed files with 89 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-firewall/ipt_netflow/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ipt-netflow-2.1.tgz 87872 SHA256 1cc1ee518ecd6c7d8d792ea79c0f69d03ce450c10fefd37f053c43aac92e9931 SHA512 0055ebb1846077f94c1fbf701af8a07a432058c8e86e31c6f420d5c00c96b45012abdcdeef3c5b1ead7d20c7efd51ac65d000b6cb931d878f528f52de0ab9c21 WHIRLPOOL e46ffe69f58293cca0fc26c2ff13ee30e68e2a60a4b198c89fdb24ebc45a4376877285358d4e72019c811d70d0a77194dbc0d46f44c8076923fc626cfe2e7488
DIST ipt-netflow-2.1_p20160119.tgz 86892 SHA256 9afb3f122f0f2b140d81b331d4500f8ad475898579fb5901ed1090d80783a4e5 SHA512 7f30683240d7516df01a4b4a37ea738980def764741c658c86e9c28ca638592a40e0b2458164105d76f88c90f780f058f5c17a0c60ffaeb775d7cdb38dbb4fe1 WHIRLPOOL fdb1a0bebeb8a2840005abd86cbd0fcbc241b4acaae2138d66d0a463807392a3076113b61d8d091ba0aa8f995ab9cc21a1f1f8e33bd9cd11bc1700b8392791d9
88 changes: 88 additions & 0 deletions net-firewall/ipt_netflow/ipt_netflow-2.1_p20160119.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,88 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
MY_PN="${PN/_/-}"
MY_P="${MY_PN}-${PV}"
inherit linux-info linux-mod toolchain-funcs

DESCRIPTION="Netflow iptables module"
HOMEPAGE="http://sourceforge.net/projects/ipt-netflow"
SRC_URI="http://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${MY_P}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="debug snmp"

RDEPEND="
net-firewall/iptables
snmp? ( net-analyzer/net-snmp )
"
DEPEND="${RDEPEND}
virtual/linux-sources
virtual/pkgconfig
"

# set S before MODULE_NAMES
S="${WORKDIR}/${MY_P}"

pkg_setup() {
BUILD_TARGETS="all"
MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
IPT_LIB="/usr/$(get_libdir)/xtables"
local CONFIG_CHECK="~IP_NF_IPTABLES"
use debug && CONFIG_CHECK+=" ~DEBUG_FS"
linux-mod_pkg_setup
}

src_prepare() {
sed -i \
-e 's:make -C:$(MAKE) -C:g' \
-e 's:gcc -O2:$(CC) $(CFLAGS) $(LDFLAGS):' \
-e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' \
Makefile.in || die

# Checking for directory is enough
sed -i -e 's:-s /etc/snmp/snmpd.conf:-d /etc/snmp:' configure || die

# bug #455984
eapply "${FILESDIR}/${PN}-2.0-configure.patch"

eapply_user
}

do_conf() {
echo ./configure $*
./configure $* ${EXTRA_ECONF} || die 'configure failed'
}

src_configure() {
local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
# this configure script is not based on autotools
# ipt-src need to be defined, see bug #455984
do_conf \
--disable-dkms \
--ipt-lib="${IPT_LIB}" \
--ipt-src="/usr/" \
--ipt-ver="${IPT_VERSION}" \
--kdir="${KV_DIR}" \
--kver="${KV_FULL}" \
$(use debug && echo '--enable-debugfs') \
$(use snmp && echo '--enable-snmp-rules' || echo '--disable-snmp-agent')
}

src_compile() {
emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" all
}

src_install() {
linux-mod_src_install
exeinto "${IPT_LIB}"
doexe libipt_NETFLOW.so
use snmp && emake DESTDIR="${D}" SNMPTGSO="/usr/$(get_libdir)/snmp/dlmod/snmp_NETFLOW.so" sinstall
doheader ipt_NETFLOW.h
dodoc README*
}

0 comments on commit a03b210

Please sign in to comment.