Skip to content

Commit

Permalink
app-portage/eix: Bump to 0.36.6
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 29, 2023
1 parent 1761e46 commit a04c722
Show file tree
Hide file tree
Showing 2 changed files with 105 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/eix/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST eix-0.36.5.tar.xz 640132 BLAKE2B b997be82e21e3316abc6f06bd120434f2a027d62a3bd97e54e7c6298ee201d9998fb0fda91955f88b1b9bbf15b3c6c0c1d821280508215131cde16d1eef621e7 SHA512 fb86367f34ae30dac10f0ba68a649c8e737f0f66fefb2933e100c63c57b778567753759f28a6b4afd0155430b050ff59297821c7b54fa73c6cd65b0231806d89
DIST eix-0.36.6.tar.xz 640216 BLAKE2B 40f1d247f6a00ecc9e034f272e73346535724e1b0cf304ea990ae849414adb4490d181db1f781bf7825f18c12cee47e03921a3e43054631d2422e0a6c8a915b8 SHA512 4dbea2a0ac66b15061b491a8da15337894ef4ae18bfb2e77eaf74c6741a45487ca7378c80620341ccf4b335592c121ab55755f0562425a9dbf9a16a9c4aa3554
104 changes: 104 additions & 0 deletions app-portage/eix/eix-0.36.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools bash-completion-r1 tmpfiles

DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="debug doc nls sqlite"

DEPEND="
nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
RDEPEND="${DEPEND}
>=app-shells/push-2.0-r1
>=app-shells/quoter-3.0_p2-r1"
BDEPEND="
app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )"

pkg_setup() {
# remove stale cache file to prevent collisions
local old_cache=${EROOT}/var/cache/${PN}
if [[ -f ${old_cache} ]]; then
rm "${old_cache}" || die
fi
}

src_prepare() {
default
sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die

sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
-e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
-i src/eix-functions.sh.in || die
sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
-i src/Makefile.am || die

eautoreconf
}

src_configure() {
local myconf=(
$(use_enable debug paranoic-asserts)
$(use_enable nls)
$(use_with doc extra-doc)
$(use_with sqlite)
--without-protobuf

# default configuration
$(use_with prefix always-accept-keywords)
--with-dep-default
--with-required-use-default

# paths
--with-portage-rootpath="${ROOTPATH}"
--with-eprefix-default="${EPREFIX}"

# build a single executable with symlinks
--disable-separate-binaries
--disable-separate-tools

# used purely to control/disrespect *FLAGS
--disable-debugging
--disable-new_dialect
--disable-optimization
--disable-strong-optimization
--disable-security
--disable-nopie-security
--disable-strong-security
)

econf "${myconf[@]}"
}

src_install() {
default
dobashcomp bash/eix
dotmpfiles tmpfiles.d/eix.conf

rm -r "${ED}"/usr/bin/eix-functions.sh || die
}

pkg_postinst() {
tmpfiles_process eix.conf

local obs=${EROOT}/var/cache/eix.previous
if [[ -f ${obs} ]]; then
ewarn "Found obsolete ${obs}, please remove it"
fi
}

pkg_postrm() {
if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
rm -rf "${EROOT}/var/cache/${PN}" || die
fi
}

0 comments on commit a04c722

Please sign in to comment.