Skip to content

Commit

Permalink
app-backup/backintime: Add live ebuild and update HOMEPAGE (thanks Sa…
Browse files Browse the repository at this point in the history
…muel Bauer).

Closes: https://bugs.gentoo.org/641600
Bug: https://bugs.gentoo.org/641962
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
xmw committed Dec 22, 2017
1 parent 59f25d0 commit a08d031
Show file tree
Hide file tree
Showing 2 changed files with 89 additions and 2 deletions.
4 changes: 2 additions & 2 deletions app-backup/backintime/backintime-1.1.24.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,12 +3,12 @@

EAPI=6

PYTHON_COMPAT=( python3_{4,5} )
PYTHON_COMPAT=( python3_{4,5,6} )

inherit eutils python-single-r1 gnome2-utils

DESCRIPTION="Backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
HOMEPAGE="https://backintime.readthedocs.io/"
HOMEPAGE="https://backintime.readthedocs.io/ https://github.com/bit-team/backintime/"
SRC_URI="https://github.com/bit-team/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
Expand Down
87 changes: 87 additions & 0 deletions app-backup/backintime/backintime-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python3_{4,5,6} )

inherit eutils python-single-r1 gnome2-utils git-r3

DESCRIPTION="Backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
HOMEPAGE="https://backintime.readthedocs.io/ https://github.com/bit-team/backintime/"
EGIT_REPO_URI="https://github.com/bit-team/backintime/"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="qt5"

DEPEND="${PYTHON_DEPS}
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
net-misc/openssh
net-misc/rsync[xattr,acl]"
RDEPEND="${DEPEND}
qt5? ( dev-python/PyQt5 )"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

src_prepare() {
#fix doc install location
sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
-i common/configure || die
sed -e "s:/doc/${PN}-qt:/doc/${PF}:g" \
-i qt/configure || die
sed -e "/addInstallFile \"..\/VERSION/d" \
-e "/addInstallFile \"..\/LICENSE/d" \
-e "/addInstallFile \"..\/debian\/copyright/d" \
-i {qt,common}/configure || die

if [ -n ${LINGUAS+x} ] ; then
cd common/po || die
for po in *.po ; do
if ! has ${po/.po} ${LINGUAS} ; then
rm ${po} || die
fi
done
fi

default
}

src_configure() {
cd "${S}"/common || die
./configure --python3 --no-fuse-group || die
if use qt5 ; then
cd "${S}"/qt || die
./configure --python3 || die
fi
}

src_compile() {
cd "${S}"/common || die
emake
if use qt5 ; then
cd "${S}"/qt || die
emake
fi
}

src_install() {
cd "${S}"/common || die
emake DESTDIR="${D}" install
if use qt5 ; then
cd "${S}"/qt || die
emake DESTDIR="${D}" install
fi

python_optimize "${D}"
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit a08d031

Please sign in to comment.