Skip to content

Commit

Permalink
dev-libs/mimalloc: add 2.0.5
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Feb 18, 2022
1 parent 51afb34 commit a0a82cd
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/mimalloc/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mimalloc-1.7.3.tar.gz 908042 BLAKE2B 6a96fc33148261e3f69a55196725bb2cf2e45f08a668b3d74fd6e06f808c1ce40fbb4783c5df50abe58dbae8b9c1dd264e6fcc6cce0a259b2cbec397d4667736 SHA512 e5a17b98d77a27d2a544869c2e0302a7e3bf77b5b494b2ee8ddc7af18bf9da152fea41702a8a17eb7e128238259fba6f96fa5bac549f5927453dc9a0bc06d013
DIST mimalloc-1.7.5.tar.gz 1115414 BLAKE2B 2bd29cce80c0308409d14536533255f114f39edbadd7972eefc5ebb2d1e655c30340ffefadc572dad9ae5772a0bc6f105f346098520807a859b10230f3e3ec01 SHA512 76de3ffe8d935df55677cce2c68651516ed033f74bc3d1a1b8963cf5c6eb240b9464a5a00a820a88daf04fc7d8b9d2505f204d6365d5f49b5ababbb85a442b1e
DIST mimalloc-2.0.3.tar.gz 917461 BLAKE2B 4b803881ab75afa358cb2dd251268c0934472074bf1983c3851a9d4f8c8ec0ea3907b52c40b0efe1cc09916cf4c5aa93f786a606e0b999536118b91bb5800310 SHA512 275a5249d09a57c9a039714fc6eef24ae778496954972419f3ac8e33f3d12e9837ba0691a3c08a4ab807c26b868aad3a5b2c28ee10ecaa60fe21ffe1d416f08f
DIST mimalloc-2.0.5.tar.gz 1125567 BLAKE2B 9148ba4af7620eec36e1dde0f6fd2d1e3e9937bd2286ac790a727052402c3286b55387236de3a77e4405983c080bb7acae8deb3334cf9103fcf3f90250080204 SHA512 d164392ace523a3fa0aa00fc58d8a9e8fbe913f07957e19ca977675b389e6d2a2eaf4772e72cae0d87aabb960f3fd6ea3923a066ece4ba4fdaa0c6860cfa414d
36 changes: 36 additions & 0 deletions dev-libs/mimalloc/mimalloc-2.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="mimalloc is a compact general purpose allocator with excellent performance"
HOMEPAGE="https://github.com/microsoft/mimalloc"
SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0/2"
KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"

src_configure() {
local mycmakeargs=(
# TODO: build hardened variant?
#-DMI_SECURE=$(usex hardened)

-DMI_INSTALL_TOPLEVEL=ON
-DMI_BUILD_TESTS=$(usex test)
)

cmake_src_configure
}

src_install() {
cmake_src_install

rm "${ED}/usr/$(get_libdir)/mimalloc.o" || die

find "${ED}" -name '*.a' -delete || die
}

0 comments on commit a0a82cd

Please sign in to comment.