forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/cinnamon-control-center: fix build failure with timezone-…
…data-2015f North Korea caused build failure. Gentoo-Bug: 559052 Reported-by: Lara Maia Upstream-Bug-url: linuxmint/cinnamon-control-center#124 Package-Manager: portage-2.2.20.1
- Loading branch information
Showing
3 changed files
with
218 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST cinnamon-control-center-2.4.2.tar.gz 4305006 SHA256 7d25193a3cc13c12f22864f3c9a907acfaa616392cb2b7ab4e0624f0d200f188 SHA512 c3b4e5af84b7e6e01deaae51ed29e184158860c5effa2550b9d285902c2c35b690cb867ae747b437ed2ac2d0e75b0e6b36c97f9af3c5bf3f4621bdf304d5c253 WHIRLPOOL 41a32cb1c97f0fd3c57d67891c66082b66db6dc5a43737d50fdc6a17819c64d9b58ac2b679baa7f9bdd906643c02c161b4a72fd208b48561cdd43807a58f5621 | ||
DIST cinnamon-control-center-2.6.0-pyongyang.tar.xz 32912 SHA256 d26e31c1377abc1c3e47e1c8e78572e0169d21bdfddb920ab839bec4e1bbe8a7 SHA512 3c6d6a970382a8e0429cc78873e4d230d5848f2a6ae4feee4d28db28cb21124f59cd7b4632f3a427f91dd7e497ee32dd3f7ba5139a3c1566264904939007d28e WHIRLPOOL a1a4102ddb13e00414b58352c3eabbd02dc425f2b3a59027a579d9ac78bdd0fd7dcacc8c204ceaeb858944202af72bbfcecabb48aa1e7ddf4ff6ec4e682fb97d | ||
DIST cinnamon-control-center-2.6.0.tar.gz 4169903 SHA256 bbc39ac8ddcbc06b6aada1ef271f95f5f0d0fe439bec38b9cd847af420305c49 SHA512 ed383484b751a9d98de7f136c21c5eb6ce7cfe1418945bd0725aa9e9f08397eb78854b38db258434ed8895dbadd2ce29b5a423a9025dea17fb4876f8847ff125 WHIRLPOOL 7e6d3373e97116d5b531f4fcff85984050fd5d7ad343137b76e30089b3c6f4ff5409f68867289f3967a257a67cd04059f2aa02c48a4e0e4c29b43755d6f4cd84 |
110 changes: 110 additions & 0 deletions
110
gnome-extra/cinnamon-control-center/cinnamon-control-center-2.4.2-r3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,110 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GCONF_DEBUG="yes" | ||
GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen | ||
|
||
inherit autotools eutils gnome2 | ||
|
||
DESCRIPTION="Cinnamons's main interface to configure various aspects of the desktop" | ||
HOMEPAGE="http://cinnamon.linuxmint.com/" | ||
SRC_URI="https://github.com/linuxmint/cinnamon-control-center/archive/${PV}.tar.gz -> ${P}.tar.gz | ||
https://dev.gentoo.org/~tetromino/distfiles/${PN}/${PN}-2.6.0-pyongyang.tar.xz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="+colord +cups input_devices_wacom" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
# False positives caused by nested configure scripts | ||
QA_CONFIGURE_OPTIONS=".*" | ||
|
||
# FIXME: modemmanager is not optional | ||
# networkmanager is not optional | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.31:2 | ||
dev-libs/libxml2:2 | ||
>=gnome-base/libgnomekbd-2.91.91:0= | ||
>=gnome-extra/cinnamon-desktop-1.0:0= | ||
>=gnome-extra/cinnamon-menus-1.0:0= | ||
>=gnome-extra/cinnamon-settings-daemon-1.0:0= | ||
>=gnome-extra/nm-applet-0.9.8 | ||
media-libs/fontconfig | ||
>=media-libs/libcanberra-0.13[gtk3] | ||
>=media-sound/pulseaudio-1.1[glib] | ||
>=net-misc/modemmanager-0.7 | ||
>=net-misc/networkmanager-0.9.8[modemmanager] | ||
>=sys-auth/polkit-0.103 | ||
|| ( >=sys-power/upower-0.9.1:= sys-power/upower-pm-utils ) | ||
>=x11-libs/gdk-pixbuf-2.23.0:2 | ||
>=x11-libs/gtk+-3.4.1:3 | ||
>=x11-libs/libnotify-0.7.3:0= | ||
x11-libs/libX11 | ||
x11-libs/libxklavier | ||
colord? ( >=x11-misc/colord-0.1.8:0= ) | ||
cups? ( >=net-print/cups-1.4[dbus] ) | ||
input_devices_wacom? ( | ||
>=dev-libs/libwacom-0.7 | ||
>=x11-libs/gtk+-3.8:3 | ||
>=x11-libs/libXi-1.2 ) | ||
" | ||
# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x | ||
# libgnomekbd needed only for gkbd-keyboard-display tool | ||
RDEPEND="${COMMON_DEPEND} | ||
|| ( ( app-admin/openrc-settingsd sys-auth/consolekit ) >=sys-apps/systemd-31 ) | ||
x11-themes/gnome-icon-theme | ||
x11-themes/gnome-icon-theme-symbolic | ||
colord? ( >=gnome-extra/gnome-color-manager-3 ) | ||
cups? ( | ||
app-admin/system-config-printer | ||
net-print/cups-pk-helper ) | ||
input_devices_wacom? ( gnome-extra/cinnamon-settings-daemon[input_devices_wacom] ) | ||
" | ||
|
||
DEPEND="${COMMON_DEPEND} | ||
app-text/iso-codes | ||
x11-proto/xproto | ||
x11-proto/xf86miscproto | ||
x11-proto/kbproto | ||
dev-libs/libxslt | ||
>=dev-util/intltool-0.40.1 | ||
>=sys-devel/gettext-0.17 | ||
virtual/pkgconfig | ||
gnome-base/gnome-common | ||
" | ||
# Needed for autoreconf | ||
# gnome-base/gnome-common | ||
|
||
src_prepare() { | ||
# make some panels optional | ||
epatch "${FILESDIR}"/${PN}-2.2.5-optional.patch | ||
|
||
# Fix NM version checking, bug #536850 | ||
epatch "${FILESDIR}"/${PN}-2.4.2-networkmanager-version.patch | ||
|
||
# North Korea causes build failure | ||
cp "${WORKDIR}"/${PN}-2.6.0-pyongyang/*.png panels/datetime/data/ || die | ||
epatch "${WORKDIR}"/${PN}-2.6.0-pyongyang/*.patch | ||
|
||
epatch_user | ||
|
||
eautoreconf | ||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
# --enable-systemd doesn't do anything in $PN-2.2.5 | ||
gnome2_src_configure \ | ||
--disable-update-mimedb \ | ||
--disable-static \ | ||
--enable-documentation \ | ||
--without-libsocialweb \ | ||
$(use_enable colord color) \ | ||
$(use_enable cups) \ | ||
$(use_enable input_devices_wacom wacom) | ||
} |
107 changes: 107 additions & 0 deletions
107
gnome-extra/cinnamon-control-center/cinnamon-control-center-2.6.0-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,107 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GCONF_DEBUG="yes" | ||
GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen | ||
|
||
inherit autotools eutils gnome2 | ||
|
||
DESCRIPTION="Cinnamons's main interface to configure various aspects of the desktop" | ||
HOMEPAGE="http://cinnamon.linuxmint.com/" | ||
SRC_URI="https://github.com/linuxmint/cinnamon-control-center/archive/${PV}.tar.gz -> ${P}.tar.gz | ||
https://dev.gentoo.org/~tetromino/distfiles/${PN}/${PN}-2.6.0-pyongyang.tar.xz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="+colord +cups input_devices_wacom" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
# False positives caused by nested configure scripts | ||
QA_CONFIGURE_OPTIONS=".*" | ||
|
||
# FIXME: modemmanager is not optional | ||
# networkmanager is not optional | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.31:2 | ||
dev-libs/libxml2:2 | ||
>=gnome-base/libgnomekbd-2.91.91:0= | ||
>=gnome-extra/cinnamon-desktop-1.0:0= | ||
>=gnome-extra/cinnamon-menus-1.0:0= | ||
>=gnome-extra/cinnamon-settings-daemon-1.0:0= | ||
>=gnome-extra/nm-applet-0.9.8 | ||
media-libs/fontconfig | ||
>=media-libs/libcanberra-0.13[gtk3] | ||
>=media-sound/pulseaudio-1.1[glib] | ||
>=net-misc/modemmanager-0.7 | ||
>=net-misc/networkmanager-0.9.8[modemmanager] | ||
>=sys-auth/polkit-0.103 | ||
>=x11-libs/gdk-pixbuf-2.23.0:2 | ||
>=x11-libs/gtk+-3.4.1:3 | ||
>=x11-libs/libnotify-0.7.3:0= | ||
x11-libs/libX11 | ||
x11-libs/libxklavier | ||
colord? ( >=x11-misc/colord-0.1.14:0= ) | ||
cups? ( >=net-print/cups-1.4[dbus] ) | ||
input_devices_wacom? ( | ||
>=dev-libs/libwacom-0.7 | ||
>=x11-libs/gtk+-3.8:3 | ||
>=x11-libs/libXi-1.2 ) | ||
" | ||
# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x | ||
# libgnomekbd needed only for gkbd-keyboard-display tool | ||
RDEPEND="${COMMON_DEPEND} | ||
|| ( ( app-admin/openrc-settingsd sys-auth/consolekit ) >=sys-apps/systemd-31 ) | ||
x11-themes/gnome-icon-theme | ||
x11-themes/gnome-icon-theme-symbolic | ||
colord? ( >=gnome-extra/gnome-color-manager-3 ) | ||
cups? ( | ||
app-admin/system-config-printer | ||
net-print/cups-pk-helper ) | ||
input_devices_wacom? ( gnome-extra/cinnamon-settings-daemon[input_devices_wacom] ) | ||
" | ||
|
||
DEPEND="${COMMON_DEPEND} | ||
app-text/iso-codes | ||
x11-proto/xproto | ||
x11-proto/xf86miscproto | ||
x11-proto/kbproto | ||
dev-libs/libxslt | ||
>=dev-util/intltool-0.40.1 | ||
>=sys-devel/gettext-0.17 | ||
virtual/pkgconfig | ||
gnome-base/gnome-common | ||
app-arch/xz-utils | ||
" | ||
# Needed for autoreconf | ||
# gnome-base/gnome-common | ||
|
||
src_prepare() { | ||
# make some panels optional | ||
epatch "${FILESDIR}"/${PN}-2.6.0-optional.patch | ||
|
||
# North Korea causes build failure | ||
cp "${WORKDIR}"/${PN}-2.6.0-pyongyang/*.png panels/datetime/data/ || die | ||
epatch "${WORKDIR}"/${PN}-2.6.0-pyongyang/*.patch | ||
|
||
epatch_user | ||
|
||
eautoreconf | ||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
# --enable-systemd doesn't do anything in $PN-2.2.5 | ||
gnome2_src_configure \ | ||
--disable-static \ | ||
--enable-documentation \ | ||
--without-libsocialweb \ | ||
$(use_enable colord color) \ | ||
$(use_enable cups) \ | ||
$(use_enable input_devices_wacom wacom) | ||
} |