Skip to content

Commit

Permalink
dev-go/go-net: version bump to 0_pre20160216
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
zmedico committed Feb 20, 2016
1 parent f11552c commit a0d098f
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-go/go-net/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST go-net-0_pre20150804.tar.gz 539435 SHA256 77fb87becd3ddb68ff06acd3a1bf1246b390e7489b3e25a9ee9314f7457ccf60 SHA512 02a9734f8335909a15280e925b11ff03b96fbedd6e48fa5c3f869ab1a8b3062971d634f7043f92cee685c618222b147fdee915f1d5d83bd82cdde171970287e3 WHIRLPOOL a63befad593737449f393d7f4490b1680d8cba808f6163b9723b0d1d228480cdcbf9e2fb091ffc96f9121aabde1e24b06f3ddcb7b30e4bffa6e39dece5a8b3e0
DIST go-net-0_pre20160216.tar.gz 741192 SHA256 482a17771601dc706945eee7e0c3a339d57a140dc3cb8adaa86e99ef28a8ea71 SHA512 75db9098b33ede5621fce36645ebe946fad911c815dae219d74242b15714d1b9a3d8544f5f8c90b58989cea3a46b5688d20f705cb24a7d31f201ec218e69e78f WHIRLPOOL 2a7dca88766e6ba010ed6b274a48e7db5cfc9084cbc16f46e2806d59519f91b296d64dead8485f191aff50168bad5b4f62ac670d17b30b90850a9906d85c6708
44 changes: 44 additions & 0 deletions dev-go/go-net/go-net-0_pre20160216.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EGO_PN=golang.org/x/net/...
EGO_SRC=golang.org/x/net

if [[ ${PV} = *9999* ]]; then
inherit golang-vcs
else
KEYWORDS="~amd64"
EGIT_COMMIT="b6d7b1396ec874c3b00f6c84cd4301a17c56c8ed"
SRC_URI="https://github.com/golang/net/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
inherit golang-vcs-snapshot
fi
inherit golang-build

DESCRIPTION="Go supplementary network libraries"
HOMEPAGE="https://godoc.org/golang.org/x/net"
LICENSE="BSD"
SLOT="0/${PVR}"
IUSE=""
DEPEND="dev-go/go-crypto:=
dev-go/go-text:="
RDEPEND=""

src_prepare() {
# disable broken tests
sed -e 's:TestReadProppatch(:_\0:' \
-i src/${EGO_SRC}/webdav/xml_test.go || die
sed -e 's:TestPingGoogle(:_\0:' \
-e 's:TestNonPrivilegedPing(:_\0:' \
-i src/${EGO_SRC}/icmp/ping_test.go || die
}

src_compile() {
# Create a writable GOROOT in order to avoid sandbox violations.
cp -sR "$(go env GOROOT)" "${T}/goroot" || die
rm -rf "${T}/goroot/src/${EGO_SRC}" || die
rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
export GOROOT="${T}/goroot"
golang-build_src_compile
}

0 comments on commit a0d098f

Please sign in to comment.