Skip to content

Commit

Permalink
dev-util/catkin: bump to 0.7.8
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.4
  • Loading branch information
aballier committed Nov 4, 2017
1 parent ce55a69 commit a0fc02b
Show file tree
Hide file tree
Showing 2 changed files with 120 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/catkin/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST catkin-0.7.6.tar.gz 202970 SHA256 468725aadfd6b615cd7d7a75fca37777db987b6ad63f73062c3273bd96d380d6 SHA512 9f4ddef3cdef0f81aeb2abe27db797318f813e184d457f6f81439d3b539efe2e2726da7eda8359a803848c5e5f8a2f8fd291b6f2a00a16a06112d084c1ec14ce WHIRLPOOL 863f477d54dd2ed297ea94776102fd31ad68cba3550e2a17a3218acda889c0b1071c9df73f16224fc75445742294df46ba6a7eae20019bb01974bde17db9fab8
DIST catkin-0.7.7.tar.gz 203773 SHA256 0ab4efd1d42fc586ace5a37aba3c4266cff31593b39b7abe3ab6ced6b160e92f SHA512 616ff6a34ab52d50e383acdcebe66aa8f4ac1515ed3c654d75f32cdfe86ee3b87b17872ea2068ea5ddc5f35b73b5cf53c84c6e386d89ad2c8270228f1c446d01 WHIRLPOOL 40c901f74e39e6239d0967ce997d6ebc011063ed0208123d20e057a3bbd53e4dd7b70c6e8c4bfb31d7f0ae9e57292e17343565b68b9c441a5c10f7ff1dee6117
DIST catkin-0.7.8.tar.gz 203828 SHA256 f0e2f0548ca40fb401d5badfd34798b39fb1aa6c08d4d369fd9cbf44c638f129 SHA512 c3628c551c8a5a1e544f7816a5bdedf413217c6e1fc7bb612801d29fbb247660b35d634c26f8847ace8984482978a8b8bf72c3373fd1e2e0972917f206ee0605 WHIRLPOOL 6a81046365f821241656c811461859d35945cd558b45172c92c0b911878230443ad95b0445f351633b0ea0835e6dc5aee1b0b3ba506f03bee63754fed2b36ca0
119 changes: 119 additions & 0 deletions dev-util/catkin/catkin-0.7.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,119 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/ros/catkin"
fi

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )

inherit ${SCM} cmake-utils python-r1 python-utils-r1

DESCRIPTION="Cmake macros and associated python code used to build some parts of ROS"
HOMEPAGE="http://wiki.ros.org/catkin"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
else
SRC_URI="https://github.com/ros/catkin/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
${PYTHON_DEPS}
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/empy[${PYTHON_USEDEP}]
dev-util/cmake
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-python/mock[${PYTHON_USEDEP}] )"

PATCHES=(
"${FILESDIR}/tests.patch"
"${FILESDIR}/distutils.patch"
"${FILESDIR}/catkin_prefix_path.patch"
"${FILESDIR}/gnuinstalldirs.patch"
"${FILESDIR}/catkin_prefix_path_util_py.patch"
"${FILESDIR}/package_xml.patch"
"${FILESDIR}/etc.patch"
"${FILESDIR}/sitedir.patch"
)

src_prepare() {
# fix libdir
sed -i \
-e 's:LIBEXEC_DESTINATION lib:LIBEXEC_DESTINATION libexec:' \
-e 's:}/lib:}/${CMAKE_INSTALL_LIBDIR}:' \
-e 's:DESTINATION lib):DESTINATION ${CMAKE_INSTALL_LIBDIR}):' \
-e 's:DESTINATION lib/:DESTINATION ${CMAKE_INSTALL_LIBDIR}/:' \
-e 's:PYTHON_INSTALL_DIR lib:PYTHON_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}:' \
cmake/*.cmake || die
cmake-utils_src_prepare
}

catkin_src_configure_internal() {
local sitedir="$(python_get_sitedir)"
mycmakeargs+=(
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPYTHON_INSTALL_DIR="${sitedir#${EPREFIX}/usr/}"
)
python_export PYTHON_SCRIPTDIR
cmake-utils_src_configure
}

src_configure() {
export PYTHONPATH="${S}/python"
local mycmakeargs=(
"$(cmake-utils_use test CATKIN_ENABLE_TESTING)"
"-DCATKIN_BUILD_BINARY_PACKAGE=ON"
)
python_foreach_impl catkin_src_configure_internal
}

src_compile() {
python_foreach_impl cmake-utils_src_compile
}

src_test() {
unset PYTHON_SCRIPTDIR
python_foreach_impl cmake-utils_src_test
}

catkin_src_install_internal() {
python_export PYTHON_SCRIPTDIR
cmake-utils_src_install
if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
dodir /usr/bin
for i in "${D}/${PYTHON_SCRIPTDIR}"/* ; do
dosym ../lib/python-exec/python-exec2 "/usr/bin/${i##*/}" || die
done
touch "${T}/.catkin_python_symlinks_generated"
fi
}

src_install() {
python_foreach_impl catkin_src_install_internal

doenvd "${FILESDIR}/40catkin"

# needed to be considered as a workspace
touch "${ED}/usr/.catkin"
}

pkg_postinst() {
ewarn "Starting from version 0.7.1-r2, dev-util/catkin changed the"
ewarn "installation path for package.xml files on Gentoo."
ewarn "In order for ROS to work properly, you will need to reinstall ROS"
ewarn "packages that have it installed in the old location:"
ewarn " emerge -1O /usr/share/*/package.xml"
ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=595004 for more details."
}

0 comments on commit a0fc02b

Please sign in to comment.