Skip to content

Commit

Permalink
app-vim/jedi: version bump 0.10.0, bug #718262
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Horea Christian <[email protected]>
Closes: gentoo#15436
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
TheChymera authored and juippis committed Apr 26, 2020
1 parent be1e39f commit a0fd745
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/jedi/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST jedi-0.10.0.tar.gz 36820 BLAKE2B a66f7c58564487d83867d61480d83364af0047cee713c41dbd5c67bff0b2ac33d066c2d0f4367c30059f46fb9f4916fc8d2eb9c64aa6a489e2c16a03f56b0b3c SHA512 65482505446b1001e92870ae64a147b38c0bb4d3151e464d325be741729506a191b284a491f4c3eb77dc46cb9bcd6b8e7bf8689ed95107e89a1f6a05c7fbc9ea
DIST jedi-0.8_p20171015.tar.gz 31593 BLAKE2B a34fc7a7d8211cefbaef0012b801bc2dec2b447d34a1d3c338ed37306d36262694f0d8e771042e899959d04bed8925c5beee32803cb7f56add7a83ceb4bf27d9 SHA512 e4238c745d509d9d7e8c0593a46935f1de3c0cdf8e3893deb156110be53e2c9012d98379a6ca747a0bdab77f1def2a88dd46ce5c7d3936f01f0d9ab597f14182
39 changes: 39 additions & 0 deletions app-vim/jedi/jedi-0.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7,3_8} )

inherit vim-plugin python-any-r1

DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
HOMEPAGE="https://github.com/davidhalter/jedi-vim"
SRC_URI="https://github.com/davidhalter/jedi-vim/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
IUSE="test"

DEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/jedi[${PYTHON_USEDEP}]')
"
RDEPEND="app-editors/vim[python]"
BDEPEND="test? ( dev-python/pytest )"

S="${WORKDIR}/jedi-vim-${PV}"

# Tests are broken.
RESTRICT="test"

# Makefile tries hard to call tests so let's silence this phase.
src_compile() { :; }

src_install() {
vim-plugin_src_install
}

src_test() {
pytest -vv || die
}

0 comments on commit a0fd745

Please sign in to comment.