Skip to content

Commit

Permalink
net-p2p/airdcpp-webclient: version bump to 1.2.0.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
Closes: gentoo#2147

Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
sbraz authored and monsieurp committed Aug 26, 2016
1 parent eacfcb7 commit a1083b2
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-p2p/airdcpp-webclient/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-1.0.7.tar.gz 717747 SHA256 a98a7a478a99334ddb2ed91eef888cec2ee71601d894d16f100b35e7849f0265 SHA512 15501fa6e7f48241f27b2bbffb977731fe2fb35043ddd6d15575ba5fe29271548093098298a82c67d8f0b32a3194b5a14f1197053c39199612aebc1ab296e0c2 WHIRLPOOL 118ec35af049fdb6ffb24fcf97e1c9e47e6b9e66399dcc83a7137b5a3a8257b3015039f13d690e52d3dac3cacc7c450d6ff5cc13b4d55440a27b7c8b9de3c9cb
DIST airdcpp-webclient-1.1.0.tar.gz 722280 SHA256 bfd6cba9fedd1ffba92826ec80d0ee97e15a67baba9b55627b489cf54ae28c33 SHA512 ae23108e4ab7175fe84c5effad22974afd27b20f7aaa0b1013c51d87f54b30d86bd13dda12b3af19b8b4bb7996b8ad3895ffdd4ce7992c1505715eaeba2d5a87 WHIRLPOOL 121b3f5f4614bb2c39f475087b16c93451640d3a4d1a6abeae9fcf514d75cfd5c156ea3eefa28cc5bc1d0b1bb0c5c731ae31ec80fe547861b8e8bd96d404aaaf
DIST airdcpp-webclient-1.2.0.tar.gz 724103 SHA256 d85177c3183b93c9573dd325c67724b5e86ec50f50c4a6b00797f3b6d22caf98 SHA512 d84e9970f4e3c354bfd97b6b0a6a62657a05817f0444afc56717b0e77e1f15b4c3598f024a0f6c096e55e5b36230ffd25cbc7953131c293b386722871535fccb WHIRLPOOL 9fe690371cdc6ca56e2d8c8513dd83d8fd67a9c4a68ae625a8c14781cb17aa7bed31c7e0375c3180705ea7855aaa7f511bcfcf172d66ce2128364e6abf5fe9d7
63 changes: 63 additions & 0 deletions net-p2p/airdcpp-webclient/airdcpp-webclient-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit cmake-utils user

DESCRIPTION="Cross-platform Direct Connect client"
HOMEPAGE="https://airdcpp-web.github.io/"
SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

KEYWORDS="~amd64 ~x86"
LICENSE="GPL-2+"
SLOT="0"
IUSE="nat-pmp +tbb +webui"

RDEPEND="
app-arch/bzip2
dev-cpp/websocketpp
dev-libs/boost
dev-libs/geoip
dev-libs/leveldb
dev-libs/openssl:0=[-bindist]
net-libs/miniupnpc
sys-libs/zlib
virtual/libiconv
nat-pmp? ( net-libs/libnatpmp )
tbb? ( dev-cpp/tbb )
"
DEPEND="
dev-lang/python:*
virtual/pkgconfig
${RDEPEND}
"
PDEPEND="webui? ( www-apps/airdcpp-webui )"

src_configure() {
local mycmakeargs=(
-DINSTALL_WEB_UI=OFF
-DLIB_INSTALL_DIR=$(get_libdir)
)
cmake-utils_src_configure
}

src_install() {
newconfd "${FILESDIR}/airdcppd.confd" airdcppd
newinitd "${FILESDIR}/airdcppd.initd" airdcppd
keepdir /var/lib/airdcppd
fowners airdcppd:airdcppd /var/lib/airdcppd
cmake-utils_src_install
}

pkg_setup() {
enewgroup airdcppd
enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
}

pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog "Run 'airdcppd --configure' to set up ports and authentication"
fi
}

0 comments on commit a1083b2

Please sign in to comment.