Skip to content

Commit

Permalink
app-admin/consul: add 1.14.2
Browse files Browse the repository at this point in the history
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Dec 1, 2022
1 parent 20ebb57 commit a13b1eb
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/consul/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST consul-1.13.3-deps.tar.xz 251812624 BLAKE2B 0ce8fe76298defc83c174d1d02ee25b
DIST consul-1.13.3.tar.gz 25380333 BLAKE2B 6dbb8f3e9e3dd6b7e5192a6f050000cfb48a7730e63e474f2d24787608f21781b5f3810400b42f38ad93995d048fe41cc9643ffa3923c297699cc1a8e975a44d SHA512 a978e25f89b7fb9ebc56fd2857493559756981b6e63e57d74b2749af9cce44897b7b5dc136a38d5861296105bedcc591adef972e18edb02efec1952c2f67add9
DIST consul-1.14.0-vendor.tar.gz 39530717 BLAKE2B 62672e0383353bcccdfcaa25ffd7409b31d8ba650080f315d8a8b68d0be4afa60a12b45ec548be0ecd5a9a703c1888c781a985f1b67fe6128fd82f69a984c42a SHA512 a2ada95b7e890c3f466009a78fdd1dfb0aa46494583811531653230adf0ead98016d22cfdeba45d68e03a6aa7fe711660c17c438c6c9038cbc732021ec011e7a
DIST consul-1.14.1-vendor.tar.gz 39669654 BLAKE2B bb4fbe3df71354ee46d5a08e532226f2a0cfd8f5eb46b20a9ba5a324e1166a64a9b6cd3e44c5eebbd16c3bd4ff6a72b3afbfe117b7cd1b7fc5b9bf68cf58aa73 SHA512 9bfef09a7df0a0d4230d7e25ba113b985a29532240f235592af480867fb2c803671e2ed6563bbb7f07c64c15a8b1a5b00a9a05151387a01049067a75ffade169
DIST consul-1.14.2-vendor.tar.gz 40549325 BLAKE2B af0135de2b781d69707246a8f7f48fb677d3b9cfff59ee95ae6c37cdbe634bc04c2e853ce3dd2f70bd9a7a1d72438cdcd382939a5e361e152180c7ae1905bf85 SHA512 8e4d160993272a99901b83821b2e29686a53c2700a3e9e2355080eaa15d74f0a0d8f0d8ff86f08a131549cb3e70f77f59da302bb3f6f6b7a367c2ccd6f3ccfd2
57 changes: 57 additions & 0 deletions app-admin/consul/consul-1.14.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit go-module systemd

DESCRIPTION="A tool for service discovery, monitoring and configuration"
HOMEPAGE="https://www.consul.io"
GIT_COMMIT="cac392a17d3f71048a949599a0f977bf9645df62"

SRC_URI="https://github.com/zmedico/consul/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"

LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
RESTRICT+=" test"
SLOT="0"
KEYWORDS="~amd64 ~arm64"

BDEPEND="dev-go/gox"
COMMON_DEPEND="
acct-group/consul
acct-user/consul"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"

S=${WORKDIR}/${P}-vendor

src_prepare() {
default
sed -e 's|^GIT_DATE=.*|GIT_DATE=2022-11-30T19:54:31Z|' -i GNUmakefile || die
}

src_compile() {
# The dev target sets causes build.sh to set appropriate XC_OS
# and XC_ARCH, and skips generation of an unused zip file,
# avoiding a dependency on app-arch/zip.
GIT_DESCRIBE="v${PV}" \
GIT_DIRTY="" \
GIT_COMMIT="${GIT_COMMIT}" \
emake dev-build
}

src_install() {
dobin bin/consul

keepdir /etc/consul.d
insinto /etc/consul.d
doins "${FILESDIR}/"*.json.example

keepdir /var/log/consul
fowners consul:consul /var/log/consul

newinitd "${FILESDIR}/consul.initd" "${PN}"
newconfd "${FILESDIR}/consul.confd" "${PN}"
insinto /etc/logrotate.d
newins "${FILESDIR}/${PN}.logrotated" "${PN}"
systemd_dounit "${FILESDIR}/consul.service"
}

0 comments on commit a13b1eb

Please sign in to comment.